Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

EIGRP Flapping (retry limit exceeded) ???

Hi All,

This morning we're seeing EIGRP flap between 10.108.255.1 and 10.108.255.2 and nothing has changed on the network.

Topology:

[10.108.255.1(ASR)] --> [Nexus 5K] --> [3750] --> [10.108.255.2]

Logs on 10.108.255.1:

Mar  9 11:26:23.435 AEDT: %DUAL-5-NBRCHANGE: EIGRP-IPv4 15: Neighbor 10.108.255.2 (Port-channel1.851) is down: retry limit exceeded

Mar  9 11:26:24.107 AEDT: %DUAL-5-NBRCHANGE: EIGRP-IPv4 15: Neighbor 10.108.255.2 (Port-channel1.851) is up: new adjacency

Mar  9 11:27:43.610 AEDT: %DUAL-5-NBRCHANGE: EIGRP-IPv4 15: Neighbor 10.108.255.2 (Port-channel1.851) is down: retry limit exceeded

Mar  9 11:27:43.730 AEDT: %DUAL-5-NBRCHANGE: EIGRP-IPv4 15: Neighbor 10.108.255.2 (Port-channel1.851) is up: new adjacency

Mar  9 11:29:03.233 AEDT: %DUAL-5-NBRCHANGE: EIGRP-IPv4 15: Neighbor 10.108.255.2 (Port-channel1.851) is down: retry limit exceeded

Mar  9 11:29:05.917 AEDT: %DUAL-5-NBRCHANGE: EIGRP-IPv4 15: Neighbor 10.108.255.2 (Port-channel1.851) is up: new adjacency

I've read through the various EIGRP troubleshooting guides online but can't narrow it down to what's causing this.

I believe it's a multicast issue somewhere within the network, but not sure how to diagnose where the issue is exactly.

1/ Unicast ping end-to-end works

From 10.108.255.1, we can ping 10.108.255.2 with small and large packet sizes.

Unfortuantely we don't have access to 10.108.255.2 so can't repeat the process the other way.

2/ Multicast ping fails

From 10.108.255.1, doing a multicast ping 224.0.0.10, we don't get any replies from 10.108.255.2 - so I think this is what the issue is.

My question is - how do I check where multicast is failing???

Config:

\\ 10.108.255.1

router eigrp 15

!

address-family ipv4 vrf Internal autonomous-system 15

  redistribute bgp 64655 metric 10000 100 255 1 1500

  network 10.108.255.0 0.0.0.3

  passive-interface default

  no passive-interface Port-channel1.851

!

interface Port-channel1.851

encapsulation dot1Q 851

ip vrf forwarding Internal

ip address 10.108.255.1 255.255.255.252

no ip redirects

no ip unreachables

no ip route-cache

\\ 10.108.255.2

interface FastEthernet0/0

description Connects to 3750:Gi1/0/6

ip address 10.108.255.2 255.255.255.252

speed 100

full-duplex

!

router eigrp 15

redistribute static

redistribute ospf 80 metric 1000 10 255 1 1500

passive-interface Serial0/0.1

network 10.0.0.0

network 157.128.0.0

no auto-summary

eigrp log-neighbor-changes

\\ 3750

interface GigabitEthernet1/0/6

switchport access vlan 851

switchport mode access

load-interval 30

speed 100

duplex full

spanning-tree portfast

Thanks.

Andy

6 REPLIES
New Member

Re: EIGRP Flapping (retry limit exceeded) ???

I had this problem using 3760 switches.  I found that the default for "system mtu routing" was 1998 in the IOS I was running.  Setting the value to 1500 solved the problem and upgrading the IOS resolved it permanently.

Re: EIGRP Flapping (retry limit exceeded) ???

Hello

I would aggree check you mtu settings for the eigrp relationship

Also

My question is - how do I check where multicast is failing???

access-list 100 permit ip host 10.108.255.1 host 224.0.0.10

debug ip packet detail 100

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.

Please don't forget to rate any posts that have been helpful. Thanks.

Re: EIGRP Flapping (retry limit exceeded) ???

Andy,

Can you run 'debug eigrp packets hello', and verify that multicast update packets are being send and or received on each end?

New Member

EIGRP Flapping (retry limit exceeded) ???

Andy, hi

did you resolve this problem

I have the same issue

Every 80 seconds EIGRP is DOWN

Dec 25 15:49:47: %DUAL-5-NBRCHANGE: EIGRP-IPv4 101: Neighbor 10.201.0.2 (POS3/0/0) is up: new adjacency

Dec 25 15:51:06: %DUAL-5-NBRCHANGE: EIGRP-IPv4 101: Neighbor 10.201.0.2 (POS3/0/0) is down: retry limit exceeded

Dec 25 15:51:07: %DUAL-5-NBRCHANGE: EIGRP-IPv4 101: Neighbor 10.201.0.2 (POS3/0/0) is up: new adjacency

Dec 25 15:52:26: %DUAL-5-NBRCHANGE: EIGRP-IPv4 101: Neighbor 10.201.0.2 (POS3/0/0) is down: retry limit exceeded

Dec 25 15:52:26: %DUAL-5-NBRCHANGE: EIGRP-IPv4 101: Neighbor 10.201.0.2 (POS3/0/0) is up: new adjacency

Dec 25 15:53:46: %DUAL-5-NBRCHANGE: EIGRP-IPv4 101: Neighbor 10.201.0.2 (POS3/0/0) is down: retry limit exceeded

New Member

I experienced EIGRP flapping

I experienced EIGRP flapping between an 1841 ISR and an 3550 switch.  here is what made the flapping go away! " I added on the 3550 switch the following entry on my interface that my 1841 was trying to talk with: 

"ip information-reply"

 

sw1#sh run int fa0/1
Building configuration...

Current configuration : 150 bytes
!
interface FastEthernet0/1
 description 1841_ISR
 no switchport
 ip address 10.0.0.2 255.255.255.0
 ip information-reply
 speed 10
 duplex half
end

EIGRP worked correctly following this change.  Hope it helps someone.

New Member

Hi, 

Hi, 
I faced this problem when running eigrp over DMVPN tunnel interface. Where the updates are flowing from hub to spoke but spoke is just sending Hellos to hub.
The actual problem is the MTU where I have set MTU to 1400 bytes considering the encryption along with GRE header, but only used GRE.
When I set the MTU to 1476 on both HUB and SPOKE, the issue is resolved.
Please note that this is a lab scenario with 7200 series routers running IOS: Version 15.0(1)M
DMVPN_HUB(config)#interface Tunnel0
DMVPN_HUB(config-if)#ip address 192.168.0.2 255.255.255.0
DMVPN_HUB(config-if)#ip mtu 1400
DMVPN_HUB(config-if)#ip nhrp authentication donttell
DMVPN_HUB(config-if)#ip nhrp map multicast dynamic
DMVPN_HUB(config-if)#ip nhrp network-id 99
DMVPN_HUB(config-if)#tunnel source FastEthernet1/0
DMVPN_HUB(config-if)#tunnel mode gre multipoint
DMVPN_HUB(config-if)#tunnel key 100000
*May 7 14:01:12.211: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 192.168.0.4 (Tunnel0) is down: retry limit exceeded
DMVPN_HUB#
*May 7 14:01:13.443: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 192.168.0.4 (Tunnel0) is up: new adjacency
DMVPN_HUB#
*May 7 14:02:32.963: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 192.168.0.4 (Tunnel0) is down: retry limit exceeded
DMVPN_HUB#
*May 7 14:02:36.307: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 192.168.0.4 (Tunnel0) is up: new adjacency
 DMVPN_HUB(config)#int tu0
DMVPN_HUB(config-if)#no ip mtu 1400
DMVPN_HUB(config-if)#ip mtu 1476
DMVPN_HUB#
*May 7 14:26:15.091: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 192.168.0.4 (Tunnel0) is up: new adjacency
DMVPN_HUB#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/156160] via 192.168.12.1, 00:13:49, FastEthernet0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/27010560] via 192.168.0.4, 00:00:30, Tunnel0
4.0.0.0/32 is subnetted, 1 subnets
D 4.4.4.4 [90/27008000] via 192.168.0.4, 00:00:30, Tunnel0
D 192.168.34.0/24 [90/26882560] via 192.168.0.4, 00:00:30, Tunnel0
9926
Views
4
Helpful
6
Replies