Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

EIGRP/IBGP recursion error routing

How do I solve this?

Error messages:

*Mar  1 15:20:57.356: RT: recursion error routing 2.2.2.2 - probable routing loop

*Mar  1 15:20:08.912: %BGP-5-ADJCHANGE: neighbor 3.3.3.3 Down Peer closed the session

--More--

*Mar  1 15:20:21.928: RT: del 4.4.4.0/24 via 4.4.4.4, bgp metric [200/0]

*Mar  1 15:20:21.932: RT: delete subnet route to 4.4.4.0/24

*Mar  1 15:20:21.932: RT: NET-RED 4.4.4.0/24

*Mar  1 15:20:21.948: RT: Try lookup less specific 4.4.4.0/24, default 1

*Mar  1 15:20:21.948: RT: Found major net on less specific 4.0.0.0/8

My topology and configuration:

------------------------------------------------

R2 interface s0/0 is connected to R4 at interface s0/0

R2 interface f0/1 is connected to R3 at interface f0/1

R3 interface s0/0 is connected to R5 at interface s0/0

R4 inteface f0/0 is connected to f0/0 at interface f0/0

R2

----

interface Loopback0

ip address 2.2.2.2 255.255.255.0

!

interface FastEthernet0/0

ip address 192.168.10.2 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

ip address 192.168.13.2 255.255.255.0

clock rate 2000000

!

interface FastEthernet0/1

ip address 192.168.12.2 255.255.255.0

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

clock rate 2000000

!

interface Serial0/2

no ip address

shutdown

clock rate 2000000

!

router eigrp 1

network 2.2.2.0 0.0.0.255

network 192.168.12.0

network 192.168.13.0

auto-summary

!

router bgp 2

no synchronization

bgp log-neighbor-changes

network 2.2.2.0 mask 255.255.255.0

neighbor 3.3.3.3 remote-as 2

neighbor 3.3.3.3 update-source Loopback0

neighbor 4.4.4.4 remote-as 2

neighbor 4.4.4.4 update-source Loopback0

neighbor 192.168.10.1 remote-as 1

no auto-summary

R3

----

interface Loopback0

ip address 3.3.3.3 255.255.255.0

!

interface FastEthernet0/0

ip address 192.168.11.3 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

ip address 192.168.14.3 255.255.255.0

clock rate 2000000

!

interface FastEthernet0/1

ip address 192.168.12.3 255.255.255.0

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

clock rate 2000000

!

interface Serial0/2

no ip address

shutdown

clock rate 2000000

!

router eigrp 1

network 3.3.3.0 0.0.0.255

network 192.168.12.0

network 192.168.14.0

auto-summary

!

router bgp 2

no synchronization

bgp log-neighbor-changes

network 3.3.3.0 mask 255.255.255.0

neighbor 2.2.2.2 remote-as 2

neighbor 2.2.2.2 update-source Loopback0

neighbor 5.5.5.5 remote-as 2

neighbor 5.5.5.5 update-source Loopback0

neighbor 192.168.11.1 remote-as 1

no auto-summary

R4

----

interface Loopback0

ip address 4.4.4.4 255.255.255.0

!

interface FastEthernet0/0

ip address 192.168.15.4 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

ip address 192.168.13.4 255.255.255.0

clock rate 2000000

!

interface FastEthernet0/1

ip address 192.168.16.4 255.255.255.0

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

clock rate 2000000

!

interface Serial0/2

no ip address

shutdown

clock rate 2000000

!

router eigrp 1

network 4.4.4.0 0.0.0.255

network 192.168.13.0

network 192.168.15.0

auto-summary

!

router bgp 2

no synchronization

bgp log-neighbor-changes

network 4.4.4.0 mask 255.255.255.0

neighbor 2.2.2.2 remote-as 2

neighbor 2.2.2.2 update-source Loopback0

neighbor 5.5.5.5 remote-as 2

neighbor 5.5.5.5 update-source Loopback0

neighbor 192.168.16.6 remote-as 3

no auto-summary

R5

---

interface Loopback0

ip address 5.5.5.5 255.255.255.0

!

interface FastEthernet0/0

ip address 192.168.15.5 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

ip address 192.168.14.5 255.255.255.0

clock rate 2000000

!

interface FastEthernet0/1

ip address 192.168.17.5 255.255.255.0

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

clock rate 2000000

!

interface Serial0/2

no ip address

shutdown

clock rate 2000000

!

router eigrp 1

network 5.5.5.0 0.0.0.255

network 192.168.14.0

network 192.168.15.0

auto-summary

!

router bgp 2

no synchronization

bgp log-neighbor-changes

network 5.5.5.0 mask 255.255.255.0

neighbor 3.3.3.3 remote-as 2

neighbor 3.3.3.3 update-source Loopback0

neighbor 4.4.4.4 remote-as 2

neighbor 4.4.4.4 update-source Loopback0

no auto-summary

Everyone's tags (6)
1 ACCEPTED SOLUTION

Accepted Solutions

EIGRP/IBGP recursion error routing

Hello.

The issue is: you are using auto-summary under EIGRP rocess; solution - use "no auto-summary"

PS: the error says that route to neighbor was learnt over BGP itself; in scenario I would better use neighbor physical interface address than loopback.

2 REPLIES

EIGRP/IBGP recursion error routing

Hello.

The issue is: you are using auto-summary under EIGRP rocess; solution - use "no auto-summary"

PS: the error says that route to neighbor was learnt over BGP itself; in scenario I would better use neighbor physical interface address than loopback.

EIGRP/IBGP recursion error routing

Hello,

I believe MilkailovskyVV is correct with the solution. Let me explain why I think you are seeing this. Below is your basic routing config for each router

router eigrp 1

network 2.2.2.0 0.0.0.255

network 192.168.12.0

network 192.168.13.0

auto-summary

!

router bgp 2

no synchronization

bgp log-neighbor-changes

network 2.2.2.0 mask 255.255.255.0

neighbor 3.3.3.3 remote-as 2

neighbor 3.3.3.3 update-source Loopback0

neighbor 4.4.4.4 remote-as 2

neighbor 4.4.4.4 update-source Loopback0

neighbor 192.168.10.1 remote-as 1

no auto-summary

Since auto-summary is on under EIGRP, the 2.2.2.0 /24 network will be auto-summarized across different major networks. It is passing between 192.168.X.X, so it will be summarizzed. Therefore, your routers will see 2.0.0.0/8.

Now here comes BGP. Your neighbors are linked to the loopback interface. In this example your 2.2.2.X Interface. Initially, your BGP comes up, but then it see's your advertisement "network 2.2.2.0 mask 255.255.255.0". Now your router will have two entries in the routing table, one from EIGRP (2.0.0.0 /8), and one for BGP (2.2.2.0 /24). Which route will it use to try and communicate with your BGP neighbor? The most specific, which happens to be advertised by the BGP neighbor. So you have the router trying to get to 2.2.2.0/24 by 2.2.2.2, this is where the recursive lookup comes from, it no longer is looking at the EIGRP route, since the one via BGP is more specific. Hope this makes sense.

-GH

471
Views
0
Helpful
2
Replies
CreatePlease to create content