Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

EIGRP Issue

Hi All,

   Ok, we got two routers on a site to site VPN tunnel. Tunnel is up and EIGRP is talking. The problem is on Router B it's not getting the correct route(s). Take a look at the output below. Any help is greatly appreciated!

Router A

=======

router eigrp 88

passive-interface FastEthernet0/0

passive-interface FastEthernet0/1

passive-interface FastEthernet0/0/0

network 3.3.3.0 0.0.0.3

network 10.125.177.0 0.0.0.255

no auto-summary

#sh ip route

     3.0.0.0/30 is subnetted, 1 subnets

C       3.3.3.0 is directly connected, Tunnel0

     65.0.0.0/27 is subnetted, 1 subnets

C       65.211.235.128 is directly connected, FastEthernet0/0/0

     10.0.0.0/24 is subnetted, 3 subnets

D       10.19.121.0 [90/26882560] via 3.3.3.2, 00:12:36, Tunnel0

S       10.25.178.0 [1/0] via 10.25.177.254

C       10.25.177.0 is directly connected, FastEthernet0/0

S*   0.0.0.0/0 [1/0] via 65.211.235.145

Router B

=======

passive-interface FastEthernet0/0

passive-interface FastEthernet0/1

passive-interface FastEthernet0/0/0

network 3.3.3.0 0.0.0.3

network 10.19.121.0 0.0.0.255

no auto-summary

#sh ip route

     3.0.0.0/30 is subnetted, 1 subnets

C       3.3.3.0 is directly connected, Tunnel0

     64.0.0.0/29 is subnetted, 1 subnets

C       64.60.196.32 is directly connected, FastEthernet0/0/0

     10.0.0.0/24 is subnetted, 1 subnets

C       10.19.121.0 is directly connected, FastEthernet0/0

S*   0.0.0.0/0 [1/0] via 64.60.196.33

----------------------------------------------------------------------------------------------------------------------

Notice on Router B we don't see an EIGRP route to Router A's internal subnet.... *confused....

Thanks,

Tom

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: EIGRP Issue

Tom

I believe that your problem is a typo on router A. You have configured under router eigrp

network 10.125.177.0 0.0.0.255

this has an extra digit in the second octet that prevents it from matching the LAN address.

HTH

Rick

3 REPLIES
Purple

Re: EIGRP Issue

Hi,

Could you post sh ip eigrp topology as well as sh run | s router eigrp on both routers.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Hall of Fame Super Silver

Re: EIGRP Issue

Tom

I believe that your problem is a typo on router A. You have configured under router eigrp

network 10.125.177.0 0.0.0.255

this has an extra digit in the second octet that prevents it from matching the LAN address.

HTH

Rick

Hall of Fame Super Silver

EIGRP Issue

Tom

According to the output of show ip route in your original post the network is

C       10.25.177.0 is directly connected, FastEthernet0/0

So the entry in EIGRP says the second octet is 125 and the show up route says the second octet is 25. That is what I mean that the second octet is wrong.

HTH

Rick

240
Views
0
Helpful
3
Replies
CreatePlease to create content