Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

EIGRP passive-interfaces on multiaccess network

Guys,

If I have 4 routers on the same LAN, and I want to passive one of them from the other 3? is the only way to do this via a filter acl?

Or can you specify an IP address on a passive command?

Many thx

Ken

1 ACCEPTED SOLUTION

Accepted Solutions

Re: EIGRP passive-interfaces on multiaccess network

Ken,

When the passive-interface command is used in EIGRP, the router cannot form neighbor adjacencies on the interface, or send or receive routing updates. However, if you want the outgoing routing updates alone be suppressed but the inbound updates continue to be received (and the routers still continue to be neighbors), then use the distribute-list command as follows:

R1(config)# access-list 20 deny any

R1(config)# router eigrp 1

R1(config-router)# distribute-list 20 out fa0/0

check out the link for more details

http://www.cisco.com/en/US/partner/tech/tk365/technologies_tech_note09186a0080093f0a.shtml

However when you run RIP you can achieve this with the neighbor command

interface fa 0/0

ip address 172.16.100.3 255.255.255.0

router rip

network 172.16.100.0

passive-interface fa 0/0

neighbor 172.16.100.1

neighbor 172.16.100.2

HTH, rate if it does

Narayan

1 REPLY

Re: EIGRP passive-interfaces on multiaccess network

Ken,

When the passive-interface command is used in EIGRP, the router cannot form neighbor adjacencies on the interface, or send or receive routing updates. However, if you want the outgoing routing updates alone be suppressed but the inbound updates continue to be received (and the routers still continue to be neighbors), then use the distribute-list command as follows:

R1(config)# access-list 20 deny any

R1(config)# router eigrp 1

R1(config-router)# distribute-list 20 out fa0/0

check out the link for more details

http://www.cisco.com/en/US/partner/tech/tk365/technologies_tech_note09186a0080093f0a.shtml

However when you run RIP you can achieve this with the neighbor command

interface fa 0/0

ip address 172.16.100.3 255.255.255.0

router rip

network 172.16.100.0

passive-interface fa 0/0

neighbor 172.16.100.1

neighbor 172.16.100.2

HTH, rate if it does

Narayan

320
Views
5
Helpful
1
Replies
CreatePlease login to create content