Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

EIGRP Question

I have two switches, switch1 and switch2, plugged into each other with a layer2 trunk link. I also have a 3rd switch, switch3, plugged into both those switches with a L3 link, all switches are running eigrp.

My question is, I've set up a /32 address on the loopback interface on switch2, and added it to the eigrp AS...now i want switch1's route to that address to go over the layer 2 interface since it's directly attached...however it only learns the route to that network from switch3 since it's connected with a routed interface. How can I make that work without setting up a static route from switch2 to one of the SVI's on switch1? Both switches are running HSRP on all the vlans...

Or is the static route really the best way of getting around it?

14 REPLIES

Re: EIGRP Question

This is an interesting topology.

If you do a show ip eigrp neighbor on Sw1 or Sw2, do you see any adjacencies that run across the trunk?

Think of the trunk is as a set of LAN segments, one segment for each VLAN. For those VLANs that have an SVI in Sw1 and in Sw2, I think you should see an EIGRP adjacency between the SVIs.

If you do have such adjacencies, (SVI <--> SVI between Sw1 and Sw2) what are their metrics, compared with the metrics through the two links through Sw3?

If you don't have such adjacencies, that would explain why Sw1 needs to go through Sw3 to get to the new loopback interface. You would need to include at least one SVI in the EIGRP on both Sw1 and Sw2.

Kevin Dorrell

Luxembourg

Re: EIGRP Question

Best thing would be to create a seperate VLAN and assign a /30 subnet to the SVI on both the switches

Enable EIGRP on this SVI and make sure it is allowed on the trunk links between SW1 and SW2

Congratulations Kevin on your CCIE !!!

Narayan

Re: EIGRP Question

Thank you Narayan!

That is a neat solution you are suggesting: to create a seperate /30 VLAN to carry the L3 traffic between Sw1 and Sw2. The alternative is to piggy-back it over one of the exsting VLANs, but your solution is definitely more elegant.

Kevin Dorrell

Luxembourg

New Member

Re: EIGRP Question

Thanks for the replies guys.

All the SVI's are on both switches (they're pretty much identically configured)...and all are running in HSRP. All the SVI's also show up in ip eigrp nei...

I tried adding delay 100 to the etherchannel between switch2 and switch3, after doing that the route was properly added to switch2 to go over the SVI's on switch1.

In show ip eigrp nei I do show the SRTT is in it's teens for the SVI's on but the interface to switch3 SRTT is 1.

I should also add that there's another switch (I'll call it switch4), plugged into switch1 with a layer 3 connection. Switch2 sees the route to the network on switch4 over the SVI's on switch1, not over the L3 interface like it does for the loopback interface.

Why would it route the loopback network over switch3 but route the switch4 network properly over switch1?

Hall of Fame Super Bronze

Re: EIGRP Question

You've done an excellent troubleshooting step on playing with delay.

The answer is there, you have different paths to reach a destination but not all paths have the same metrics. The lower the metric the preferred the route.

You should continue troubleshooting the 'why' (which you've done successfully) by typing the command show ip eigrp topology [ip address subnet].

With that command, you can see the routes in the eigrp table and which is the best route, 2nd best route, etc. It also tells you the bandwidth and delay associated to each route.

HTH,

__

Edison.

New Member

Re: EIGRP Question

In ip eigrp topo x.x.x.x/32 I see that the minimum bandwidth metrics don't match the bandwidth of the links. The L3 interface between SW2 and SW3 shows minimum bandwidth 5000000 and the L2 trunk between SW1 and SW2 shows 1000000 for each SVI.

Both those etherchannels have 4 ports...and I verified the bandwidth is 4000000Kbits in sho int po x on both those links...so I guess the question now is why are the minimum bandwidth metrics different in t he eigrp topology??

Hall of Fame Super Bronze

Re: EIGRP Question

That's odd. When configuring an interface is always best practice to manually apply the bandwidth command to avoid this kind of issues.

If you do so, does it report the correct bandwidth under the eigrp topology ?

__

Edison.

New Member

Re: EIGRP Question

Nope I just tried manually applying bandwidth settings to the etherchannel interfaces, I still get the same thing.

Here's the output (PO5 is the L3 interface to Switch3 and PO6 is the L2 trunk to Switch1):

IP-EIGRP (AS 150): Topology entry for 10.20.20.1/32

State is Passive, Query origin flag is 1, 1 Successor(s), FD is 129024

Routing Descriptor Blocks:

x.x.x.x (Port-channel5), from x.x.x.x, Send flag is 0x0

Composite metric is (129024/128768), Route is Internal

Vector metric:

Minimum bandwidth is 5000000 Kbit

Total delay is 5020 microseconds

Reliability is 255/255

Load is 1/255

Minimum MTU is 1500

Hop count is 2

x.x.x.x (Vlan13), from x.x.x.x, Send flag is 0x0

Composite metric is (130816/128256), Route is Internal

Vector metric:

Minimum bandwidth is 1000000 Kbit

Total delay is 5010 microseconds

Reliability is 255/255

Load is 1/255

Minimum MTU is 1500

Hop count is 1

x.x.x.x (Vlan204), from x.x.x.x, Send flag is 0x0

Composite metric is (130816/128256), Route is Internal

Vector metric:

Minimum bandwidth is 1000000 Kbit

Total delay is 5010 microseconds

Reliability is 255/255

Load is 1/255

Minimum MTU is 1500

Hop count is 1

x.x.x.x (Vlan203), from x.x.x.x, Send flag is 0x0

Composite metric is (130816/128256), Route is Internal

Vector metric:

Minimum bandwidth is 1000000 Kbit

Total delay is 5010 microseconds

Reliability is 255/255

Load is 1/255

Minimum MTU is 1500

Hop count is 1

Switch2# sh int po 5 | i BW

MTU 1500 bytes, BW 4000000 Kbit, DLY 10 usec,

Switch2# sh int po 6 | i BW

MTU 1500 bytes, BW 4000000 Kbit, DLY 10 usec,

New Member

Re: EIGRP Question

Ok...I think eigrp is taking into account the bandwidth of the SVI itself which is 1Gb...so when I add bandwidth 4000000 to an SVI on switch2, the primary route goes over the layer 2 etherchannel port.

Is that how it's supposed to behave? What's generally the best way of doing this? should I just create a "fake" SVI like Narayan suggested on both switches with HSRP and set the bandwidth to 4000000?

Re: EIGRP Question

I would recommend that, but don't put HSRP on that SVI. If there are no hosts on that VLAN, (and there shouldn't be), there is no advantage to putting HSRP, and it may actually confuse things.

Certainly the bandwidth configured on the SVI will affect the EIGRP. As far as the EIGRP is concerned, that is the interface that is receiving the advertisment.

Kevin Dorrell

Luxembourg

Re: EIGRP Question

What about the link between SW3 and SW1? The minimum bandwidth of the path has to consider all the links in the path; it is literally the bandwidth of the weakest link.

Check the configured bandwidth at both ends of each link as well. I cannot remember off the top of my head whether it is the bandwidth at the receive end of each link or the transmit end that goes into this calculation. (Can someone remind me please before I have to lab it up to find out!?)

Kevin Dorrell

Luxembourg

Re: EIGRP Question

EIGRP considers the bandwidth of the outgoing interface i.e the transmit end into its calculation

Narayan

Re: EIGRP Question

Narayan,

Thank you. Outgoing from the p.o.v. of the data packets, I presume, rather than the p.o.v. of the updates. So, I can think of it like OSPF, which advertises an LSA with its transmit cost to each attached network.

I think I'm going to lab up some scenarios with asymmetric routing to see if I can work out whether there are any unstable topologies, and if not, why not.

Kevin Dorrell

Luxembourg

New Member

Re: EIGRP Question

Thanks guys. I'll set up the /30 svi's on the switches tonight and see how it works...I'm sure it will work fine since changing the bw on the production svi's did the trick (although i changed them back).

1001
Views
14
Helpful
14
Replies
CreatePlease to create content