Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

EIGRP routing

The issue is to configure routers with EIGRP to send only desired routes. I heard this is somehow done through prefix lists and route map, but I dont know exactly. Has anyone dealt with it? Or can anyone suggest any links with configuration guide?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: EIGRP routing

Ypu would be required to use distribute lists for filtering routes from advertising.

The distribute-list can reference an access-list or prefix-list

eg. say R1<--->R2 R1 runs eigrp on all its interfaces but needs to send routing updates only for loopback1

R1

interface Loopback1

ip address 1.1.1.1 255.255.255.0

!

interface Loopback2

ip address 2.2.2.2 255.255.255.0

!

interface FastEthernet0/0

ip address 10.10.10.1 255.255.255.0

router eigrp 1

network 1.0.0.0

network 2.0.0.0

network 10.0.0.0

distribute-list prefix test out

no auto-summary

ip prefix-list test seq 10 permit 1.1.1.0/24

R2

interface FastEthernet0/0

ip address 10.10.10.2 255.255.255.0

router eigrp 1

network 10.0.0.0

no auto-summary

Router#sh ip route

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets

D 1.1.1.0 [90/156160] via 10.10.10.1, 00:06:50, FastEthernet0/0

10.0.0.0/24 is subnetted, 1 subnets

C 10.10.10.0 is directly connected, FastEthernet0/0

Router#

http://www.cisco.com/en/US/docs/ios/12_2/ip/configuration/guide/1cfindep.html#wp1001343

HTH

Narayan

3 REPLIES

Re: EIGRP routing

Ypu would be required to use distribute lists for filtering routes from advertising.

The distribute-list can reference an access-list or prefix-list

eg. say R1<--->R2 R1 runs eigrp on all its interfaces but needs to send routing updates only for loopback1

R1

interface Loopback1

ip address 1.1.1.1 255.255.255.0

!

interface Loopback2

ip address 2.2.2.2 255.255.255.0

!

interface FastEthernet0/0

ip address 10.10.10.1 255.255.255.0

router eigrp 1

network 1.0.0.0

network 2.0.0.0

network 10.0.0.0

distribute-list prefix test out

no auto-summary

ip prefix-list test seq 10 permit 1.1.1.0/24

R2

interface FastEthernet0/0

ip address 10.10.10.2 255.255.255.0

router eigrp 1

network 10.0.0.0

no auto-summary

Router#sh ip route

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets

D 1.1.1.0 [90/156160] via 10.10.10.1, 00:06:50, FastEthernet0/0

10.0.0.0/24 is subnetted, 1 subnets

C 10.10.10.0 is directly connected, FastEthernet0/0

Router#

http://www.cisco.com/en/US/docs/ios/12_2/ip/configuration/guide/1cfindep.html#wp1001343

HTH

Narayan

Community Member

Re: EIGRP routing

Thank you, this is what I was looking for

Re: EIGRP routing

try using redistribute..as for route maps, it's mainly used for bgp (for policy based routing or PBR)

127
Views
0
Helpful
3
Replies
CreatePlease to create content