Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

EIGRP Topology Question Null Route

I am in the very beginning of a project to install a VOIP Network for our LAN.  I use EIGRP as a router protocol.  I have a full class "B" address scheme that is broken down in class "c" address space for users.  I break down the addresses by geographic areas on our campus. I have four Cisco 6500 Devices in the Network that are connected via routed links.  So my network statement now looks like this:

router eigrp 5555
passive-interface Vlan70
passive-interface Vlan131
passive-interface Vlan132
passive-interface Vlan133
network 139.223.0.0 <----------- Not my real network
auto-summary

For VOIP, I was going to use the same design and just add another network to our routing statement.  The third octet will match the geo subnets for the users.  To begin I setup a new VLAN interface on a Cisco 6500. 

int vlan 341

ip address 10.243.141.0 255.255.255.0

Network statement changes to:

rrouter eigrp 5555
passive-interface Vlan70
passive-interface Vlan131
passive-interface Vlan132
passive-interface Vlan133

passive-interface Vlan341
network 139.223.0.0 <----------- Not my real network

network 10.243.0.0 0.0.255.255
auto-summary

When I do this I get:

D       10.0.0.0/8 is a summary, 20:56:37, Null0
C       10.243.141.0/24 is directly connected, Vlan341

106-TC1A-6509-1#show ip eigrp topology 10.0.0.0/8

IP-EIGRP (AS 5555): Topology entry for 10.0.0.0/8
   State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2816
   Routing Descriptor Blocks:
   0.0.0.0 (Null0), from 0.0.0.0, Send flag is 0x0
       Composite metric is (2816/0), Route is Internal
       Vector metric:
         Minimum bandwidth is 1000000 Kbit
         Total delay is 10 microseconds
         Reliability is 255/255
         Load is 1/255
         Minimum MTU is 1500
         Hop count is 0

My question is:

Is this a good way to implement VOIP?  Second and most important, where is the null route come from for the 10.0.0.0/8 network? 


1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: EIGRP Topology Question Null Route

Douglas,

The 10.0.0.0/8 entry in your routing table is called a discard route entry and is added automatically as a result of your EIGRP router performing automatic summarization (you have a subnet of the major network 10.0.0.0/8, and you are advertising it out an interface that is in a different major network, in your case, the 139.223.0.0/16 - in such cases, the subnet will be summarized to the major network itself, i.e. 10.0.0.0/8). The discard route to the Null0 interface is added as a protection against routing loops.

Regarding the details of the discard route, how it works and what it protects, see, for example, this article:

https://supportforums.cisco.com/message/3159168#3159168

(lower at the post)

It is strongly recommended to deactivate the automatic summarization in current EIGRP deployments, and have it activated only if you are absolutely certain of its ramifications. The automatic summarization can be deactivated in your EIGRP configuration by using the no auto-summary command. This will stop your EIGRP router to perform automatic summarization, and as a result, this discard route will be removed from your routing table as well.

Best regards,

Peter

1 REPLY
Cisco Employee

Re: EIGRP Topology Question Null Route

Douglas,

The 10.0.0.0/8 entry in your routing table is called a discard route entry and is added automatically as a result of your EIGRP router performing automatic summarization (you have a subnet of the major network 10.0.0.0/8, and you are advertising it out an interface that is in a different major network, in your case, the 139.223.0.0/16 - in such cases, the subnet will be summarized to the major network itself, i.e. 10.0.0.0/8). The discard route to the Null0 interface is added as a protection against routing loops.

Regarding the details of the discard route, how it works and what it protects, see, for example, this article:

https://supportforums.cisco.com/message/3159168#3159168

(lower at the post)

It is strongly recommended to deactivate the automatic summarization in current EIGRP deployments, and have it activated only if you are absolutely certain of its ramifications. The automatic summarization can be deactivated in your EIGRP configuration by using the no auto-summary command. This will stop your EIGRP router to perform automatic summarization, and as a result, this discard route will be removed from your routing table as well.

Best regards,

Peter

480
Views
0
Helpful
1
Replies
CreatePlease to create content