Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

EMC Celerra / Windows Broadcom TOE- File Transfer Slow after enable MLS QOS

We are seeing slow file transfers from EMC to the end XP stations after enabling MLS QOS on the access layer 3750 12.2(25)SEE3. I believe the EMC Celerra runs Linux and utilizes Samba for file sharing. I ran across an earlier post.

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=IP%20Telephony&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.1ddd1fe1

Turning off QOS fixes the issue. Additionally none of the Windows 2000/2003 servers are having this issue, with the exception of the new Dell servers with Integrated Broadcom BCM5708C NetXtreme II, with TOE offload enabled. With QOS on and TOE on, transfer is slow on the new Dell Servers. If I disable either QOS or TOE, then the speed returns. I have measured with IXIA Chariot and see 95MB (on a Fast Ethernet port) when all is well, and 800k when the speed is slow.

Has anyone ran across this or something similar?

7 REPLIES
Silver

Re: EMC Celerra / Windows Broadcom TOE- File Transfer Slow after

How are you implementing QOS? Can you provide to us your configuration? This will help us to determine if your configuration is correct and if your are implementing QOS correctly....

Re: EMC Celerra / Windows Broadcom TOE- File Transfer Slow after

Using Trust DSCP end to end with PQ out. I have removed all PQ and trust settings and the 3750 would be now considered default, except for "MLS QOS". The servers and workstations are on different networks in the Cisco Core/Dist/Access model. No MLS QOS on the server switch, just the workstation access switch. As a note, this does not occur on a GigE port, even if the GigE is negotiated down to 100FULL. Only occurs on FastEthernet. I'm thinking there's a queuing buffer issue here. We have seen this in some older IOS versions.

Silver

Re: EMC Celerra / Windows Broadcom TOE- File Transfer Slow after

How are you marking the EMC traffic? What DSCP value are you marking it and how are you queueing this DSCP value. Is it truely end to end QOS for this DSCP value.

Re: EMC Celerra / Windows Broadcom TOE- File Transfer Slow after

All marking and trusting is turned off to facilitate troubleshooting this issue. I think this is somehow similar to CSCeg29704 and/or CSCsc96037.

New Member

Re: EMC Celerra / Windows Broadcom TOE- File Transfer Slow after

I am still working on the same problem. At the moment I installed on the 3560 the image Version 12.2(35)SE1 with the following QOS-Settings. The interesting thing is that when i do a Filetransfer from Samba with Totalcommander i have the full Speed about 8000 kbit. But with Windows filetransfer only 760 kbit. With Totalcommander the filesize is bigger and the Sambaserver can send more packets at once.

mls qos map policed-dscp 0 24 to 8

mls qos map cos-dscp 0 8 16 24 32 46 48 56

mls qos srr-queue output cos-map queue 1 threshold 3 5

mls qos srr-queue output cos-map queue 2 threshold 1 2 4

mls qos srr-queue output cos-map queue 2 threshold 2 3

mls qos srr-queue output cos-map queue 2 threshold 3 6 7

mls qos srr-queue output cos-map queue 3 threshold 3 0

mls qos srr-queue output cos-map queue 4 threshold 3 1

mls qos srr-queue output dscp-map queue 1 threshold 3 46

mls qos srr-queue output dscp-map queue 2 threshold 1 16 18 20 22 25 32 34 36

mls qos srr-queue output dscp-map queue 2 threshold 1 38

mls qos srr-queue output dscp-map queue 2 threshold 2 24 26

mls qos srr-queue output dscp-map queue 2 threshold 3 48 56

mls qos srr-queue output dscp-map queue 3 threshold 3 0

mls qos srr-queue output dscp-map queue 4 threshold 1 8

mls qos srr-queue output dscp-map queue 4 threshold 3 10 12 14

mls qos queue-set output 1 threshold 2 70 80 100 100

mls qos queue-set output 1 threshold 4 40 100 100 100

mls qos

class-map match-all voice-signaling

match access-group name voice-signaling

class-map match-all voice-payload

match access-group name voice-payload

!

!

policy-map phoneshared

class voice-signaling

set dscp cs3

police 32000 8000 exceed-action policed-dscp-transmit

class voice-payload

set dscp ef

police 128000 8000 exceed-action drop

class class-default

police 10000000 8000 exceed-action policed-dscp-transmit

ip access-list extended voice-payload

permit udp 10.14.32.0 0.0.7.255 range 32512 32767 any range 32512 32767

ip access-list extended voice-signaling

permit udp 10.14.32.0 0.0.7.255 range 32512 32767 host 10.11.13.10 eq 32640

permit udp 10.14.32.0 0.0.7.255 range 32512 32767 host 10.11.13.11 eq 32640

permit udp 10.14.32.0 0.0.7.255 range 32512 32767 host 10.14.32.10 eq 32640

permit udp 10.14.32.0 0.0.7.255 range 32512 32767 host 10.14.32.11 eq 32640

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

srr-queue bandwidth share 1 70 25 5

srr-queue bandwidth shape 30 0 0 0

priority-queue out

mls qos trust dscp

int range fas 0/1 - 48

service-policy input phoneshared

srr-queue bandwidth share 1 70 25 5

srr-queue bandwidth shape 30 0 0 0

priority-queue out

spanning-tree portfast

no mls qos trust dscp

end

Re: EMC Celerra / Windows Broadcom TOE- File Transfer Slow after

I found some similar conversations on other discussion forums. They saw many checksum errors in the packet captures, as do I. The suggestion was to modify the queue-set. I adjusted the parameters until traffic flowed properly. Here are my settings, you might give it a try and see.

mls qos queue-set output 1 threshold 2 800 800 50 800

I am puzzled why the default QOS parameters aren't adequate to pass Samba traffic. Also why Microsoft shares seem to work OK, but not with TOE enabled. What does all this mean?

New Member

Re: EMC Celerra / Windows Broadcom TOE- File Transfer Slow after

This settings are working fine, but all traffic in 1 queue. I implemented this QOS-Settings now on my testswitch and will play with other queuesets.

mls qos map policed-dscp 0 24 to 8

mls qos map cos-dscp 0 8 16 24 32 46 48 56

mls qos srr-queue output cos-map queue 1 threshold 3 5

mls qos srr-queue output dscp-map queue 1 threshold 3 46

mls qos queue-set output 1 threshold 2 800 800 50 800

mls qos

But I still didnt know why Totalcommander change the windows-size

924
Views
0
Helpful
7
Replies