Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

enable spanning-tree for a vlan

hi all,

We have 2 core switches. 1 is made as vtp server and other is client. HSRP is configured between them so that in case if one goes ther other will serve vlans.

I defined a vlan 13 on primary switch with a set of private ip addresses as given below:

interface Vlan13

ip address 10.250.7.4 255.255.255.0

no ip redirects

standby 1 ip 10.250.7.1

standby 1 priority 85

standby 1 preempt

!

spanning-tree vlan 1,5,7,9,13 priority 4096

And saved the conf.

when i run the command,

sh spanning-tree vlan 13 it gives me an error like given below:

"Spanning tree instance(s) for vlan 13

does not exist."

I would like to know what i must do in order to enable the spanning-tree on vlan.

Thanks

sugunakar

10 REPLIES

Re: enable spanning-tree for a vlan

Sugunakar,

Do a show vlan 13 and see if vlan 13 shows up there. If it doesn't then you need to create a VLAN 13 and that can be done by entering the following command in the global config mode as follows.

config t

vlan 13

HTH

Sundar

New Member

Re: enable spanning-tree for a vlan

Here is the output from my config file:

#Sh VLAN

VLAN Name Status Ports

---- -------------------------------- --------- ----------

1 default active Gi1/0/1, G

Gi1/0/23,

10 xxxxA active

11 ccccc active

12 sssss active

13 jjjj active

And one thing i observed

SWB11FSR1#sh spanning-tree vlan 13

Spanning tree instance(s) for vlan 13 does not exist.

I am able to see the same vlan in other switch which is configured as HSRP for vlans and it is marked as root there.

I want this switch to recognise this vlan in spanning-tree and become root.

One more observation:

I am seeing a line like

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

no spanning-tree vlan 13

spanning-tree vlan 1,5,7,9,11,13,900 priority 4096

spanning-tree vlan 6,8,12,14,200 priority 8192

I am unable to remove the line

"no spanning-tree vlan 13".

Thanks in advance

Regards

sugun

Re: enable spanning-tree for a vlan

Hi Sugun,

The command should be "spanning-tree vlan 13" to get rid of the "no spanning-tree vlan 13" in your configuration. Do you see any error message when you are attempting to add this?

There won't be any stp instance running for vlan 13 unless there is a least one port carrying traffic for vlan 13 on this switch. So make sure that there is an access port in vlan 13 or a trunk carrying vlan 13 up on your box.

Regards,

Francois

New Member

Re: enable spanning-tree for a vlan

Hi Francois,

Thank you very much Francois.

I was assuming no spanning-tree was something like comment and i cant remove. The moment, i used the "spanning-tree vlan 13 ", everything is working fine.

Thank you very much for your valuable inputs.

Regards

sugun

Re: enable spanning-tree for a vlan

Is spanning tree working for your other VLANs? Try a 'show spann sum', you should see STP for all your VLANs. If it's just 13 that is not working, try 'sh vlan' and make sure 13 is in the VLAN database. If it is try 'sh int vlan 13' and make sure it is up. Post your results.

New Member

Re: enable spanning-tree for a vlan

hi ceclark,

Thanks for the response.

I am able to see that the int vlan 13 is up.

sh span sum is not showing the vlan 13.

Here is the output from my config file:

#Sh VLAN

VLAN Name Status Ports

---- -------------------------------- --------- ----------

1 default active Gi1/0/1, G

Gi1/0/23,

10 xxxxA active

11 ccccc active

12 sssss active

13 jjjj active

And one thing i observed

SWB11FSR1#sh spanning-tree vlan 13

Spanning tree instance(s) for vlan 13 does not exist.

I am able to see the same vlan in other switch which is configured as HSRP for vlans and it is marked as root there.

I want this switch to recognise this vlan in spanning-tree and become root.

One more observation:

I am seeing a line like

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

no spanning-tree vlan 13

spanning-tree vlan 1,5,7,9,11,13,900 priority 4096

spanning-tree vlan 6,8,12,14,200 priority 8192

I am unable to remove the line

"no spanning-tree vlan 13".

Thanks in advance

Regards

sugun

Re: enable spanning-tree for a vlan

That helps, thanks for posting the config. Is VLAN 13 configured on the other Core? What is your trunk between the two cores (single connection or etherchannel)? Can you see if VLAN 13 is trunking between the cores? Is vlan 13 in STP on the other Core?

New Member

Re: enable spanning-tree for a vlan

hI ceclark

VLAN 13 is configured on other core(infact on two cores).

There is no trunk port confgured between the two cores. i am attachng cdp neghbor output from both cores.

VLAN 13 is not a trunkng one.

SWB11FSR1>sh cdp neighbors

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

S - Swtch, H - Host, I - IGMP, r - Repeater, P - Phone

Device ID Local Intrfce Holdtme Capability Platform Port ID

SWB11FSR10 Gig 1/0/19 169 S I WS-C2950T-Gig 0/2

SWB11FSR11 Gig 1/0/14 129 S I WS-C2950T-Gig 0/2

SWB13FZA1 Gig 1/0/7 138 S I WS-C2950T-Gig 0/2

SWB12FZA1 Gig 1/0/9 146 S I WS-C2950T-Gig 0/2

SWB12FZB1 Gig 1/0/11 142 S I WS-C2950T-Gig 0/2

SWB12FZA3 Gig 1/0/10 145 S I WS-C2950T-Gig 0/2

SWB13FZB1 Gig 1/0/8 153 S I WS-C2950T-Gig 0/2

SWB14FZB1 Gig 1/0/6 127 T S WS-C2924-XFas 0/24

SWB13FZA4 Gig 1/0/16 174 S I WS-C3550-2Fas 0/23

SWB13FZB4 Gig 1/0/15 120 S I WS-C3550-2Fas 0/23

SWB12FZB4 Gig 1/0/17 147 S I WS-C3550-2Fas 0/23

SWB14FZA1 Gig 1/0/5 177 S I WS-C2950T-Gig 0/2

SWB11FSR3 Gig 1/0/12 178 S I WS-C2950T-Gig 0/2

SWB16FSR5 Gig 1/0/20 136 S I WS-C2950T-Gig 0/1

SWB11FSR5 Gig 1/0/13 149 S I WS-C2950T-Gig 0/2

SWB16FSR3 Gig 1/0/4 121 S I WS-C2950T-Gig 0/2

SWB11FSR7 Gig 1/0/18 142 S I WS-C2950T-Gig 0/2

BANG-PSW2.fcgis.cGig 1/0/3 132 S I WS-C3550-2Fas 0/23

JAB050406DZ(SWB16Gig 1/0/2 146 T S WS-C4006 2/11

SWB11FSR2>sh cdp neighbors

Device ID Local Intrfce Holdtme Capability Platform Port ID

SWB11FSR13 Gig 1/0/14 161 S I WS-C2950T-Gig 0/2

SWB12FZB3 Gig 1/0/11 124 S I WS-C2950T-Gig 0/2

SWB13FZB3 Gig 1/0/8 172 S I WS-C2950T-Gig 0/2

SWB12FZA2 Gig 1/0/9 124 S I WS-C2950T-Gig 0/2

SWB13FZA3 Gig 1/0/7 168 S I WS-C2950T-Gig 0/2

SWB13FZA4 Gig 1/0/16 153 S I WS-C3550-2Fas 0/24

SWB14FZB3 Gig 1/0/6 179 S I WS-C3550-2Fas 0/24

SWB13FZB4 Gig 1/0/15 158 S I WS-C3550-2Fas 0/24

SWB12FZB4 Gig 1/0/17 125 S I WS-C3550-2Fas 0/24

SWB16FSR4 Gig 1/0/4 165 S I WS-C2950T-Gig 0/2

SWB11FSR4 Gig 1/0/12 154 S I WS-C2950T-Gig 0/2

SWB11FSR9 Gig 1/0/19 163 S I WS-C2950T-Gig 0/2

SWB11FSR8 Gig 1/0/18 169 S I WS-C2950T-Gig 0/2

BANG-PSW2.fcgis.cGig 1/0/3 170 S I WS-C3550-2Fas 0/24

BANG-PSW3.fcgis.cGig 1/0/13 128 S I WS-C3550-2Fas 0/24

BANG-PSW1.fcgis.cGig 1/0/10 121 S I WS-C3550-2Fas 0/24

BANG-PSW4.fcgis.cGig 1/0/5 172 S I WS-C3550-2Fas 0/24

JAB050406DZ(SWB16Gig 1/0/2 125 T S WS-C4006 2/12

yes. VLAN 13 is in STP in other core. Below s the

SWB11FSR2#sh spanning-tree vlan 13

VLAN0013

Spanning tree enabled protocol ieee

Root ID Priority 8205

Address 000f.90c9.9800

This bridge is the root

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 8205 (priority 8192 sys-id-ext 13)

Address 000f.90c9.9800

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

Re: enable spanning-tree for a vlan

Why is ther no layer2 trunk between the core switches? What trunks are vlan 13 allowed on? Is vlan 13 able to communicate with all the core switches and distro/access switches at layer 2?

New Member

Re: enable spanning-tree for a vlan

Hi Clark,

From the begining there is no layer 2 trunk between these devices. On all trunks vlan 13 is allowed as we never kept any restrictions in cores.

The soln to this problem is provided by francois.

I was assuming no spanning-tree was something like comment and i cant remove. The moment, i used the "spanning-tree vlan 13 ", everything is working fine.

I really appreciate the kind of help i got from you and this forum.

Regards

sugun

918
Views
0
Helpful
10
Replies
CreatePlease to create content