Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

enabling CEF changing connected routes to static route

I have 3800 router which has ospf for LAN and static. we are redistributing static routes into ospf. when enabling local gig interface which was showing connected become static route. we routing local subnet also to serial interfaces. but local interface should be showing connected. Please provide me a solution on this.

10 REPLIES
New Member

Re: enabling CEF changing connected routes to static route

Hi,

If we disable cef everything working fine.

New Member

Re: enabling CEF changing connected routes to static route

If anyone knows the reason, please help me.

Cisco Employee

Re: enabling CEF changing connected routes to static route

Sampath,

Could you please provide the output of a "show ip route x.x.x.x" for the specific route and "show int xx" for the specific int.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: enabling CEF changing connected routes to static route

Router2#sh ip route 1.1.1.3

Routing entry for 1.0.0.0/8

Known via "static", distance 1, metric 0

Redistributing via ospf 1

Advertised by ospf 1 subnets

Routing Descriptor Blocks:

* 172.16.1.2

Route metric is 0, traffic share count is 1

We have route 1.0.0.0 255.255.255.0 to 172.16.1.2

statis routes redistributed into ospf. It usually shows connected when no ip cef. When CEF enabled showing static.

New Member

Re: enabling CEF changing connected routes to static route

i think has something to do with the way that CEF maintains the FIB database, cant explain further though.

on the neighbor routers with CEF enabled,do you see the same route as ospf route?

New Member

Re: enabling CEF changing connected routes to static route

Hi,

Yes. i am seeing this route through ospf.

Cisco Employee

Re: enabling CEF changing connected routes to static route

Sampath,

Can you provide the exact configuration of the static route and the version of IOS you use.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: enabling CEF changing connected routes to static route

interface GigabitEthernet0/0

ip address 1.1.1.3 255.255.255.0

no ip redirects

no ip proxy-arp

ip nat inside

ip virtual-reassembly

no ip mroute-cache

ip ospf authentication message-digest

ip ospf authentication-key

duplex auto

speed auto

media-type rj45

no cdp enable

router ospf 1

router-id 1.1.1.3

log-adjacency-changes

redistribute static subnets

passive-interface default

no passive-interface GigabitEthernet0/0

no passive-interface GigabitEthernet0/1

ip route 0.0.0.0 0.0.0.0 1.1.1.254 (customer FW)

ip route 10.0.0.0 255.0.0.0 172.16.1.2

IOS version : c3845-advsecurityk9-mz.124-15.XY1.bin

OSPF used in LAN environment for redundancy.

New Member

Re: enabling CEF changing connected routes to static route

Route wrongly mentioned

ip route 1.0.0.0 255.0.0.0 172.16.1.2 is the correct one.

New Member

Re: enabling CEF changing connected routes to static route

Any help on this?

164
Views
3
Helpful
10
Replies
CreatePlease to create content