Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

encapsulation dot1q unrecognized

Hi.

i have a 2600 router and i need to apply the vlan trunking on subinterfaces fastethernet 0/1.1 and 0/1.50.

the configuration i tried are as follows

Router(config)#interface fast 0/0.1

Router(config-subif)# encap?

% Unrecognized command

the sho version command result is

-----------------------------

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-I-M), Version 12.2(8)T5, RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Fri 21-Jun-02 08:50 by ccai

Image text-base: 0x80008074, data-base: 0x80A2BD40

ROM: System Bootstrap, Version 12.2(7r) [cmong 7r], RELEASE SOFTWARE (fc1)

cisco 2611XM (MPC860P) processor (revision 0x100) with 27648K/5120K bytes of memory.

X.25 software, Version 3.0.0.

2 FastEthernet/IEEE 802.3 interface(s)

2 Serial network interface(s)

-------------------------

the rest i deleted to make it a little shorter.

i read that ios 12.2 supports the encapsulation dot1q command on cisco website. !!!!

can any one help???

8 REPLIES
Super Bronze

Re: encapsulation dot1q unrecognized

I haven't confirmed this, but it's possible the encapsulation feature might require a higher feature set then the IP only version you're using offers.

PS:

You might also consider moving of the old 12.2 "T" version; 12.3 would have the same features and is also GD.

New Member

Re: encapsulation dot1q unrecognized

thanks joseph

actually.. i tried a lot looking for a higher feature to set it... but no luck,

please if you have any ideas about this feature or any thing else. i need to do it tommorow.

thanks.

New Member

Re: encapsulation dot1q unrecognized

Hi,Do you see "switchport mode trunk" command?If so, what you observe implies that ISL is not supported.Only if you have both ISL and dot1q you will see "switchport trunk encapsulation" command.When you configure "switchport mode trunk" the encapsulation will use dot1q.Hope this helps.

New Member

Re: encapsulation dot1q unrecognized

hi nambi, do you mean if i have the switchport trunk encapsulation on the router... i don't think so, i will cheack tommorrow.

Hall of Fame Super Silver

Re: encapsulation dot1q unrecognized

Arivudainambi

Your answer is interesting and correct for Catalyst switches. The switchport mode trunk command is a Catalyst switch command. The question here is about encapsulation on an 2600 IOS router which does not have any switchport commands.

I agree with Joseph that the issue is that encapsulation (VLAN trunking) is not supported in the IP BASE (or IP only) image that is running. Upgrade to a higher feature set (and hopefully a newer version) is the solution.

[edit] After submitting my response I did check the Software Advisor on CCO and it looks like the IP PLUS feature set (even in 12.2T) requires 64 MB of memory and the current machine has only 32. So a memory upgrade will be required to do the IOS upgrade.

HTH

Rick

Super Bronze

Re: encapsulation dot1q unrecognized

fyi:

Knowing that older versions are often smaller, I hoped a older version would run in 32 MB. Just checked and found the 12.2 Plus version requires 48 MB and 12.1 requires 40 MB, so some additional RAM appears to be required.

PS:

NB: On some images, especially older versions, you can sometimes run with less than the specified required minimal RAM. Believe doing so is considered an non-supported environment by Cisco.

New Member

Re: encapsulation dot1q unrecognized

will.. thank you guys, i will try to get a newer IOS version tommorrow.

New Member

Re: encapsulation dot1q unrecognized

Thanks Rick.I overlooked the question.

1472
Views
5
Helpful
8
Replies
CreatePlease to create content