Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Encapsulation for Catalyst 2960

Replacing a 2900XL with a new 2960 and need to copy over some configs. I need to put switchport trunk encapsulation dot1q in int fas0/23 but "encapsulation" is not an option to enter. I can only enter allowed, native, or pruning.

I'd appreciate any help with this. Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions
Community Member

Re: Encapsulation for Catalyst 2960

It won't allow you to put the line:

switchport trunk encapsulation dot1q

It will reject it. If that's the only encapsulation type that switch supports, then that's the one it will use when you enter:

switchport mode trunk

5 REPLIES
Cisco Employee

Re: Encapsulation for Catalyst 2960

Hi Chaney,

2960 switch only supports dot1q encapsulation and that is the reason encapsulation command is not available/supported.

HTH

Ankur

*Pls rate helpfull post

Community Member

Re: Encapsulation for Catalyst 2960

Thanks for your reply. Just so I'm clear, if I'm copying these lines:

interface FastEthernet0/23

switchport access vlan 2

interface FastEthernet0/24

switchport trunk encapsulation dot1q

switchport mode trunk

Would I just leave out the encapsulation line all together? Would there be something in its place (allowed, native, pruning)?

Community Member

Re: Encapsulation for Catalyst 2960

It won't allow you to put the line:

switchport trunk encapsulation dot1q

It will reject it. If that's the only encapsulation type that switch supports, then that's the one it will use when you enter:

switchport mode trunk

Re: Encapsulation for Catalyst 2960

Hi,

You do not need to enter "switchport trunk encapsulation dot1q". It is built into the IOS as this model only support dot1Q trunking.

You will need "switchport access vlan 2" and "switchport mode trunk" according to your need.

HTH

Shaheen

Community Member

Re: Encapsulation for Catalyst 2960

Thanks for the help everyone.

1266
Views
10
Helpful
5
Replies
CreatePlease to create content