Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Error - %PM-4-ERR_DISABLE: pagp-flap error AND putting Fa0/8 IN ERROR DIS

Hi ,

Can any one help me on the below query plz:-

I am seeing follwoing error after configuring Trunking and Ehter channeling in desirable mode between switches.

SW1 & SW2 # interface FastEthernet0/7

switchport trunk encapsulation dot1q

switchport mode trunk

duplex full

channel-group 1 mode desirable

!

interface FastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

duplex full

channel-group 1 mode desirable

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state to up

00:07:37: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state to down

00:07:39: %PM-4-ERR_DISABLE: pagp-flap error detected on Fa0/8, putting Fa0/8

in err-disable state

00:07:41: %LINK-3-UPDOWN: Interface FastEthernet0/8, changed state to down

2 REPLIES
Cisco Employee

Re: Error - %PM-4-ERR_DISABLE: pagp-flap error AND putting Fa0/8

The error shows that after bundeling the ports in the channel, there was some continous port-flap due to which the channel flapped and its been put into error-disable state. Make sure that you have the same config on all the ports which are used in the bundle.

You can do the following to recover it :

1. Check the interace Fa0/8 and rule out any physical layer issues.

2. If the port is OK and is up again, try using the range command and shut/noshut the channel ports.

3. Use the command " error-disable recovery cause pagp-flap " in the config mode if you dont want to use the step 2.

4. If you suspect some software config problem, then remove the entire configs on all the ports, shut down all the ports, configure all them back again and then fire up the ports back again using noshutdown command.

New Member

Re: Error - %PM-4-ERR_DISABLE: pagp-flap error AND putting Fa0/8

hi Singh ,

Thanks for the above note!

I did all the attemps till the step 2 , but it is of no use. Till the time i form trunk between switch 1 & 2 , i dont have any issue with them . but when the same ports I am creating ether channel with desirable mode ..it is giving all the issues which are mentioned above.

I have checked the speed & duplex pareamenters as well.

Want to know the use of step 3 in this scenario.

Your help is much appreciated!

Akber.

2306
Views
0
Helpful
2
Replies