Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

errors across port-channel

Guys,

We've got a 4gig port-channel running from a 4506 -> 3750 (2 switch) stack.

We received a call last week regarding the network going slow and on the off chance we seen this issue and thought that the errors may have just been historical. The counters have been cleared 4 days ago but now they are nearly 1 million errors on the port-channel. It's strange as all 4 ports are configured with the same settings. I will post the outputs to the bottom of this and see if any of you experts can shed some light into this matter.

Thanks for your time!

Thomas.

4506 -

4506# sh int po5
Port-channel5 is up, line protocol is up (connected)
  Hardware is EtherChannel, address is 000f.2386.f700 (bia 000f.2386.f700)
  Description: Link (4Gb/s) to 3750
  MTU 1500 bytes, BW 4000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 6/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is N/A
  input flow-control is off, output flow-control is unsupported
  Members in this channel: Gi5/33 Gi5/34 Gi5/35 Gi5/36
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 1w4d, output never, output hang never
  Last clearing of "show interface" counters 4d05h
  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 94389000 bits/sec, 8567 packets/sec
  5 minute output rate 3832000 bits/sec, 2974 packets/sec
     1403144761 packets input, 2006168020857 bytes, 0 no buffer
     Received 819344 broadcasts (249140 multicast)
     0 runts, 0 giants, 0 throttles
     911095 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     663932228 packets output, 82535420512 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

interface Port-channel5
description Link (4Gb/s) to 3750
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,6-11,21
switchport mode trunk
end

interface GigabitEthernet5/33
description Link to 3750 Gi1/0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,6-11,21
switchport mode trunk
speed 1000
duplex full
qos trust dscp
channel-group 5 mode active
end

interface GigabitEthernet5/34
description Link to gh5-d3750-1 Gi2/0/2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,6-11,21
switchport mode trunk
speed 1000
duplex full
qos trust dscp
channel-group 5 mode active
end

interface GigabitEthernet5/35
description Link to 3750 Gi1/0/3
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,6-11,21
switchport mode trunk
speed 1000
duplex full
qos trust dscp
channel-group 5 mode active
end

interface GigabitEthernet5/36
description Link to 3750 Gi2/0/4
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,6-11,21
switchport mode trunk
speed 1000
duplex full
qos trust dscp
channel-group 5 mode active
end

3750

3750# sh int po1
Port-channel1 is up, line protocol is up (connected)
  Hardware is EtherChannel, address is 0022.be4d.f783 (bia 0022.be4d.f783)
  Description: Link (4Gb/s) to 4506
  MTU 1500 bytes, BW 4000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 5/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Full-duplex, 1000Mb/s, link type is auto, media type is unknown
  input flow-control is off, output flow-control is unsupported
  Members in this channel: Gi1/0/1 Gi1/0/3 Gi2/0/2 Gi2/0/4
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:27, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 3639000 bits/sec, 2795 packets/sec
  5 minute output rate 87688000 bits/sec, 7976 packets/sec
     67438141775 packets input, 8960156703405 bytes, 0 no buffer
     Received 811103312 broadcasts (0 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 510144132 multicast, 0 pause input
     0 input packets with dribble condition detected
     146300873944 packets output, 210615114944396 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

description Link to 4506 Gi5/33
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,6-11,21
switchport mode trunk
speed 1000
duplex full
no mdix auto
channel-group 1 mode active
spanning-tree guard root
end

interface GigabitEthernet1/0/3

description Link to 4506 Gi5/35
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,6-11,21
switchport mode trunk
speed 1000
duplex full
no mdix auto
channel-group 1 mode active
spanning-tree guard root

interface GigabitEthernet2/0/2
description Link to 4506 Gi5/34
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,6-11,21
switchport mode trunk
speed 1000
duplex full
no mdix auto
channel-group 1 mode active
spanning-tree guard root
end

interface GigabitEthernet2/0/4
description Link to 4506 Gi5/36
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,6-11,21
switchport mode trunk
speed 1000
duplex full
no mdix auto
channel-group 1 mode active
spanning-tree guard root
end

Everyone's tags (2)
2 REPLIES
Cisco Employee

Re: errors across port-channel

Hello,

Could you please check the output of "show controller ethernet-controller " and see if there are any errors in there? A typical output would look like below:

sh controllers ethernet-controller fa 0/1

     Transmit FastEthernet0/1                 Receive
      6213609 Bytes                          4660517 Bytes
        11954 Unicast frames                   12102 Unicast frames
        70472 Multicast frames                 40914 Multicast frames
          514 Broadcast frames                  1608 Broadcast frames
            0 Too old frames                  776328 Unicast bytes
            0 Deferred frames                3578396 Multicast bytes
            0 MTU exceeded frames             160275 Broadcast bytes
            0 1 collision frames                   0 Alignment errors
            0 2 collision frames                   0 FCS errors
            0 3 collision frames                   0 Oversize frames
            0 4 collision frames                   0 Undersize frames
            0 5 collision frames                   0 Collision fragments
            0 6 collision frames
            0 7 collision frames               13682 Minimum size frames
            0 8 collision frames               37725 65 to 127 byte frames
            0 9 collision frames                1112 128 to 255 byte frames
            0 10 collision frames               2105 256 to 511 byte frames
            0 11 collision frames                  0 512 to 1023 byte frames
            0 12 collision frames                  0 1024 to 1518 byte frames
            0 13 collision frames                  0 Overrun frames
            0 14 collision frames                  0 Pause frames
            0 15 collision frames
            0 Excessive collisions                 0 Symbol error frames
            0 Late collisions                      0 Invalid frames, too large
            0 VLAN discard frames                  0 Valid frames, too large
            0 Excess defer frames                  0 Invalid frames, too small
        69811 64 byte frames                       0 Valid frames, too small
        10210 127 byte frames
          595 255 byte frames                      0 Too old frames
         2226 511 byte frames                      0 Valid oversize frames
           96 1023 byte frames                     0 System FCS error frames
            2 1518 byte frames                     0 RxPortFifoFull drop frame
            0 Too large frames
            0 Good (1 coll) frames
            0 Good (>1 coll) frames

Hope this helps.

Regards,

NT

New Member

Re: errors across port-channel

Unfortunately our 4500 doesn't seem to have that command but is still racking up on the errors. I am just thinking how actual critical these errors actually are? Since we've had that many already on the interface and nothing has been done.

I know that's not the correct attitude but it's strange how it's sporadic over the 4 physical interfaces with no prejudice on 1 gig port than any other.

If anyone can help that would be a massive help as I think am hitting my head off a brick wall.

Cheers,


Thomas.

942
Views
0
Helpful
2
Replies
CreatePlease to create content