Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Ether Channel config

I have just set up Ether Channel on a 295

0 with 12.1 IOS, but when I go to the other switch (2950 12.0 IOS) I get an erro

r when I try to create the Channel group. I have included available commands to sh

ow they are valid. Any ideas?

SB>en
SB#config t
Enter configuration commands, one per line.  End with CNTL/Z.
SB(config)#int Port-channel ?
  <0-2147483647>  Port-channel interface number

SB(config)#int Port-channel 1
               ^
% Invalid input detected at '^' marker.

SB(config)#

3 ACCEPTED SOLUTIONS

Accepted Solutions
VIP Super Bronze

Re: Ether Channel config

Hi Steve,

In config mode when you do a interface ? do you see Port-channel as an option?

Here is on out put from a 2950.

I also wonder why that number is do large when you issue command "int port-channel and ?

Here is on out put from a 2950

I can create etherchannel with no problems and the maximum is 6

Management-Switch(config)#interface ?           
  Async              Async interface
  BVI                Bridge-Group Virtual Interface
  Dialer             Dialer interface
  FastEthernet       FastEthernet IEEE 802.3
  GigabitEthernet    GigabitEthernet IEEE 802.3z
  Group-Async        Async Group interface
  Lex                Lex interface
  Loopback           Loopback interface
  Multilink          Multilink-group interface
  Null               Null interface
  Port-channel       Ethernet Channel of interfaces
  Tunnel             Tunnel interface
  Virtual-Template   Virtual Template interface
  Virtual-TokenRing  Virtual TokenRing
  Vlan               Catalyst Vlans
  range              interface range command

Management-Switch(config)#interface po
Management-Switch(config)#interface port-channel ?
  <1-6>  Port-channel interface number

Management-Switch(config)#interface port-channel 2
Management-Switch(config-if)#

HTH

Reza

Re: Ether Channel config


I have just set up Ether Channel on a 295

0 with 12.1 IOS, but when I go to the other switch (2950 12.0 IOS) I get an erro

r when I try to create the Channel group. I have included available commands to sh

ow they are valid. Any ideas?

SB>en
SB#config t
Enter configuration commands, one per line.  End with CNTL/Z.
SB(config)#int Port-channel ?
  <0-2147483647>  Port-channel interface number

SB(config)#int Port-channel 1
               ^
% Invalid input detected at '^' marker.

SB(config)#

Steve,

When you create an EtherChannel for Layer 2 interfaces, a logical interface is dynamically created. You then manually assign an interface to the EtherChannel by using the channel-group interface configuration command which creates the port-channel logical interface.

You configure Layer 2 EtherChannels by configuring the Ethernet interfaces with the channel-group interface configuration command, which creates the port-channel logical interface.

and Reza has rightly pointed for channel-group-number, the range is 1 to 6

To conifgure a etherchannel follow the following steps:-

Step 1

configure terminal

Enter global configuration mode.

Step 2

interface interface-id

Enter interface configuration mode, and specify a physical interface to configure.

Valid interfaces include physical interfaces.

Up to eight interfaces of the same type and speed can be configured for the same group.

Step 3

channel-group channel-group-number mode {auto [non-silent] | desirable [non-silent] | on}

Assign the interface to a channel group, and specify the PAgP mode. The default mode is auto silent.

For channel-group-number, the range is 1 to 6. Each EtherChannel can have up to eight compatibly configured Ethernet interfaces.

Step 4

end

Return to privileged EXEC mode.

Step 5

show running-config

Verify your entries.

Hope that clear out your query

If helpful do rate the post

Ganesh.H

Purple

Re: Ether Channel config

  Steve just enter this on both and it should come up.  Substitute whatever ports you are using in the interface range command. It's important to bring both ports up at the same time when creating etherchannels.

int range f0/1 - 2

channel-group 2 mode desirable non-silent

no shut

11 REPLIES
New Member

Re: Ether Channel config

The "paste" is slightly off, the carrot is under the "P" on the switch error.

VIP Super Bronze

Re: Ether Channel config

Hi Steve,

In config mode when you do a interface ? do you see Port-channel as an option?

Here is on out put from a 2950.

I also wonder why that number is do large when you issue command "int port-channel and ?

Here is on out put from a 2950

I can create etherchannel with no problems and the maximum is 6

Management-Switch(config)#interface ?           
  Async              Async interface
  BVI                Bridge-Group Virtual Interface
  Dialer             Dialer interface
  FastEthernet       FastEthernet IEEE 802.3
  GigabitEthernet    GigabitEthernet IEEE 802.3z
  Group-Async        Async Group interface
  Lex                Lex interface
  Loopback           Loopback interface
  Multilink          Multilink-group interface
  Null               Null interface
  Port-channel       Ethernet Channel of interfaces
  Tunnel             Tunnel interface
  Virtual-Template   Virtual Template interface
  Virtual-TokenRing  Virtual TokenRing
  Vlan               Catalyst Vlans
  range              interface range command

Management-Switch(config)#interface po
Management-Switch(config)#interface port-channel ?
  <1-6>  Port-channel interface number

Management-Switch(config)#interface port-channel 2
Management-Switch(config-if)#

HTH

Reza

New Member

Re: Ether Channel config

I cheated a litte and upgraded the IOS on the switch to match the other 2950 (12.1) and it worked just fine. I build the Port channel with the int command, then assign the ports, and I now have the bundle working. Yes, on the 12.0 IOS I could not create the Channel Group with the int port-channel xx but the comand was listed in the help feature.

Would it make sense that the setup is different from 12.0 to 12.1 ?? Here is the config that worked. (12.1)

SA#en
SA#config t
Enter configuration commands, one per line.  End with CNTL/Z.
SA(config)#int port-channel 5
SA(config-if)#int range f0/11 - 12
SA(config-if-range)#switchport mode trunk
SA(config-if-range)#channel-group 5 mode on
SA(config-if-range)#switchport nonegotiate
SA(config-if-range)#

VIP Super Bronze

Re: Ether Channel config

Glad it worked.  My 2950 also is running 121 and it works both ways

c2950-i6q4l2-mz.121-19.EA1c.bin

I can create the Etherchannel first and then add the ports to it or just go to the physical port and add it to a new channel-group number.

Reza

Re: Ether Channel config


I have just set up Ether Channel on a 295

0 with 12.1 IOS, but when I go to the other switch (2950 12.0 IOS) I get an erro

r when I try to create the Channel group. I have included available commands to sh

ow they are valid. Any ideas?

SB>en
SB#config t
Enter configuration commands, one per line.  End with CNTL/Z.
SB(config)#int Port-channel ?
  <0-2147483647>  Port-channel interface number

SB(config)#int Port-channel 1
               ^
% Invalid input detected at '^' marker.

SB(config)#

Steve,

When you create an EtherChannel for Layer 2 interfaces, a logical interface is dynamically created. You then manually assign an interface to the EtherChannel by using the channel-group interface configuration command which creates the port-channel logical interface.

You configure Layer 2 EtherChannels by configuring the Ethernet interfaces with the channel-group interface configuration command, which creates the port-channel logical interface.

and Reza has rightly pointed for channel-group-number, the range is 1 to 6

To conifgure a etherchannel follow the following steps:-

Step 1

configure terminal

Enter global configuration mode.

Step 2

interface interface-id

Enter interface configuration mode, and specify a physical interface to configure.

Valid interfaces include physical interfaces.

Up to eight interfaces of the same type and speed can be configured for the same group.

Step 3

channel-group channel-group-number mode {auto [non-silent] | desirable [non-silent] | on}

Assign the interface to a channel group, and specify the PAgP mode. The default mode is auto silent.

For channel-group-number, the range is 1 to 6. Each EtherChannel can have up to eight compatibly configured Ethernet interfaces.

Step 4

end

Return to privileged EXEC mode.

Step 5

show running-config

Verify your entries.

Hope that clear out your query

If helpful do rate the post

Ganesh.H

New Member

Re: Ether Channel config

Yes, thanks for the explanation. I'm not sure what the glitch was in the 12.0, but I executed the commands (above in my earlier post) and it worked just like I thought it would.

Purple

Re: Ether Channel config

  Steve just enter this on both and it should come up.  Substitute whatever ports you are using in the interface range command. It's important to bring both ports up at the same time when creating etherchannels.

int range f0/1 - 2

channel-group 2 mode desirable non-silent

no shut

New Member

Re: Ether Channel config

I have added another port and connection to the Port channel, and it has crashed. I know if I wiped the config and rebuilt it, I would get it working, but I really want to learn how to see what's wrong/troubleshoot the issue. I plugged in another cable into port 4, no issues, when I ran the same commands on that port to make it a trunk and to add it to the group, it crashed. At frist I thought this was only because I had yet to configure the other switch on the other end of the bundle, but now that the other side is also completed, the port channel will not come back (link light out, errdisable state). I have looked at too many things to post here, so I will start by asking which show command is best to start with?

I have verified the correct ports are in the correct group:

SA#sh etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        u - unsuitable for bundling
        U - in use      f - failed to allocate aggregator
        d - default port

Number of channel-groups in use: 2
Number of aggregators:           2

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------

1      Po1(SD)          -
4      Po4(SD)          -        Fa0/4(D)    Fa0/5(D)    Fa0/6(D)
                                 Fa0/7(D)    Fa0/8(D)

ALSO, Running config shows the proper config:

interface FastEthernet0/1
!
interface FastEthernet0/2
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 3
switchport mode access
!
interface FastEthernet0/4
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
!
interface FastEthernet0/5
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
!
interface FastEthernet0/6
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
!
interface FastEthernet0/7
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
!
interface FastEthernet0/8
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
!

New Member

Re: Ether Channel config

I also have a VLAN conflict with the management VLAN 1:

SB(config)#int vlan 3
SB(config-if)#no shut
SB(config-if)#
01:40:28: %LINK-3-UPDOWN: Interface Vlan3, changed state to up
01:40:28: %LINK-5-CHANGED: Interface Vlan1, changed state to administratively do
wn

VIP Super Bronze

Re: Ether Channel config

2950 is a layer-2 device only.  You can only have one SVI interface at a time and the only purpose of the one SVI interface is for management.  That is why when you create another SVI interface it bring down the first one.  If you want to have the ability to create multiple SVIs and do routing then you need another switch like a 3560 and/or 3750.

Take a look at this section of this document:

http://www.cisco.com/en/US/tech/tk389/tk689/technologies_configuration_example09186a008009478e.shtml#confthevlancat

HTH

Reza

New Member

Re: Ether Channel config

I have a router on a stick, so inter VLAN routing is working. I'm going to rebuild.

1422
Views
0
Helpful
11
Replies