Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Ether-Channel mode ON issue

I have some issues running  ether-channel mode on. I have a 3120G Blade Switch (stacked). The blade  switch connects to the blade servers (internal).

Gi1/0/1 connects to eth0 and gi2/0/1 connects to eth1 on the blade server.

Here is my configuration:

interface Port-channel11

description Server1 | BOND 0 | HPBLADE BL460

switchport access vlan 11

switchport mode access

!

interface GigabitEthernet1/0/1

description Server1-eth0 | DOWNLINK

switchport access vlan 11

switchport mode access

channel-group 11 mode on

!

interface GigabitEthernet2/0/1

description Server1-eth1| DOWNLINK

switchport access vlan 11

switchport mode access

channel-group 11 mode on

On the server eth0 and eth1 are bonded. Here is the config

cat ifcfg-bond0

DEVICE=bond0

BOOTPROTO=none

ONBOOT=yes

IPADDR=192.20.184.11

NETMASK=255.255.255.0

USERCTL=no

BONDING_OPTS="mode=2 miimon=100 xmit_hash_policy=2"

Everything works fine, the etherchannel is up and running.

The  issue is when is shutdown eth0 on the server, the corresponding  interface on the switch (gi1/0/1) does not go down, show up and running.  Can anyone help me on this?

3 REPLIES
VIP Super Bronze

Ether-Channel mode ON issue

Can you change your config to run LACP and test again?  Make the switch side mode active.

Also, what happens if you shut the interface on the switch instead of the server when the mode in on?

HTH

New Member

Ether-Channel mode ON issue

Yes when i run my test with LACP everything works fine, but with mode on the switch does not recognize the server interface going down. With mode ON when i shudown the interface on switch, the server detects the link going down. Not sure if this is LINUX issue or CISCO..

VIP Super Bronze

Ether-Channel mode ON issue

Then just use LACP.  Unix and Linux products like standard protocols like LACP anyway.

396
Views
0
Helpful
3
Replies
CreatePlease to create content