Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Ethercahnnel error %EC-5-CANNOT_BUNDLE2

we have two 6509 connected in vss config.

one 6509 was shutdown due to power problem and was up after a few minutes.

a 2960s that is connected to both 6509 through 2 port etherchannel connection gave the following error:

Feb 23 19:11:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/27, changed state to down

Feb 23 19:11:14: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/27, changed state to down

Feb 23 19:17:37: %EC-5-CANNOT_BUNDLE2: Gi1/0/27 is not compatible with Gi1/0/28 and will be suspended (trunk mode of Gi1/0/27 is access, Gi1/0/28 is trunk)

Feb 23 19:17:39: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/27, changed state to up

Feb 23 19:17:47: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/27, changed state to up

when i run "sh etherchannel sum" i get:

1      Po1(SU)         LACP      Gi1/0/27(P) Gi1/0/28(P)

so everything seems to be ok.

does the above  %EC-5-CANNOT_BUNDLE2 error just mean that at the time the interface was down the was a problem with the ethercahnnel (expected....)

or is there a problem with the etherchannel config?

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Ethercahnnel error %EC-5-CANNOT_BUNDLE2

Jacob

It is obviously negotitating to a trunk otherwise your network wouldn't work but i think you should set them explicity.

I configured the "switchport mode trunk" and the "switchport trunk encapsulation on both physical and port channel in the past.

Jon

11 REPLIES
Hall of Fame Super Blue

Ethercahnnel error %EC-5-CANNOT_BUNDLE2

Jacob

Can you post the config for those gigabit ports ?

Jon

Community Member

Ethercahnnel error %EC-5-CANNOT_BUNDLE2

on 2960s
--------

interface Port-channel1
description ### to VSS port 14
ip dhcp snooping trust

interface GigabitEthernet1/0/27
channel-group 1 mode active
ip dhcp snooping trust

interface GigabitEthernet1/0/28
channel-group 1 mode active
ip dhcp snooping trust

on 6509
-------

interface Port-channel14
description #to comp_room
switchport
spanning-tree guard root

interface GigabitEthernet1/2/14
description to ### comp_room
switchport
channel-group 14 mode active
spanning-tree guard root

interface GigabitEthernet2/2/14
description to ### comp_room
switchport
channel-group 14 mode active
spanning-tree guard root

Hall of Fame Super Blue

Ethercahnnel error %EC-5-CANNOT_BUNDLE2

Jacob

Are these meant to be trunk links or access port links ie. you haven't configured either the physical interfaces or the port channel as either.

Jon

Community Member

Re: Etherchannel error %EC-5-CANNOT_BUNDLE2

trunk

you are right that its not configured on the ports

whats the default ?

and where should it be set , on physical ports or on port channel?

(i checked on other switches and trunk is set on both. is that ok?)

thanks

Community Member

Ethercahnnel error %EC-5-CANNOT_BUNDLE2

HI Jacob,

Can you shut and no shut  the Port channel interface.

Prajith

Community Member

Ethercahnnel error %EC-5-CANNOT_BUNDLE2

i can check that later after working hours

Hall of Fame Super Blue

Ethercahnnel error %EC-5-CANNOT_BUNDLE2

Jacob

It is obviously negotitating to a trunk otherwise your network wouldn't work but i think you should set them explicity.

I configured the "switchport mode trunk" and the "switchport trunk encapsulation on both physical and port channel in the past.

Jon

Community Member

Ethercahnnel error %EC-5-CANNOT_BUNDLE2

do you think the above error is because trunk is not set and when the port disconnects the link reverts back to access ?

Hall of Fame Super Blue

Ethercahnnel error %EC-5-CANNOT_BUNDLE2

Jacob

It doesn't seem to be affecting the actual operation once it has formed the etherchannel but yes, i think this may be why you are seeing that error message.

Jon

Community Member

Ethercahnnel error %EC-5-CANNOT_BUNDLE2

do you do this on all interfaces on all switches taking part in the etherchannel ? or just say on the access switches connecting to the backbone?

Hall of Fame Super Blue

Ethercahnnel error %EC-5-CANNOT_BUNDLE2

Jacob

Do you mean the configuration ?

All trunks should be set to trunks either dynamically or set to on as should the port channels.

Leaving the ports unconfigured just means the port negotiates to either a trunk or an access port but you should configure it rather than leave it up to the switch.

Jon

339
Views
0
Helpful
11
Replies
CreatePlease to create content