Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Etherchannel advice needed

Hi , can anyone advise? ...

We have  two data centres connected by a 2 pairs of active resilient ( diverse) 1Gbit fibre circuits. At each DC the circuits connect into a 3750E stack,

each circuit connects to a different switch within the stack (interfaces G3/0/49 & G4/0/49). We are trunking Vlans over these links and have grouped them into a single Etherchannel using LACP but can't get the etherchannel to work. One interface on each switch always goes into suspended mode.

I am fairly confident that the config is correct on the stacks.  There are two things that spring to mind which may be the problem. 1, My understanding is that LACP works with interfaces on different switches within the stacks but I may be wrong.  2,  the pairs fibre links have different latency values due to the diverse routes taken . Route A is 70K  route B is 100K  one way trip times for both pairs are sub millisecond,  could this be a factor?

Debuging hasn't shown anything of value

stack A DC1 config

interface Port-channel12
switchport trunk encapsulation dot1q
switchport trunk native vlan 12
switchport trunk allowed vlan 3-8,41-46,51,52,101-103,111,121-128,920
switchport mode trunk
speed nonegotiate

interface GigabitEthernet3/0/49
switchport trunk encapsulation dot1q
switchport trunk native vlan 12
switchport trunk allowed vlan 3-8,41-46,51,52,101-103,111,121-128,920
switchport mode trunk
speed nonegotiate
channel-group 12 mode active

interface GigabitEthernet4/0/49
switchport trunk encapsulation dot1q
switchport trunk native vlan 12
switchport trunk allowed vlan 3-8,41-46,51,52,101-103,111,121-128,920
switchport mode trunk
speed nonegotiate
channel-group 12 mode active

stack B DC2 config

interface Port-channel12
switchport trunk encapsulation dot1q
switchport trunk native vlan 12
switchport trunk allowed vlan 3-8,41-46,51,52,101-103,111,121-128,920
switchport mode trunk
speed nonegotiate

interface GigabitEthernet3/0/49
switchport trunk encapsulation dot1q
switchport trunk native vlan 12
switchport trunk allowed vlan 3-8,41-46,51,52,101-103,111,121-128,920
switchport mode trunk
speed nonegotiate
channel-group 12 mode passive

interface GigabitEthernet4/0/49
switchport trunk encapsulation dot1q
switchport trunk native vlan 12
switchport trunk allowed vlan 3-8,41-46,51,52,101-103,111,121-128,920
switchport mode trunk
speed nonegotiate
channel-group 12 mode passive

Many Thanks

Everyone's tags (1)
2 REPLIES
New Member

Re: Etherchannel advice needed

I'd change the passive mode to active.  No harm.  I will look for other possibilities, too, but for now that's all I have.


Well, just thought of one other thing...make sure all the duplex and speeds matchup for all the ports.  The nonegotiate for the port-channel interface seems unnecessary. I know they are all gig interfaces but I have seen strange things before.


Finally, from this link:

http://www.bitmover.org/LACP.htm

Are you seeing a capital S or lower case s when showing the etherchannel.  Lower s is bad.  Upper case is good.


James

Purple

Re: Etherchannel advice needed

   When bringing up the ports bring them all up at the same time using a "no shut" on the port channel SVI .   Post a " show etherchannel detail"  for us to see what is going on . Also it will usually tell you in the logs why the port was put into a suspended state , you could post that too ..

827
Views
0
Helpful
2
Replies
CreatePlease login to create content