Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Etherchannel and VLAN interface

I have a switchstack of 4 3750's(stack #1) that have been connected to another stack of 3750s(stack #2) for a few months.

I recently created an etherchannel with LACP between the two. Now the management interface on stack #1 isn't accessible for machines plugged into stack #2

My machine is plugged into stack #2

There is another stack(stack #3) that connects via etherchannel to stack #2. Machines plugged into that stack can access the VLAN int on stack #1. As well as machines plugged directly into stack #1

Am I missing something pretty standard? I think there is a trunk config I'm missing?

Any help or suggestions are appreciated.

Thanks,

Jasen

9 REPLIES
New Member

Re: Etherchannel and VLAN interface

the management vlans are the same? same IP subnet?

are you running lacp on both port channels? or is one pagp?

are you trunking on your port channel?

do a "show spanning-tree vlan " and look at the interfaces. Do you see 2 fast ethernet ports or a single port channel?

New Member

Re: Etherchannel and VLAN interface

Yes, Management VLANs are the same. Same IP subnet.

LACP on both port channels.

Yes, I'm trunking on the port channel

A Single Port Channel is shown in the 'show spanning-tree vlan

Hall of Fame Super Bronze

Re: Etherchannel and VLAN interface

Please post show ether sum from both switches.

__

Edison.

New Member

Re: Etherchannel and VLAN interface

Stack #2:

Number of channel-groups in use: 2

Number of aggregators: 2

Group Port-channel Protocol Ports

------+-------------+-----------+-----------------------------------------------

1 Po1(SU) LACP Gi1/0/49(P) Gi3/0/49(P)

2 Po2(SU) LACP Gi1/0/50(P) Gi2/0/1(P) Gi4/0/1(P) Gi4/0/2(P)

Stack #1:

Number of channel-groups in use: 1

Number of aggregators: 1

Group Port-channel Protocol Ports

------+-------------+-----------+----------------------------------------------

2 Po2(SU) LACP Gi1/0/25(P) Gi2/0/25(P) Gi3/0/25(P)

Gi4/0/25(P)

Hall of Fame Super Bronze

Re: Etherchannel and VLAN interface

Port-channels look good, let's see the config from the 3 stacks.

__

Edison.

New Member

Re: Etherchannel and VLAN interface

Attached are the port-channel and int configs from the 3 stacks.

Initially I noticed that stackone did not have 'switchport mode trunk' under the port-channel command. When added, the problem was not solved.

Stackthree has some configs under gig1/0/1 that a co-worker entered through CNA. I doubt that has any bearing on the issue since everything on that switch is functioning.

Again, thank you all for your assistance. Please let me know if I can provide anything else.

Thanks,

Jasen

Hall of Fame Super Bronze

Re: Etherchannel and VLAN interface

I noticed that stackone did not have 'switchport mode trunk' under the port-channel command.

That's not a good sign. Any changes on the physical interfaces will be mirrored to the logical port-channel interface. I don't recommend making changes in the logical interface. To re-sync the physical with the logical please execute the following commands in stackone (please do it during a maintenance window).

no interface Port-channel2

default interface GigabitEthernet1/0/25

default interface GigabitEthernet2/0/25

default interface GigabitEthernet3/0/25

default interface GigabitEthernet4/0/25

interface GigabitEthernet1/0/25

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 2 mode active

interface GigabitEthernet2/0/25

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 2 mode active

interface GigabitEthernet3/0/25

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 2 mode active

interface GigabitEthernet4/0/25

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 2 mode active

Can you also please the output from typing show ip interface brief | ex una from the 3 stacks.

HTH,

__

Edison.

New Member

Re: Etherchannel and VLAN interface

Sorry for the late post, I was out last week.

SWSTMAD01#show ip int br | ex una

Interface IP-Address OK? Method Status Protocol

Vlan1 192.168.172.228 YES manual up up

SWSTMAD02#show ip int bri | ex una

Interface IP-Address OK? Method Status Protocol

Vlan1 192.168.172.246 YES manual up up

Vlan173 192.168.173.2 YES manual up up

Vlan174 192.168.174.1 YES manual up up

SWSTMAD03#show ip int br | ex una

Interface IP-Address OK? Method Status Protocol

Vlan1 192.168.172.242 YES NVRAM up up

Again, thank you for your help. Please let me know if I can provide any other information.

Thanks,

Jasen

Re: Etherchannel and VLAN interface

Hi,

In order for ports to successffuly negotiate Ether channel some criteria must match:

1- spanning-tree config.

2- Vlans allowed.

3- Port Speed and duplex.

4- Ether channel type. (LACP or PAGP).

if its LACP standard, then make sure one part of the ether channel is active, this will allow ports to initiate negotiate LACP with its peer.

this would acheived by:

channel-group (Port channel number) mode active -- this is Interface Config command.

HTH

Mohamed

162
Views
0
Helpful
9
Replies