Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Etherchannel behaviour

I am studying for 642-813 switching exam and I faced the following doubt:

From the book CCNP SWITCH OFFICIAL CERTIFICATION GUIDE it is said that PAgP dynamically modifies parameters of the EtherChannel if
one of the bundled ports is modified:

"PAgP forms an EtherChannel only on ports that are configured for either identical static
VLANs or trunking. PAgP also dynamically modifies parameters of the EtherChannel if
one of the bundled ports is modified. For example, if the configured VLAN, speed, or duplex
mode of a port in an established bundle is changed, PAgP reconfigures that parameter
for all ports in the bundle".


And From the Cisco webpage it is said that if you change parameters in the port-channel then it is applied to all ports in the bundle.

http://www.cisco.com/en/US/docs/switches/lan/catalyst2950/software/release/12.1_9_ea1/configuration/guide/swethchl.html

"After you configure an EtherChannel, configuration changes applied to the port-channel interface apply to all the physical

interfaces assigned to the port-channel interface. Configuration changes applied to the physical interface affect only the

interface where you apply the configuration. To change the parameters of all ports in an EtherChannel, apply configuration

commands to the port-channel interface, for example, Spanning Tree Protocol (STP) commands or commands to configure a Layer 2

EtherChannel as a trunk".


Are both of them correct?


Thanks,

Antonio

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Etherchannel behaviour

Hello Mike,

Well, I've performed an experiment and here are the results - posting as captured:

Sw2(config-if)#do show ether sum

Flags:  D - down        P - bundled in port-channel

        I - stand-alone s - suspended

        H - Hot-standby (LACP only)

        R - Layer3      S - Layer2

        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met

        u - unsuitable for bundling

        w - waiting to be aggregated

        d - default port

Number of channel-groups in use: 1

Number of aggregators:           1

Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

1      Po1(SU)         PAgP      Fa0/11(P)   Fa0/12(P)  

Sw2(config-if)#do show run int po1

Building configuration...

Current configuration : 92 bytes

!

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

end

Sw2(config-if)#do show run int fa0/11

Building configuration...

Current configuration : 127 bytes

!

interface FastEthernet0/11

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode desirable

end

Sw2(config-if)#do show run int fa0/12

Building configuration...

Current configuration : 127 bytes

!

interface FastEthernet0/12

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode desirable

end

Sw2(config-if)#int fa0/12

Sw2(config-if)#sw mo ac

Sw2(config-if)#

*Mar  2 05:33:28.508: %EC-5-CANNOT_BUNDLE2: Fa0/12 is not compatible with Fa0/11 and will be suspended (dtp mode of Fa0/12 is off, Fa0/11 is on)

*Mar  2 05:33:29.506: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state to down

Sw2(config-if)#

Sw2(config-if)#do show run int fa0/11

Building configuration...

Current configuration : 127 bytes

!

interface FastEthernet0/11

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode desirable

end

Sw2(config-if)#do show run int fa0/12

Building configuration...

Current configuration : 128 bytes

!

interface FastEthernet0/12

switchport trunk encapsulation dot1q

switchport mode access

channel-group 1 mode desirable

end

Sw2(config-if)#sw mo tr

Sw2(config-if)#

*Mar  2 05:34:11.482: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state to up

Sw2(config-if)#

Sw2(config-if)#

Sw2(config-if)#do show ether sum

Flags:  D - down        P - bundled in port-channel

        I - stand-alone s - suspended

        H - Hot-standby (LACP only)

        R - Layer3      S - Layer2

        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met

        u - unsuitable for bundling

        w - waiting to be aggregated

        d - default port

Number of channel-groups in use: 1

Number of aggregators:           1

Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

1      Po1(SU)         PAgP      Fa0/11(P)   Fa0/12(P)  

Sw2(config-if)#speed 10

Sw2(config-if)#

*Mar  2 05:34:34.132: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state to down

*Mar  2 05:34:37.974: %EC-5-CANNOT_BUNDLE2: Fa0/12 is not compatible with Fa0/11 and will be suspended (speed of Fa0/12 is 10M, Fa0/11 is 100M)

Sw2(config-if)#

Sw2(config-if)#do show ether sum

Flags:  D - down        P - bundled in port-channel

        I - stand-alone s - suspended

        H - Hot-standby (LACP only)

        R - Layer3      S - Layer2

        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met

        u - unsuitable for bundling

        w - waiting to be aggregated

        d - default port

Number of channel-groups in use: 1

Number of aggregators:           1

Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

1      Po1(SU)         PAgP      Fa0/11(P)   Fa0/12(s)  

Sw2(config-if)#do show run int fa0/11

Building configuration...

Current configuration : 127 bytes

!

interface FastEthernet0/11

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode desirable

end

Sw2(config-if)#do show run int fa0/12

Building configuration...

Current configuration : 137 bytes

!

interface FastEthernet0/12

switchport trunk encapsulation dot1q

switchport mode trunk

speed 10

channel-group 1 mode desirable

end

Sw2(config-if)#

Note that at first, I had a working PAgP-controlled EtherChannel on logical interface Po1 bundling together Fa0/11 and Fa0/12. Then, on Fa0/12, I've changed the mode from trunk to access. The switch merely complained that the port is incompatible and kicked it off the EtherChannel. As I show in subsequent commands, the Fa0/11 did not inherit the switchport mode access command even though PAgP was running and I entered this command on Fa0/12.

Afterwards, I have put Fa0/12 back to trunk mode and instead, I've reconfigured it statically to 10Mbps. Again, the switch complained and suspended the Fa0/12, claiming that Fa0/11 is running on different speed. And just as before, the setting of speed 100 was not carried over to Fa0/11.

So I believe that the book is not entirely correct on what it says. Perhaps the author is confusing PAgP and EtherChannel in general. However, I see no logical reason why should PAgP try to "equalize" the local configuration of physical ports. It can be done easily by always configuring the logical Port-channel interface, so why should PAgP duplicate this work.

PAgP and LACP are intended to negotiate whether ports can be used as a single EtherChannel on both interconnected devices, but apart from that, I don't ever recall seeing or reading anything that would go beyond this signalling/negotiating function.

Best regards,

Peter

6 REPLIES

Etherchannel behaviour

I think the Cisco link you give is talking about LACP etherchannels and then it goes on to talk about understanding PaGP etherchannels. The one from the book is talking about PaGP. So yes they are both correct. PaGP change one port they all dynamicly change. LACP change one port and it only affects that port.

Mike

Cisco Employee

Etherchannel behaviour

Hello Antonio and Mike,

I believe there is a misunderstanding here.

Neither LACP nor PAgP are going to modify the configuration of the ports on the opposite device. At most, they can compare a selected set of configuration parameters but to my best knowledge, they do not actually cause the neighboring switch to reconfigure itself.

Regarding the automatic reconfiguration of local ports - I think that this is related to the fact that every configuration performed on the Port-channel interface is automatically pushed down by IOS to all physical member ports. There is, however, no PAgP or LACP involved here. The same would be true even for mode on EtherChannels where none of these two protocols is used.

Please feel welcome to disagree and debate this!

Best regards,

Peter

Etherchannel behaviour

No I did not mean the opposite device....just on the same device. I also agree about changing the port channel and it pushing it to the individual ports. I think what he was asking based on the info he provided was that the two things seemed to be contradicting. What I was saying is, on the same switch, if you are setup using PaGP and you change the port config it will dynamicly change all the other ports in the channel. If it is LACP if you make a change to the individual port it will only apply to that one port and not all the other ports in the channel.

Please correct me if I am mistaken. But that is what I got out of reading the two things mentioned. Peter I will rely on you to set me straight.

Mike

Cisco Employee

Re: Etherchannel behaviour

Hello Mike,

Well, I've performed an experiment and here are the results - posting as captured:

Sw2(config-if)#do show ether sum

Flags:  D - down        P - bundled in port-channel

        I - stand-alone s - suspended

        H - Hot-standby (LACP only)

        R - Layer3      S - Layer2

        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met

        u - unsuitable for bundling

        w - waiting to be aggregated

        d - default port

Number of channel-groups in use: 1

Number of aggregators:           1

Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

1      Po1(SU)         PAgP      Fa0/11(P)   Fa0/12(P)  

Sw2(config-if)#do show run int po1

Building configuration...

Current configuration : 92 bytes

!

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

end

Sw2(config-if)#do show run int fa0/11

Building configuration...

Current configuration : 127 bytes

!

interface FastEthernet0/11

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode desirable

end

Sw2(config-if)#do show run int fa0/12

Building configuration...

Current configuration : 127 bytes

!

interface FastEthernet0/12

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode desirable

end

Sw2(config-if)#int fa0/12

Sw2(config-if)#sw mo ac

Sw2(config-if)#

*Mar  2 05:33:28.508: %EC-5-CANNOT_BUNDLE2: Fa0/12 is not compatible with Fa0/11 and will be suspended (dtp mode of Fa0/12 is off, Fa0/11 is on)

*Mar  2 05:33:29.506: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state to down

Sw2(config-if)#

Sw2(config-if)#do show run int fa0/11

Building configuration...

Current configuration : 127 bytes

!

interface FastEthernet0/11

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode desirable

end

Sw2(config-if)#do show run int fa0/12

Building configuration...

Current configuration : 128 bytes

!

interface FastEthernet0/12

switchport trunk encapsulation dot1q

switchport mode access

channel-group 1 mode desirable

end

Sw2(config-if)#sw mo tr

Sw2(config-if)#

*Mar  2 05:34:11.482: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state to up

Sw2(config-if)#

Sw2(config-if)#

Sw2(config-if)#do show ether sum

Flags:  D - down        P - bundled in port-channel

        I - stand-alone s - suspended

        H - Hot-standby (LACP only)

        R - Layer3      S - Layer2

        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met

        u - unsuitable for bundling

        w - waiting to be aggregated

        d - default port

Number of channel-groups in use: 1

Number of aggregators:           1

Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

1      Po1(SU)         PAgP      Fa0/11(P)   Fa0/12(P)  

Sw2(config-if)#speed 10

Sw2(config-if)#

*Mar  2 05:34:34.132: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state to down

*Mar  2 05:34:37.974: %EC-5-CANNOT_BUNDLE2: Fa0/12 is not compatible with Fa0/11 and will be suspended (speed of Fa0/12 is 10M, Fa0/11 is 100M)

Sw2(config-if)#

Sw2(config-if)#do show ether sum

Flags:  D - down        P - bundled in port-channel

        I - stand-alone s - suspended

        H - Hot-standby (LACP only)

        R - Layer3      S - Layer2

        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met

        u - unsuitable for bundling

        w - waiting to be aggregated

        d - default port

Number of channel-groups in use: 1

Number of aggregators:           1

Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

1      Po1(SU)         PAgP      Fa0/11(P)   Fa0/12(s)  

Sw2(config-if)#do show run int fa0/11

Building configuration...

Current configuration : 127 bytes

!

interface FastEthernet0/11

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode desirable

end

Sw2(config-if)#do show run int fa0/12

Building configuration...

Current configuration : 137 bytes

!

interface FastEthernet0/12

switchport trunk encapsulation dot1q

switchport mode trunk

speed 10

channel-group 1 mode desirable

end

Sw2(config-if)#

Note that at first, I had a working PAgP-controlled EtherChannel on logical interface Po1 bundling together Fa0/11 and Fa0/12. Then, on Fa0/12, I've changed the mode from trunk to access. The switch merely complained that the port is incompatible and kicked it off the EtherChannel. As I show in subsequent commands, the Fa0/11 did not inherit the switchport mode access command even though PAgP was running and I entered this command on Fa0/12.

Afterwards, I have put Fa0/12 back to trunk mode and instead, I've reconfigured it statically to 10Mbps. Again, the switch complained and suspended the Fa0/12, claiming that Fa0/11 is running on different speed. And just as before, the setting of speed 100 was not carried over to Fa0/11.

So I believe that the book is not entirely correct on what it says. Perhaps the author is confusing PAgP and EtherChannel in general. However, I see no logical reason why should PAgP try to "equalize" the local configuration of physical ports. It can be done easily by always configuring the logical Port-channel interface, so why should PAgP duplicate this work.

PAgP and LACP are intended to negotiate whether ports can be used as a single EtherChannel on both interconnected devices, but apart from that, I don't ever recall seeing or reading anything that would go beyond this signalling/negotiating function.

Best regards,

Peter

Re: Etherchannel behaviour

Peter...thanks for the information. 5+

I was just going by the book and the Cisco website. It does appear the book is not correct. I think I will email him and see what exactly he was trying to say.

Peter, thank you as always.

Mike

Community Member

Etherchannel behaviour


Well Folks, many thanks for helping me clarify this doubt.

Regards,

Antonio

429
Views
10
Helpful
6
Replies
CreatePlease to create content