Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Etherchannel between 3750 and 2811

Is it possible to create an EtherChannel connection between a 3750 stack (2 members) and the onboard LAN interfaces in a 2811?

If yes, could you point me to some doc / configuration examples?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Etherchannel between 3750 and 2811

Hi KEITH,

Just got the answer on this for you.

Ether-channel is not supported on 2800 routers on the builtin FE ports. Its only supported on the etherswitch modules and the network modules on the routers.

Here is a bug for the same:

http://www.cisco.com/cgi-bin/Support/Bugtool/onebug.pl?bugid=CSCin55942

HTH, Please rate if it does.

-amit singh

17 REPLIES
New Member

Re: Etherchannel between 3750 and 2811

FYI - I have attempted a configuration based on the following, but with no luck so far;

http://www.cisco.com/en/US/products/hw/switches/ps628/products_configuration_example09186a00800ef797.shtml#req

Purple

Re: Etherchannel between 3750 and 2811

should work I would think , make sure the native vlan matches on each of the link .

New Member

Re: Etherchannel between 3750 and 2811

Go through the below links,

For Cisco IOS

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_configuration_example09186a0080094958.shtml

For CatIOS

http://cio.cisco.com/univercd/cc/td/doc/produ

ct/lan/cat6000/sw_6_3/confg_gd/channel.htm

Regards,

Suresh Jain

New Member

Re: Etherchannel between 3750 and 2811

I believe I have everything configured correctly, but for the life of me - I'm not seeing the error of my ways.

Attached are snipets from the config along with verification output.

Is the answer staring me in the face and it's time to break out the 2X4?

New Member

Re: Etherchannel between 3750 and 2811

Explanation of what doesn't work;

* EIGRP neighbors not being discovered between the Router and the Switch.

-- The switch does receive an EIGRP Hello, but route exchange and ACKS are not seen

-- The router never sees an EIGRP Hello from the switch

What does work;

* Interfaces are Up / Up on both sides

* Port-Channel up on both sides

* CDP neighbors seen both sides

So, what is not working is routing in this configuration.

If I use ports on the EtherSwitch module in the 2811 instead, I am able to get an EtherChannel configuration working between the switch and router.

What I am trying to understand is why I am not able to use the onboard Ethernet interfaces (FA0/0 & FA0/1) to accomplish this.

Thanks to anyone who can help educate me on this one.

Re: Etherchannel between 3750 and 2811

The only that we can make out of the configs is that 3750 ports are bundeled on layer2 ether-channel. While the routers ports ate bundeled on a layer 3 ether-channel.

I would suggest you take create a L3 port-channel on 3750 as well. Make the two bundeled ports as layaer 2 ports using "no switchport" under the interface and bundeled them to a layer-3 portchaneel with an IP address on it.

Let us know your findings on it.

-amit singh

New Member

Re: Etherchannel between 3750 and 2811

Thanks for your response - Still no luck :(

Any other thoughts?

###### SWITCH CONFIG ######

interface Port-channel1

no switchport

ip address 10.120.255.45 255.255.255.252

interface GigabitEthernet1/0/24

no switchport

no ip address

duplex full

speed 100

channel-group 1 mode on

interface GigabitEthernet2/0/24

no switchport

no ip address

duplex full

speed 100

channel-group 1 mode on

router eigrp 10499

redistribute connected

network 10.120.0.0 0.3.255.255

no auto-summary

###### ROUTER CONFIG ######

!

interface Port-channel1

no ip address

hold-queue 150 in

!

interface Port-channel1.44

encapsulation dot1Q 1 native

ip address 10.120.255.46 255.255.255.252

no snmp trap link-status

!

interface FastEthernet0/0

no ip address

duplex full

speed 100

channel-group 1

!

interface FastEthernet0/1

no ip address

duplex full

speed 100

channel-group 1

router eigrp 10499

redistribute connected

network 10.120.0.0 0.3.255.255

no auto-summary

###### RESULTS ######

NO ROUTING ACROSS Port-Channel Interfaces

>> Both sides see CDP neighbors

>> Switch receives EIGRP HELLO and UPDATE - but no ACK

>> Router not receiving EIGRP updates - sends HELLOS on Port-Channel1.44, but nothing back

**>> also tried the above config with 1 difference on router - no subinterface 1.44 and IP address on Port-Channel itself (same results)

Re: Etherchannel between 3750 and 2811

Hi,

Let the router be on port-channel only. Dont create the sub-interface for it.

Once done that, please paste the output of " show port-channel " from both the devices. Also attach the config for both the devices.

Can you ping the port-channel interfaces from either of the side?

Try to get some debugs for eigrp adjacency.

-amit singh

New Member

Re: Etherchannel between 3750 and 2811

Hi,

I am out of the office for the Thanksgiving holiday, returning on Monday. If time permits, I will go into the office and get this information before then.

Thank you and please check back.

New Member

Re: Etherchannel between 3750 and 2811

Attached are 2 files - 1 for the router and 1 for the switch\stack.

In each are the config, interface show, and debug output. I hope this covers everything you asked for.

P.S. I'm am unable to ping the port-channel interface(s) from either side.

Thanks in advance.

-Keith

Purple

Re: Etherchannel between 3750 and 2811

Are the 2 router ports on a HWIC ? If so you it won't support it . Here is a blurb from the card specs .

A. The Cisco EtherSwitch network modules and service modules support Cisco EtherChannel technology, including the Gigabit Ethernet ports. Up to eight ports with the same speed and duplex can be aggregated into a single channel group. The Cisco EtherSwitch HWICs do not support Cisco EtherChannel technology. If both a network module and an HWIC are used, the network module interfaces can be configured for Cisco EtherChannel technology, but those on the HWIC cannot.

New Member

Re: Etherchannel between 3750 and 2811

No, these are the 2 on-board ethernet ports FE0/0 and FE0/1.

Re: Etherchannel between 3750 and 2811

Hi,

After looking the debugs from both the sides I have oberseverd one thing that 3750 is sending the routing updates to router but router is not sending back the "Ack" to the 3750.2811 router is neither enqueuing any updates to send it to the 3750. Check the requence number and flags in the debugs.

One thing I have just notice the " hold-queue 0 in" command under the port-channel interface. Why that command it given there?. AFAIK this vlaue cannot be zero. This will prevent the router from sending the updates on the port-channel interface. Try removing this command and let us know your findings.

http://www.cisco.com/en/US/products/sw/iosswrel/ps5187/products_command_reference_chapter09186a008017d01f.html#wp1142192

HTH,

-amit singh

New Member

Re: Etherchannel between 3750 and 2811

Hi,

Made the changes but still no luck - same results. I'm really beginning to think this will not work.

If I make each interface (fa0/0 & fa0/1) separate layer 3 point to point interfaces, I am able to have redundant links back to the core switch. Either that or create a Layer 3 port-channel using ports on the switch module in the router work also.

What I was really hoping to end up with was a single Layer 3 interface using the "on-board" router interfaces for redundancy \ speed.

Any other ideas or is this looking like a dead horse?

I sure appreciate your feedback and help.

New Member

Re: Etherchannel between 3750 and 2811

My original question was "will this setup work with 3750 and 2811?"

I was hoping to end up with a configuration similar to the following;

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_configuration_example09186a0080094958.shtml

I was hoping it wasn't limited to the 7200 & 7500 class of routers.

Re: Etherchannel between 3750 and 2811

Hi KEITH,

Just got the answer on this for you.

Ether-channel is not supported on 2800 routers on the builtin FE ports. Its only supported on the etherswitch modules and the network modules on the routers.

Here is a bug for the same:

http://www.cisco.com/cgi-bin/Support/Bugtool/onebug.pl?bugid=CSCin55942

HTH, Please rate if it does.

-amit singh

New Member

Re: Etherchannel between 3750 and 2811

Thanks!

966
Views
3
Helpful
17
Replies