Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Etherchannel Between Two 4510R-E Switches

Hello,

I have two 4510R-E switches both running Sup6-E for the supervisor.  We've noticed some odd issues with traffic flowing between switches and I wanted to start off by getting a sanity check on the configuration.  Below is the config (identicle on the other switch except for the interface numbers) as it stands now.  I think during my next maintenance window, I will change the mode from desirable to on, but I'm not sure if that will make any difference.  So, I guess, my question is, what is the best configuration for the etherchannel between these two switches?

interface Port-channel2

description *** Uplink between 4510R-E switches ***

switchport

switchport mode trunk

switchport nonegotiate

interface GigabitEthernet2/15

description *** Uplink to BERN01PORS2 4510R ***

switchport mode trunk

switchport nonegotiate

channel-group 2 mode desirable

interface GigabitEthernet2/16

description *** Uplink to BERN01PORS2 4510R ***

switchport mode trunk

switchport nonegotiate

channel-group 2 mode desirable

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Etherchannel Between Two 4510R-E Switches

Hi Mark,

I think during my next maintenance window, I will change the mode from desirable to on

I wouldn't recommend to do so; using PAgP or LACP for negotiate the EtherChannel is the safer approach.

As far as I see, there's nothing wrong with your EtherChannel config.

What kind of media is used for interconnecting the switches? If it's fiber, do you have UDLD enabled on those links?

There are some useful show-commands to check channel status, distribution among the links and status changes (timestamps):

show etherchannel [] summary

show etherchannel [] port-channel

show pagp [] counters

Perhaps you could check if everything looks stable, of course you can post the output if you have any doubts.

Hope that helps

Rolf

5 REPLIES

Re: Etherchannel Between Two 4510R-E Switches

Hi Mark,

I think during my next maintenance window, I will change the mode from desirable to on

I wouldn't recommend to do so; using PAgP or LACP for negotiate the EtherChannel is the safer approach.

As far as I see, there's nothing wrong with your EtherChannel config.

What kind of media is used for interconnecting the switches? If it's fiber, do you have UDLD enabled on those links?

There are some useful show-commands to check channel status, distribution among the links and status changes (timestamps):

show etherchannel [] summary

show etherchannel [] port-channel

show pagp [] counters

Perhaps you could check if everything looks stable, of course you can post the output if you have any doubts.

Hope that helps

Rolf

Hall of Fame Super Gold

Etherchannel Between Two 4510R-E Switches

channel-group 2 mode desirable

If the EtherChannel is ONLY between two Cisco boxes, then I'd use "mode on".

Cisco Employee

Etherchannel Between Two 4510R-E Switches

I agree with Rolf.  be careful when using "Mode On" as I have seen this take down a network when one of the links comes unbundled for whatever reason.  You may also look into using UDLD to ensure your links function properly.

Purple

Re: Etherchannel Between Two 4510R-E Switches

The config is fine and what I always use and have never  had any issue with PAGP  channel negotiation .  Changing it to on will make no difference.  Myself I use desirable non-silent as the channel option .  LACP  is the other option .  I also manually prune off any unneeded vlans across the trunk links .

New Member

Re: Etherchannel Between Two 4510R-E Switches

Thanks everyone for the input.  I was pretty sure the config was sound, but I needed a sanity check.  I ran the show commands, and everything looked ok as well.  I think we've identified the issue to be something between our UCS system/Fabric Interconnects and the 4510 switches as the issue only appears on systems running within the UCS environment. 

Thanks again, and I will post in the UCS community should I have any quesitons regarding that.

Cheers,

Mark

337
Views
0
Helpful
5
Replies