Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Etherchannel configuration

I have blade server switches configured like this:

interface range GigabitEthernet0/20 - 22

description s41-lnsomnptc gig4/13

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 18 mode desirable

!

interface Port-channel18

switchport trunk encapsulation dot1q

switchport mode trunk

end

There are 3 GE interfaces in the bundle that are connected to a 4506. Here are the configs:

interface range GigabitEthernet4/13 - 16

description Etherchannel s1e8-lnsomnptc gig0/20

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 18 mode desirable

!

interface Port-channel18

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

We receive input errors on our 4506 on each of the GE interfaces associated with the channel and receive input errors on the port - channel it self. I was thinking about replacing all ETH connections but thought possibly if I hard code the GE interfaces to:

Speed 1000

Duplex full

On both ends (blade switch to 4506) this would clear this up? Most or all of our etherchannels are experinceing these input errors only on the 4506's. The servers connected to the blade switch are hard coded at speed 1000 duplex full. We also have a few other port-channels connected directly to the 4506 from a server that is hard coded on both ends with speed 1000 duplex full with no input errors.

Thank you,

12 REPLIES

Re: Etherchannel configuration

Hi,

1.Can you paste show interface for each individual member interface, as well as port-channel interface, where you are seeing the errors ?

2.Also instead of desirable mode use "ON" mode.

HTH..rate if helpful..

New Member

Re: Etherchannel configuration

I'm only sending one port-channel also this one I picked has errors but not nearly as much as others we have. If I turn the mode to on and a cable gets broke or unplugged the channel comes down. We've experinced that and do not want this to happen. Everything is set to desirable for this very reason.

s41-lnsomnptc#sh int port-channel 18

Port-channel18 is up, line protocol is up (connected)

Hardware is EtherChannel, address is 0015.2ba0.bf4c (bia 0015.2ba0.bf4c)

MTU 1500 bytes, BW 3000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 1000Mb/s, media type is N/A

input flow-control is off, output flow-control is unsupported

Members in this channel: Gi4/13 Gi4/14 Gi4/15

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:01, output never, output hang never

Last clearing of "show interface" counters 5w6d

Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 42237

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 1413000 bits/sec, 425 packets/sec

5 minute output rate 1390000 bits/sec, 634 packets/sec

2253606658 packets input, 766000045748 bytes, 0 no buffer

Received 5105983 broadcasts (3938716 multicast)

0 runts, 0 giants, 0 throttles

3316 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 input packets with dribble condition detected

3961610284 packets output, 2997840649292 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

s41-lnsomnptc#sh int g4/13

GigabitEthernet4/13 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet Port, address is 0015.2ba0.bf4c (bia 0015.2ba0.bf4c)

Description: Etherchannel s1e8-lnsomnptc gig0/20

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 1000Mb/s, link type is auto, media type is 10/100/1000-TX

input flow-control is off, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:01, output never, output hang never

Last clearing of "show interface" counters 5w6d

Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 21100

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 200000 bits/sec, 62 packets/sec

5 minute output rate 391000 bits/sec, 270 packets/sec

803351653 packets input, 240782139333 bytes, 0 no buffer

Received 3271290 broadcasts (2543101 multicast)

0 runts, 0 giants, 0 throttles

375 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 input packets with dribble condition detected

1027731550 packets output, 222824105797 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

New Member

Re: Etherchannel configuration

s41-lnsomnptc#sh int g4/14

GigabitEthernet4/14 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet Port, address is 0015.2ba0.bf4d (bia 0015.2ba0.bf4d)

Description: Etherchannel s1e8-lnsomnptc gig0/21

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 1000Mb/s, link type is auto, media type is 10/100/1000-TX

input flow-control is off, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:12, output never, output hang never

Last clearing of "show interface" counters 5w6d

Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 8764

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 118000 bits/sec, 47 packets/sec

5 minute output rate 668000 bits/sec, 215 packets/sec

846965834 packets input, 216071162241 bytes, 0 no buffer

Received 868099 broadcasts (716979 multicast)

0 runts, 0 giants, 0 throttles

2478 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 input packets with dribble condition detected

2437043255 packets output, 2633106117365 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

GigabitEthernet4/15 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet Port, address is 0015.2ba0.bf4e (bia 0015.2ba0.bf4e)

Description: Etherchannel s1e8-lnsomnptc gig0/22

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 1000Mb/s, link type is auto, media type is 10/100/1000-TX

input flow-control is off, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:13, output never, output hang never

Last clearing of "show interface" counters 5w6d

Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 12373

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 936000 bits/sec, 295 packets/sec

5 minute output rate 265000 bits/sec, 134 packets/sec

603311667 packets input, 309151396105 bytes, 0 no buffer

Received 966786 broadcasts (678743 multicast)

0 runts, 0 giants, 0 throttles

463 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 input packets with dribble condition detected

496863070 packets output, 141916341123 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

New Member

Re: Etherchannel configuration

s1e8-lnsomnptc#sh int g0/21

GigabitEthernet0/21 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet, address is 0013.19c1.b795 (bia 0013.19c1.b795)

Description: s41-lnsomnptc gig4/14

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive not set

Full-duplex, 1000Mb/s, link type is auto, media type is 10/100/1000BaseTX SFP

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:03, output 00:00:12, output hang never

Last clearing of "show interface" counters 2y17w

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 710000 bits/sec, 215 packets/sec

5 minute output rate 120000 bits/sec, 44 packets/sec

3181729260 packets input, 1081332602 bytes, 0 no buffer

Received 837962285 broadcasts (0 multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 412579382 multicast, 0 pause input

0 input packets with dribble condition detected

4033800741 packets output, 1727403559 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

s1e8-lnsomnptc#sh int g0/22

GigabitEthernet0/22 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet, address is 0013.19c1.b796 (bia 0013.19c1.b796)

Description: s41-lnsomnptc gig4/15

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive not set

Full-duplex, 1000Mb/s, link type is auto, media type is 10/100/1000BaseTX SFP

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:17, output 00:00:03, output hang never

Last clearing of "show interface" counters 2y17w

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 384000 bits/sec, 140 packets/sec

5 minute output rate 486000 bits/sec, 209 packets/sec

3847201200 packets input, 3658030998 bytes, 0 no buffer

Received 488891661 broadcasts (0 multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 208250169 multicast, 0 pause input

0 input packets with dribble condition detected

3593381534 packets output, 98605177 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

New Member

Re: Etherchannel configuration

s1e8-lnsomnptc#

s1e8-lnsomnptc#sh int g0/20

GigabitEthernet0/20 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet, address is 0013.19c1.b794 (bia 0013.19c1.b794)

Description: s41-lnsomnptc gig4/13

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive not set

Full-duplex, 1000Mb/s, link type is auto, media type is 10/100/1000BaseTX SFP

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:04, output 00:00:14, output hang never

Last clearing of "show interface" counters 2y17w

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 403000 bits/sec, 239 packets/sec

5 minute output rate 305000 bits/sec, 145 packets/sec

1259632742 packets input, 338315146 bytes, 0 no buffer

Received 3087492089 broadcasts (0 multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 2639705786 multicast, 0 pause input

0 input packets with dribble condition detected

707249779 packets output, 1891806013 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

Purple

Re: Etherchannel configuration

I would also check your code version for bugs like this , sometimes it is just cosmetic within a given code version .

New Member

Re: Etherchannel configuration

cat4000-i9s-mz.122-20.EWA2.bin

cat4000-i9s-mz.122-20.EWA2.bin

This is what they are both running on the core switches. Then:

(CGESM-I6L2-M), Version 12.2(25)SE1

(CGESM-I6L2-M), Version 12.2(25)SE1

running on the blade switches

New Member

Re: Etherchannel configuration

Hi Ted

I suspect that you could be over-subscribing your interface buffers which could cause the drops you are seeing. This also entirely depends on what modules you are using. I would possibly try and change your port channel so the interfaces are not in sequence, as in: use g0/1 and g0/9 and g0/17. Check what modules you are using and check the over-suscribed rates in relation to the Sups.

S

New Member

Re: Etherchannel configuration

I checked counters per module. Can you tell me the best way to check oversubscription on my modules? They are WS4548's and am running a cisco Cat6k-MSFC2 (R7000) IOS (tm) MSFC2 Software (C6MSFC2-JSV-M), Version 12.1(11b)E4, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

Re: Etherchannel configuration

Here is some information to check out.

http://www.cisco.com/en/US/prod/collateral/modules/ps2710/ps5494/product_data_sheet0900aecd802109ea.html

WS-X4548-GB-RJ45

• 48 ports

• 10/100/1000 module (RJ-45)

• Cisco IOS Software Release 12.1(19)EW or later

• IEEE 802.3x flow control

• Bandwidth is allocated across six 8-port groups, providing 1 Gbps per port group

• More power efficient and more cost effective than the WS-X4448-GB-RJ45

• Enterprise and commercial: designed for gigabit to the desktop

Note where it says Bandwidth is allocated across six 8-port groups, providing 1 Gbps per port group

You will have to split up the ports in your etherchannel so they are not all in the same group. Also make sure the group of ports does not have any other ether channels that would take up the bandwidth. Remember just because they are Gigabit ports does not mean they can all run at a Gigabit at the same time. I had to do this in our enviroment and it solved some of our problems.

Hope this helps,

Mike

New Member

Re: Etherchannel configuration

On the CGESM, I dont think autoneg works properly on the GLC-T= module. SO setting both sides to Speed 1000, duplex full. will probably fix your problem.

Purple

Re: Etherchannel configuration

I think you have to take a look at the load on the port-channel , hard to believe it would fill a 3 gig port channel but then again if the blade is fully populated you are running 14 servers down the one port channel . I doubt hardcoding will solve anything as gig is full duplex anyway . You could also play with the port channel load balancing algorithms to see if you can get a more equal traffic flow across the channels. Also the input errors aren't that great over a 5 week period , ideally you would like them to be zero but nothing is black and white in IT. :-)

359
Views
0
Helpful
12
Replies
CreatePlease to create content