Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

etherchannel doesn't come up because of "vtp domain mismatch"

we want to build an etherchannel (PaGP or LACP) between a Catalyst4000 and a Catalyst2960 with two GigEth-Ports on each switch. All 4 Ports are in Mode access (not Mode trunk!). when we try, there is an ERROR-Message "vtp domain mismatch" and one of the 2 Link's doesn't come up (gets down). Both PaGP and LACP don't work. Because one Switch is ISP-Euipment and one Switch is Customer-Equipment it isn't possible to make the VTP-Domains (including passwords) the same.

Is LACP (non Cisco properitary) using the Cisco VTP information ? I don't think so ... ---> ANY IDEA ???

regards, Ralf

2 ACCEPTED SOLUTIONS

Accepted Solutions
Silver

Re: etherchannel doesn't come up because of "vtp domain mismatch

Hi Ralf,

Workaround:

Disable the exchange of DTP packets by doing **switchport nonegotiate*** command on interfaces.

Thanks,

satish

Re: etherchannel doesn't come up because of "vtp domain mismatch

Ralf,

Did you try setting the etherchannel mode to 'on'. When I set the mode to on in my lab switches the port-channel interface came right up. I tried LACP and PAGP and it caused the ports to be suspended.

Satish, if you enter the command 'switchport mode access' doesn't that disable the exchange of DTP packets?

HTH

Sundar

4 REPLIES
Silver

Re: etherchannel doesn't come up because of "vtp domain mismatch

Hi Ralf,

Workaround:

Disable the exchange of DTP packets by doing **switchport nonegotiate*** command on interfaces.

Thanks,

satish

Re: etherchannel doesn't come up because of "vtp domain mismatch

Ralf,

Did you try setting the etherchannel mode to 'on'. When I set the mode to on in my lab switches the port-channel interface came right up. I tried LACP and PAGP and it caused the ports to be suspended.

Satish, if you enter the command 'switchport mode access' doesn't that disable the exchange of DTP packets?

HTH

Sundar

Purple

Re: etherchannel doesn't come up because of "vtp domain mismatch

I would make sure trunking is off on your ports , by default on the 2960's the trunk mode is desirable and will trunk with any switchport that is set as desirable or auto for trunk mode , think 4000's are auto as default . try the following.

?To enable trunking to a device that does not support DTP, use the switchport mode trunk and switchport nonegotiate interface configuration commands to cause the interface to become a trunk but to not generate DTP frames.

Re: etherchannel doesn't come up because of "vtp domain mismatch

Hi

Can u try this.ensure that u have the same vlan on the ports which are combined in the ether-channel.It doesnt matter the vtp domains are differnet.

Thanks

Mahmood

843
Views
0
Helpful
4
Replies
CreatePlease to create content