Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

etherchannel DOT1q tagging...

I have an non-Cisco L2 switch that needs to connect to a Cat 6509 via etherchannel using LACP. How do I assign a VLAN/dot1q encapsulation on the etherchannel/port-channel on the Cat6509 to identify the VLAN.

Here's my config;

6509-SW-01#sh run int fa3/15

Building configuration...

Current configuration : 154 bytes

!

interface FastEthernet3/15

description Kat testing--Sourcefire Mgmt

no ip address

shutdown

channel-protocol lacp

channel-group 15 mode active

end

6509-SW-01#sh run int fa3/16

Building configuration...

Current configuration : 113 bytes

!

interface FastEthernet3/16

description Kat testing--Foundry

no ip address

channel-group 15 mode active

end

6509-SW-01#sh run int port 15

Building configuration...

Current configuration : 47 bytes

!

interface Port-channel15

no ip address

end

6509-SW-01#

6 REPLIES
New Member

Re: etherchannel DOT1q tagging...

I'm assuming you're going to have multiple vlans going over that port-channel. I'm having a similar issue.

I create the port-channel and then the sub-interface. Then when I try using the command:

encapsulation dot1Q 161

I get an error:

Command rejected: VLAN 161 not available

The problem is that vlan 161 has been created and is active.

New Member

Re: etherchannel DOT1q tagging...

Were you able to create the sub-interface on the port-channel. The problem in my case is that VTP is enabled and cannot create a new VLAN.

Purple

Re: etherchannel DOT1q tagging...

It goes under the port channel interface. Native vlan has to match on each side. there are no sub interfaces involved .

switchport mode trunk

switchport trunk encapsulation dot1q

switchport trunk native vlan XXX

switchport trunk allowed xxx,xxx,xxx

New Member

Re: etherchannel DOT1q tagging...

Thank you.

Boyet

New Member

Re: etherchannel DOT1q tagging...

OK... I've gone and created the vlans as interfaces instead and assigned them the ip addresses, etc.

The problem now is that when i go onto the interface that is going to be the trunk and try using

switchport mode trunk

I get an error:

command rejected: Po37 not a switching port

I thought maybe it had to do with the fact that I was trying to do it on a port-channel, but i get the same issue while trying to use the command on a physical interface as well.

This is on a 6509 also.

IOS (tm) s72033_rp Software (s72033_rp-PK9SV-M), Version 12.2(17d)SXB8, RELEASE SOFTWARE (fc2)

New Member

Re: etherchannel DOT1q tagging...

Ahh... Nevermind. Just using the command switchport first allows you to set it up.

Thanks for the info Glen.

264
Views
0
Helpful
6
Replies