Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Etherchannel error

Hi folks,

running CAT 6513, IOS v12.2(33) (sxh)

created 2 trunks interfaces and attempted to add them to an etherchannel.  One of the interfaces continued to drop into an up/down(not connected) state with the following error in the log:

Jun  4 16:54:51: %EC-SP-5-CANNOT_BUNDLE2: Gi8/35 is not compatible with Gi4/28 and will be suspended (flow control send of Gi8/35 is on, Gi4/28 is off.

So, i disabled send flowcontrol on 8/35.  This allowed me to add to the EC, but i later looked at this interface and found it to be negotiating at 100mb full rather than 1gb full.

The EC is being used to trunk multiple vlans to a VMWare ESX host.  I thought possibly the NIC on the host was causing the problem, but found it to be set to auto-negotiate.

Any thoughts on this?

thanks.

Bruce

5 REPLIES
New Member

Re: Etherchannel error

I am a noob but I still wanted to ask you this:

Did you try turning flow control on both ends? Instead of having them both turned off?

Also, is there anyway you could be running different cables to the devices that are causing the incompatibility?

I hope you get this resolved. Let me know.

New Member

Re: Etherchannel error

New Member

Re: Etherchannel error

I'm hoping the originator of the thread will come back to let us know what happened

New Member

Re: Etherchannel error

well,

so far, it hasnt worked...I set the both switch interfaces (in my case 4/28 and 8/35) Send flow control to on, and when I added the second interface in the EC, it errored with a slightly different error stating that the first interface (4/28) flowcontrol status is "disagree".

so far, no resolution...

bruce

New Member

Re: Etherchannel error

Bruce

Is Auto-negotiation on the port enabled or disabled?

Enable it on both ports and use the sync-restart-delay command.

Just offering suggestions here.

HTH

Joe

1043
Views
0
Helpful
5
Replies