Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Etherchannel Issue on Cisco 6500

Hi,

I have configured ether-channel b/w 6500 and 3750 stack, and now the interface in ether-channel doesnt work and caused 3750 stack to go down.

I checked the interface on stack switch and found the ether-channel down, but where as the connecting port on 6500 was up.

I have already changed the fiber connections and also tried different ports at both ends but still the same issue.Hence have shut down one of the link and running without redundancy. If i enable the port then the port-channel goes down on 3750 not sure why is this happening.

Your help would be greatly appriciated.

REgards,

Neha

12 REPLIES

Re: Etherchannel Issue on Cisco 6500

Hi

can u post the configs...

Thanks

Mahmood

New Member

Re: Etherchannel Issue on Cisco 6500

HI,

Its an simple layer 2 etherchannel bunling.It was working fine before without any issue.We saw a mac address flap after that we rebooted the stack switch and the problem occured.

6500-int G3/5 and 3/6---- Etherchannel bundled ---3750 stack

interface Port-channel2

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-100

switchport mode trunk

no ip address

speed nonegotiate

interface GigabitEthernet3/5

description "Port 1 int Port-channel-3"

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-100

switchport mode trunk

no ip address

speed nonegotiate

channel-group 2 mode on

!

interface GigabitEthernet3/6

description "Port 2 int Port-channel-3"

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-100

switchport mode trunk

no ip address

shutdown-----------------------------------> Had to shut the port down due to issue with port-channel.

speed nonegotiate

channel-group 2 mode on

3750:

interface Port-channel3

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-100

switchport mode trunk

speed nonegotiate

interface GigabitEthernet3/0/1

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan 1-100

shutdown-----------------------------------> Had to shut the port down due to issue with port-channel.

channel-group 3 mode on

interface GigabitEthernet3/0/2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-100

switchport mode trunk

speed nonegotiate

channel-group 3 mode on

!

Summary: If I do no shut on the ports the port-channel will be admin down at 3750 and the interfaces will also be down.were as the other end(on 6500 ) the intefaces will be up.

New Member

Re: Etherchannel Issue on Cisco 6500

Could you please post the IOS versions of your devices.? On the other hand did you think to put the values for speed instead of speed no nonegotiate

Btw I will recommend you to try this IOS

System image file is "flash:c3750-ipservices-mz.122-35.SE5/c3750-ipservices-mz.1

22-35.SE5.bin" and try again.I hope it will work (make sure you backed up the things first to roll back)

Regards

Ersin

New Member

Re: Etherchannel Issue on Cisco 6500

Hi,

Please see the image file running on the switches:-

1) 6500

Version 12.2(18)SXF4

20

3750

Version 12.2(46)SE:c3750-ipbasek9-mz.122-46.SE/c3750-ipbasek9-mz.122-46.SE.bin"

Let me know if you required any furtther info.

Neha

Hall of Fame Super Bronze

Re: Etherchannel Issue on Cisco 6500

Please post the content of show log from each switch after doing the following:

a) clear log

b) try to etherchannel again

Also, post the output from typing show ether sum from both switches.

HTH,

__

Edison.

New Member

Re: Etherchannel Issue on Cisco 6500

hi,

a)I did it but could not see anything in the log about the channel going down.

I know its strange but no luck.

Do you think is this relating to bug or hardware or stp loop????

b)Also I have tried bundling with different ports on 3750 but no luck the int and prtchnl goes down.

Not sure what is causing it. What do you think this might be??????

HTH

Neha

Hall of Fame Super Bronze

Re: Etherchannel Issue on Cisco 6500

I can't help you without seeing the information that I asked for.

__

Edison.

New Member

Re: Etherchannel Issue on Cisco 6500

I am sorry but did not understand

You changed the IOS and it works now ?

Could you please more clear about what you did and sypmtoms ?

Thx

Ersin

New Member

Re: Etherchannel Issue on Cisco 6500

Do you have a chance to change the IOS like I said ?

Please again make sure about the backup for rolling back

New Member

Re: Etherchannel Issue on Cisco 6500

Hi,

So do you recommend me to change the ios which is currently running to :

System image file is "flash:c3750-ipservices-mz.122-35.SE5/c3750-ipservices-mz.1

22-35.SE5.bin" ???

New Member

Re: Etherchannel Issue on Cisco 6500

Hello Neha

Is active 3750 is productive ?

If yes do you have another 3750 with you ?

If yes try to change its IOS and try to migrate to 6509.If you do not have it try this one when 3750 is not active (maybe during night)

On the other define speeds manually instead of nonegotiate

Sorry that is all I know because I tried and worked

Bronze

Re: Etherchannel Issue on Cisco 6500

interface GigabitEthernet3/0/1

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan 1-100

shutdown-----------------------------------> Had to shut the port down due to issue with port-channel.

channel-group 3 mode on

Just a remark:

This port does not have "speed nonegotiate" defined on it. the other side has. Make sure "speed nonegotiate" is defined on BOTH sides or it will not work. Actually, i recommend NOT using "speed nonegotiate" ,especially on gigabit interfaces.

231
Views
0
Helpful
12
Replies
CreatePlease to create content