Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

Etherchannel issue, Port-Channel down down but correctly configured

Hello everybody:

I has a issue about etherchannel beetwen 02 Catalyst 6500 switch, i need your comment about it. if you had any similar experience:

1.- On Catalyst Switch 6500-1:


     I configured interface port-channel 4 and associated it to G6/29 and G6/30

interface Port-channel4
description IUU1_Gn1_HLIMSGSN01_Port_channel_6_29_6_30
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 406,408
switchport mode trunk
switchport nonegotiate
logging event link-status
load-interval 30
mls qos vlan-based
mls qos trust dscp
!


2.- On Catalyst Switch 6500-2:


     I configured interface port-channel 4 and associated it to G6/29 and G6/30

interface Port-channel4

description IUU2_Gn2_HLIMSGSN01_Port_channel_6_29_6_30

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 407,409

switchport mode trunk

switchport nonegotiate

logging event link-status

load-interval 30

mls qos vlan-based

mls qos trust dscp

3.- When i see on both switches "show interface Po4" these appear in line Down and Protocol Down.

SWGPRS02-ST1#show int po4

Port-channel4 is down, line protocol is down (disconnected)

  Hardware is EtherChannel, address is 1cdf.0fbe.d26d (bia 1cdf.0fbe.d26d)

  Description: IUU2_Gn2_HLIMSGSN01_Port_channel_6_29_6_30

  MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec,

4.- When i put the command on switch-1 "show etherchannel summary" i see:

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SD)         LACP      Gi9/4(D)      
2      Po2(SU)          -        Gi1/31(P)      Gi2/28(P)     
3      Po3(SU)          -        Gi1/34(P)      Gi1/40(P)      Gi2/40(D)     
                                 Gi2/48(D)      Gi6/15(P)      Gi6/18(P)     
4      Po4A(SU)         LACP      Gi6/29(P)      Gi6/30(P)     
5      Po5(SU)         LACP      Gi6/31(P)      Gi6/32(P)     
6      Po6(SU)         LACP      Te4/3(P)      
7      Po7(RU)          -        Gi1/39(P)      Gi2/46(P)      Gi2/47(P)

    when i put the command on switch-2 "show etherchannel summary" i see:


2      Po2(SD)          -        Gi2/28(D)     
3      Po3(SU)          -        Gi1/34(P)      Gi1/40(P)      Gi6/15(P)     
                                 Gi6/18(P)     
4     Po4B(SU)         LACP      Gi6/29(P)      Gi6/30(P)     
5      Po5(SU)         LACP      Gi6/31(P)      Gi6/32(P)     
6      Po6(SU)         LACP      Te4/3(P)      
7      Po7(RU)          -        Gi1/39(P)      Gi2/46(P)      Gi2/47(P)     
8      Po8(SU)         LACP      Te4/4(P)      

and i see output "show interface Po4A" up up on switch-1, "show interface Po4B" up up on switch-2   

5.- In the show running-config not appear configured Po4A and Po4B. it only show on outputs

6.- Po4A and Po4 was not configured on neither switches, my question is why appear Po4A and Po4B on switch-1 and switch-2 respectively?   and why Po4 appear in down down.

7.- I solved this issue by shutdown and not shutdown to the interfaces on both routers, currently all is OK, but i want if you have any ideas about this issue.

Thanks a lot in advance

4 REPLIES
New Member

Etherchannel issue, Port-Channel down down but correctly configu

do you mind posting the interfaces configuration tied to the port channels...to further assist...

thanks

Gold

Re: Etherchannel issue, Port-Channel down down but correctly con

Hello,

since you problem is solved with a shutdown / no shutdown, I just explain about the secondary port creation (Po4A/B):

Here are a few probable causes which trigger such issues (Creation of a Secondary Port Channel) with LACP port channels:

1. Adding a new port to an existing port channel. If any configuration mismatch is seen on the newly added port, it will be added to Secondary port-channel as you can see (Here, Po4A)

2. Configuration mismatch on the ports bundled in the port channel.

3. Configuration mismatch on the interfaces of the far end device can also create inconsistency between the ports bundled in the port channel.

This is expected behavior. The exact reason will be shown in the Logs while adding the port to port-channel.

'mls qos channel-consistency' is one of the reason which will put the port in to secondary port-channel.

The first step to resolve this issue is to look for the command "mls qos channel-consistency" in the interface configuration or to recreate the port channel following the best practices mentioned below.

The best practices in resolving port channel issues are:

1. Manually shut the bundled interfaces and the port channel interface down on both the end. 2. Then reset the interface configuration to default.

3. Reconfigure the interfaces to be bundled and assign them to the port channel. 4. Verify the configuration of the interfaces. 5. Bring up the interfaces after the configuration has been verified.

This is a known and an expected behavior with LACP. If LACP is not a mandatory requirement, you may recreate the port channel with the channel mode "ON".

plz Rate if it helped.

Soroush.

Hope it Helps!

Soroush.
Purple

Re: Etherchannel issue, Port-Channel down down but correctly con

  Can't imagine that channel works too well seeing you have different allowed vlans on each side of that channel .  Could be why it segmented the channel to begin with .

New Member

Etherchannel issue, Port-Channel down down but correctly configu

Read up on the creation of secondary aggregator ports Po(n)A and Po(n)B..

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_configuration_example09186a0080094470.shtml#po1a

The configuration doesn't match on the two switches for the Port-Channel as you've allowed different VLANs on the trunks, therefore it created the secondary aggregator ports.

"An EtherChannel supports the same allowed range of VLANs on all the LAN ports in a trunking Layer 2 EtherChannel. If the allowed range of VLANs is not the same, the LAN ports do not form an EtherChannel."

Here I'm just assuming your port configuration.. Are you sure a shut/no shut fixed this?

32325
Views
5
Helpful
4
Replies
CreatePlease to create content