Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Etherchannel L3 from 6509 to 3750 doesn't work

Hi, I have six Gigabit ports in Channel.

I tried mode On, Lacp,Pagp, Etherchannel go up but some links flapping and comunication is broken.

6509:

interface Port-channel2

ip address 192.12.47.254 255.255.255.252

ip sap listen

ip ospf cost 2

!

interface GigabitEthernet9/19

no ip address

no cdp enable

channel-protocol pagp

channel-group 2 mode desirable

!

interface GigabitEthernet9/20

no ip address

no cdp enable

channel-protocol pagp

channel-group 2 mode desirable

!

interface GigabitEthernet9/21

no ip address

no cdp enable

channel-protocol pagp

channel-group 2 mode desirable

!

interface GigabitEthernet9/22

no ip address

no cdp enable

channel-protocol pagp

channel-group 2 mode desirable

!

interface GigabitEthernet9/23

no ip address

no cdp enable

channel-protocol pagp

channel-group 2 mode desirable

!

interface GigabitEthernet9/24

no ip address

no cdp enable

channel-protocol pagp

channel-group 2 mode desirable

!

3750:

interface Port-channel1

ip address 192.12.47.253 255.255.255.252

ip sap listen

ip ospf cost 2

!

interface GigabitEthernet3/0/7

no ip address

no cdp enable

channel-protocol pagp

channel-group 1 mode desirable

!

interface GigabitEthernet3/0/8

no ip address

no cdp enable

channel-protocol pagp

channel-group 1 mode desirable

!

interface GigabitEthernet3/0/9

no ip address

no cdp enable

channel-protocol pagp

channel-group 1 mode desirable

!

interface GigabitEthernet3/0/10

no ip address

no cdp enable

channel-protocol pagp

channel-group 1 mode desirable

!

interface GigabitEthernet3/0/11

no ip address

no cdp enable

channel-protocol pagp

channel-group 1 mode desirable

!

interface GigabitEthernet3/0/12

no ip address

no cdp enable

channel-protocol pagp

channel-group 1 mode desirable

!

Log from 6509:

Oct 18 18:03:47: %EC-SP-5-L3DONTBNDL1: Gi9/21 suspended: PAgP not enabled on the

remote port.

Why?

Thanks

3 REPLIES
Purple

Re: Etherchannel L3 from 6509 to 3750 doesn't work

config looks correct . I would look for physical layer issues on the flapping ports . Also on the 3750 I would use crossover cables and turn off mdix on the ports , we have seen weird stuff with mdix on occasions. I usually use the parameter of non-silent after the desirable statement , I know it works because we have a 3750 to 6509 trunk set this way and have never had a problem.

New Member

Re: Etherchannel L3 from 6509 to 3750 doesn't work

Hi, I tried to set non-silent command under port-channel configuration but It remain down.

I'm using Sfp 1000Sx to connect 3750 to 6509 and Mdix is disabled.

What Ios version do you have in your Switch?

Some ports are Up, some ports are Down:

Oct 18 18:03:47: %EC-SP-5-L3DONTBNDL1: Gi9/21 suspended: PAgP not enabled on the

remote port. Oct 18 18:03:47: %EC-SP-5-L3DONTBNDL1: Gi9/21 suspended: PAgP not enabled on the

remote port.

Thanks

New Member

Re: Etherchannel L3 from 6509 to 3750 doesn't work

I believe both ends of the channel need to be in the same channel-group.

hth

543
Views
0
Helpful
3
Replies