Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

EtherChannel - Long Time between LINK-3-UPDOWN and LINEPROTO-5-UPDOWN:

Hi,

On a WS-C3750X it tooks 1 minute after connecting a port to change the status from LINK-3-UPDOWN "up" to LINEPROTO-5-UPDOWN "up"

Mar 27 16:25:37 192.168.1.144 788: *Mar  8 00:30:48.032: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/1, changed state to up
Mar 27 16:26:38 192.168.1.144 790: *Mar  8 00:31:49.227: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/1, changed state to up

Mar 27 16:25:54 192.168.1.144 789: *Mar  8 00:31:05.086: %LINK-3-UPDOWN: Interface GigabitEthernet2/0/1, changed state to up
Mar 27 16:26:56 192.168.1.144 791: *Mar  8 00:32:06.583: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/0/1, changed state to up

The ports are configured like that:

interface GigabitEthernet1/0/1
switchport access vlan 27

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

channel-group 1 mode passive !

interface GigabitEthernet2/0/1

switchport access vlan 27

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

channel-group 1 mode passive

!

interface Port-channel1

switchport access vlan 27

switchport mode access

end

The server which is connected has nothing special configured...

Does anyone have an idea why this takes so long?

Thanks!

Cheers,

Tobias

Everyone's tags (3)
2 REPLIES
VIP Super Bronze

EtherChannel - Long Time between LINK-3-UPDOWN and LINEPROTO-5-U

Hi,

Is LACP also configured on the server side?

Also, usually the switch runs in active mode and server is passive mode

channel-group 1 mode active

Can you test again?

HTH
New Member

Re: EtherChannel - Long Time between LINK-3-UPDOWN and LINEPROTO

Hi,

No, LACP is not configured on the server during boot/dhcp/pxe. It's configured later on in the Linux OS (and this works, but also takes 60 seconds between link up and protocol up). I've changed to mode active, but that did not change anything. I had mode passive because I read somewhere that dhcp/pxe does only work with this mode. But after changing to active it still works, but it takes a long time to get the lease because of the mentioned problem...

Cheers,

Tobias

This is how it looks when Linux is booting up and configure the links:

Mar 29 09:02:10 192.168.1.144 1655: *Mar  9 17:07:27.138: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/1, changed state to down

Mar 29 09:02:11 192.168.1.144 1656: *Mar  9 17:07:27.364: %LINK-3-UPDOWN: Interface GigabitEthernet2/0/1, changed state to down

Mar 29 09:02:13 192.168.1.144 1657: *Mar  9 17:07:29.520: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/1, changed state to up

Mar 29 09:02:31 192.168.1.144 1658: *Mar  9 17:07:47.748: %LINK-3-UPDOWN: Interface GigabitEthernet2/0/1, changed state to up

Mar 29 09:03:09 192.168.1.144 1659: *Mar  9 17:08:25.346: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/1, changed state to up

Mar 29 09:03:10 192.168.1.144 1660: *Mar  9 17:08:26.344: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up

Mar 29 09:03:11 192.168.1.144 1661: *Mar  9 17:08:27.225: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/0/1, changed state to up

Mar 29 09:03:11 192.168.1.144 1662: *Mar  9 17:08:27.351: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up
951
Views
0
Helpful
2
Replies