Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

EtherChannel / Port Groups / Switch trunk/LAG | 2960S

Hi all,

We recently upgraded to a some 48 port 2960S Catalysts and I have setup EtherChannel between the two of them.  I'm no expert here, so I just want to get some feedback on how I configured it.  I'm not having any noticable issues with the config, but I'd like to know I did it right (or wrong) and the way it "should" be.

I grouped two ports, and here are the snippets from my config:

interface Port-channel5

description Switch Trunk LAG

switchport mode trunk

interface GigabitEthernet1/0/47

description Switch LAG

switchport mode trunk

channel-protocol lacp

channel-group 5 mode active

!

interface GigabitEthernet1/0/48

description Switch LAG

switchport mode trunk

channel-protocol lacp

channel-group 5 mode active

I just read something that made me wonder if the post should be mode access instead of mode trunk, which is what prompted me to post here to the experts.

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions

Re: EtherChannel / Port Groups / Switch trunk/LAG | 2960S

There doesn't seem to be anything wrong with it.

You can create it as a trunk, access port, or a L3 port, whatever floats your boat.

I would also look at port-channel load-balancing' This is based on a hash of the following.

src-mac

dst-mac

src-dst-mac

src-dst-ip

etc etc. Just know what kinda  traffic is going through.

You can configure load balancing by 'port-channel load-balance ?'

Also, run the command 'show etherchannel summary'

It should be in a SU state.

11 REPLIES

Re: EtherChannel / Port Groups / Switch trunk/LAG | 2960S

There doesn't seem to be anything wrong with it.

You can create it as a trunk, access port, or a L3 port, whatever floats your boat.

I would also look at port-channel load-balancing' This is based on a hash of the following.

src-mac

dst-mac

src-dst-mac

src-dst-ip

etc etc. Just know what kinda  traffic is going through.

You can configure load balancing by 'port-channel load-balance ?'

Also, run the command 'show etherchannel summary'

It should be in a SU state.

New Member

EtherChannel / Port Groups / Switch trunk/LAG | 2960S

Thanks.

So, do I need "channel-protocol lacp"?  I know EtherChannel and LACP are similar but Etherchannel is Cisco's proprietary if I understand correctly.  So, if I take out the LACP line, does it run in proprietary EtherChannel?  Better?  Same?  And also, what benefit/side effects would I get if the switchports were in access mode?

I've basically got all my servers on one switch and all myworkstations on the other with tons of traffic (windows file shares, sql, etc).  10 servers, 30 workstations.  And am looking for the best performance with what I have.

EtherChannel / Port Groups / Switch trunk/LAG | 2960S

Actually, lacp is industry standard and pagp is cisco-proprietary. Etherchannel is a term used to describe the technology used. Technically, you don't need to specify lacp, but you'd configure it as a "channel-group mode active" or "channel-group mode passive" to enable lacp negotiation.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

EtherChannel / Port Groups / Switch trunk/LAG | 2960S

Ok, cool.  So what I have is good and there aren't really any changes that would have a substantial impact on performance.

Appreciate all the feedback!

EtherChannel / Port Groups / Switch trunk/LAG | 2960S

Also just a FYI, I believe if you change the Etherchannel load balancing options, you will have to re-create the Etherchannel.

Anyway, glad we were able to help you out.

Cisco Employee

EtherChannel / Port Groups / Switch trunk/LAG | 2960S

Hi John,

Also just a FYI, I believe if you change the Etherchannel load balancing options, you will have to re-create the Etherchannel.

No, that is not necessary. You can change the load balancing mechanisms on the fly. You would need to recreate an EtherChannel if you changed the mode between Layer2 and Layer3.

Best regards,

Peter

EtherChannel / Port Groups / Switch trunk/LAG | 2960S

I think I've been reading some wrong documentation...... Freakin Cisco.

I've actually made the changes on the fly, and ran the 'test' command, but never technically investigated the traffic.

Peter, is it possible to have different load-balancing algrithms on each side?

Sorry for the questions Peter, some times documentation can be confusing.

Cisco Employee

EtherChannel / Port Groups / Switch trunk/LAG | 2960S

John,

First of all, don't be sorry for any questions here! Your questions are absolutely appropriate, and after all, this entire forum is all about questions (and hopefully, answers)

I think I've been reading some wrong documentation...... Freakin Cisco.

Perhaps it was necessary on some selected platforms but my knowledge is that the load balancing algorithm can be changed on the fly without recreating the EtherChannels.

Peter, is it possible to have different load-balancing algrithms on each side?

Yes, absolutely, and in fact, it is often desired, especially when the load balancing mechanism takes only a single address field into account.

Best regards,

Peter

New Member

EtherChannel / Port Groups / Switch trunk/LAG | 2960S

John,

What is the test command you mention above?  Is that only for load balancing?

EtherChannel / Port Groups / Switch trunk/LAG | 2960S

Yeah, it's really only used to test load balancing.

If you type in 'test ?' I belive it's under 'test etherchannel' or something lilke that.

New Member

EtherChannel / Port Groups / Switch trunk/LAG | 2960S

Thanks.  All this info has been helpful.

Much apprecaited guys!

647
Views
30
Helpful
11
Replies
CreatePlease login to create content