Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

etherchannel portfast

Can i use spantree portfast on etherchannel links?

7 REPLIES
New Member

etherchannel portfast

i am trying to configure etherchannel between dell esxi host and a 6509

interface Port-channel1

switchport

switchport access vlan 120

switchport mode access

no ip address

shutdown

interface GigabitEthernet5/5

switchport

switchport access vlan 120

switchport mode access

no ip address

spanning-tree portfast

channel-group 1 mode on

interface GigabitEthernet5/4

switchport

switchport access vlan 120

switchport mode access

no ip address

spanning-tree portfast

channel-group 1 mode on


is this ok configuration?

channel-group 1 mode has several options

active     Enable LACP unconditionally

  auto       Enable PAgP only if a PAgP device is detected

  desirable  Enable PAgP unconditionally

  on         Enable Etherchannel only

  passive    Enable LACP only if a LACP device is detected

what option should i use?

Re: etherchannel portfast

Personally, I wouldn't do it. If for some reason your etherchannel breaks and spanning tree sees each link as individual links instead of the port-channel as a whole, you're asking for trouble.

As far as your modes, I'd select active or desirable on both ends. "On" mode doesn't use a negotiation protocol, but Active (LACP) or Desirable (Pagp) uses negotiation for the other end. The Active and Desirable modes actively try to form an etherchannel, whereas the Passive and Auto modes listen for the negotiation but don't try to actively form an etherchannel.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

etherchannel portfast

hi

I configured the port channel but show etherchannel 1 summary is showing this

SE6509#show etherchannel 1 summary

Flags:  D - down        P - bundled in port-channel

        I - stand-alone s - suspended

        H - Hot-standby (LACP only)

        R - Layer3      S - Layer2

        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met

        u - unsuitable for bundling

        w - waiting to be aggregated

Number of channel-groups in use: 1

Number of aggregators:           1

Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

1      Po1(SD)         LACP      Gi5/4(I)   Gi5/5(I)  

why is the Portchannel in a SD state? It means its down?

Re: etherchannel portfast

Yes, it's down. Are the ports physically up? Have you configured the other side?

I also noticed that the port channel interface is shut...

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
Purple

etherchannel portfast

  The device on the far end has to be setup as an LACP negotiated etherchannel also for it work . Talk to the people who support the dell.

New Member

etherchannel portfast

the other end is a esxi host. from he documentation, I have setup the nics to route based on IP hash but still the port channel is in a down state

Hall of Fame Super Blue

etherchannel portfast

Tony

It's not to do with the load balancing method ie. IP hash it is far more fundamental than that. The ESXi host is not forming an etherchannel with the switch.

You need to check the host end.

Jon

651
Views
0
Helpful
7
Replies
CreatePlease to create content