Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ETHERCHANNEL PROBLEM

Hello to everyone,

I have a problem with an etherchannel between a cisco 2950 and a couple of catalyst 4506.

The  cisco 2950 is connect via an etherchannel to the catalyst 4506A. The  channel consist of two port on both side and is in trunk mode,  encapsulation dot1q.

Now i have the necessity to connect the 2950 to the other catalyst, 4506B.

So,  i copy the same configuration on the 4506B, but when I unplug the two  rj45 cables from the catalyst 4506A to plug them in the 4506B the  etherchannel doesn't go up in any way.

Sorry i'm becoming crazy.

Have you some idea?

Thank's.

1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Re: ETHERCHANNEL PROBLEM

  I'll throw the obvious out there , are you using crossover cables ?   Or did the 4506A have a module that supported mdix while the new does does not ? 

8 REPLIES
Cisco Employee

ETHERCHANNEL PROBLEM

Hello,

Can you please post the configuration of the EtherChannel both from your 2950 and 4506A and 4506B? Are you trying to have two EtherChannels on 2950 at the same time, one going to 4506A and the second to 4506B?

Best regards,

Peter

New Member

ETHERCHANNEL PROBLEM

Yes.

Here you are the configuration of the functioning ethrchannel:

4506A

interface Port-channel5

description *** FEC --> SW2950 ***

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

interface GigabitEthernet6/1

description *** FEC --> SW2950 ***

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 5 mode on

!

interface GigabitEthernet6/2

description *** FEC --> SW2950 ***

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 5 mode on

2950

interface Port-channel1

description FEC --> SW4506

switchport mode trunk

interface FastEthernet0/23

switchport mode trunk

channel-group 1 mode on

!

interface FastEthernet0/24

switchport mode trunk

channel-group 1 mode on

4506B

interface Port-channel4

description *** FEC --> SW2950 ***

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

interface FastEthernet5/5

description *** FEC --> SW2950 ***

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 4 mode on

!

interface FastEthernet5/6

description *** FEC --> SW2950 ***

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 4 mode on

The configuration of the 2950 is the same.

Thanks.

New Member

ETHERCHANNEL PROBLEM

Hii,

When you copy a running config no shut command is not shown in the running config. so when you copy it no shut command is not present.

So give a no shut command on 4506B catalyst ports and i guess it should work.

HTH,

Sukanya

PS: Please rate helpfull post...

Cisco Employee

ETHERCHANNEL PROBLEM

Hello,

The configuration seems to be okay so far. How exactly do you know that the EtherChannel does not come up? Are there any logging messages displayed on the console? Any other symptoms, no matter how insignificant they may seem?

Do I understand you correctly that what you do currently is taking the cables from 4506A and plugging them into 4506B, so that on 2950, there is only a single EtherChannel active at any time?

Best regards,

Peter

Purple

Re: ETHERCHANNEL PROBLEM

  I'll throw the obvious out there , are you using crossover cables ?   Or did the 4506A have a module that supported mdix while the new does does not ? 

New Member

ETHERCHANNEL PROBLEM

I solved,

glen.grant was right it was the most stupid thing. The module WS-X4232-GB-RJ needs the cross cable!!!

Thank to everyone for the support.

ETHERCHANNEL PROBLEM

can try once with the below command with the straight cable  if you get chance.

instead of channel group mode on make it as mode active...

Cisco Employee

ETHERCHANNEL PROBLEM

Glen,

+5 points! You're a genius here. I would never think of this although I am aware that 2950 do not have the auto-MDIX functionality. Well done, and thanks for reminding us about these tiny wonderful quirks!

Best regards,

Peter

350
Views
5
Helpful
8
Replies
CreatePlease login to create content