Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Etherchannel problem

I have a 3750 stack in one of my MDFs, this stack connects to 4 additional 3750 stacks via redundant fiber connections (2 connections to each IDF). I have bundled each of the fiber connections, but I just noticed that when I do a "show etherchannel detail" on the core stack there is only 1 port active in each etherchannel. When I remove the channel-group configuration at the interface level and then put it back, one port in the bundle immediatly leaves the group. The interface configuration is as follows:

!

interface GigabitEthernet1/0/1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet2/0/1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

!

The "show etherchannel 1 detail" gives the following:

Group state = L2

Ports: 2 Maxports = 8

Port-channels: 1 Max Port-channels = 1

Protocol: -

Minimum Links: 0

Ports in the group:

-------------------

Port: Gi1/0/1

------------

Port state = Up Mstr In-Bndl

Channel group = 1 Mode = On Gcchange = -

Port-channel = Po1 GC = - Pseudo port-channel = Po1

Port index = 0 Load = 0x00 Protocol = -

Age of the port in the current state: 0d:00h:07m:29s

Port-channels in the group:

---------------------------

Port-channel: Po1

------------

Age of the Port-channel = 10d:18h:27m:21s

Logical slot/port = 10/1 Number of ports = 2

GC = 0x00000000 HotStandBy port = null

Port state = Port-channel Ag-Inuse

Protocol = -

Port security = Disabled

Ports in the Port-channel:

Index Load Port EC state No of bits

------+------+------+------------------+-----------

0 00 Gi1/0/1 On 0

Time since last port bundled: 0d:00h:07m:29s Gi2/0/1

Time since last port Un-bundled: 0d:00h:09m:53s Gi1/0/1

  • LAN Switching and Routing
10 REPLIES

Re: Etherchannel problem

Is it possible that the problem lies at the other end of this channel link? Are the two corresponding ports on the other end of the link correctly configured and bundled? This is the sort of behavior I might expect if the two ports making the bundle at the other end are mismatched and therefore unable to form a bundle.

Maybe they are crossed between different distribution switches. At the core switch, if you show cdp neighbors, are these two ports connected where you think they are connected?

Kevin Dorrell

Luxembourg

New Member

Re: Etherchannel problem

It doesn't appear that is the case, i have confirmed the ports are correctly configured and bundled, at least the configuration is exactly the same on the interfaces. In fact a "show etherchannel detail" on the other side shows a good bundle. They are connected where I think they are.

New Member

Re: Etherchannel problem

What is IOS Release? 12.2(40)SE?

New Member

Re: Etherchannel problem

Yes, in fact we had recently upgraded to the 12.2(40)SE

Have you seen the same problem?

New Member

Re: Etherchannel problem

New Member

Re: Etherchannel problem

Check that you are using a LACP trunk. PAgP is not supported for etherchannels across chassis.

"PAgP cannot be enabled on cross-stack EtherChannels while LACP is supported on cross-stack EtherChannels from Cisco IOS Software Release 12.2(25)SEC and later. "

http://www.cisco.com/en/US/products/hw/switches/ps5023/products_configuration_example09186a00806cb982.shtml#lacp

Purple

Re: Etherchannel problem

No he is forcing the etherchannel on which is ok on crosstack etherchannel. that is the problem when you force on a etherchannel it can look like it is working like on one side like you are seeing , you might want to try and use lacp instead and see what happens.

New Member

Re: Etherchannel problem

It is not helping! =). I tested Cross-Stack Etherchannel in both mode. Result was the same. I changed even Stack Master (from switch 1 to 2) and after election the bundled port Gi1/0/1 is displayed in the Etherchannel only through 'remote command 1 sh etherchannel 1 port', but all is working. =)

It is IOS Release 12.2(40)SE bug. I am fully confident.

New Member

Re: Etherchannel problem

I did the same last night and came to the same conclusion. Thank you for your help with this.

308
Views
5
Helpful
10
Replies