Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

etherchannel problems between 6509 and 3750 stack

6509 is running IOS ver 72033.advipservcesk9_wan_mz.122-33.SXH2a

3750 stack consists of one 3750g-24ts and one 3750-24p running ipbasek9-122.46(SE).

When each end configured for "channel-group n mode on" the 3750 ports go into err-disable. With each end configured for "channel-group n mode desirable" 3750 will fail because PAgP does not work across stack, etherchannel ports need to be on same switch.

Has anyone else seen this problem and what action was taken to overcome this problem?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: etherchannel problems between 6509 and 3750 stack

Hi Rob,

Follow this link to setup the Ether-Channels

http://www.cisco.com/en/US/products/hw/switches/ps5023/products_configuration_example09186a00806cb982.shtml

Hope This helps

Shaheen

5 REPLIES
Community Member

Re: etherchannel problems between 6509 and 3750 stack

Configure the etherchannel with the commands ( channel-group n mode )instaed of desirable.Pleaseet me know how its working once it is done.

Re: etherchannel problems between 6509 and 3750 stack

Hi Rob,

Follow this link to setup the Ether-Channels

http://www.cisco.com/en/US/products/hw/switches/ps5023/products_configuration_example09186a00806cb982.shtml

Hope This helps

Shaheen

Cisco Employee

Re: etherchannel problems between 6509 and 3750 stack

When it does happen can you collect o/p of

show errdisable recovery

show errdisable flap-values

Purple

Re: etherchannel problems between 6509 and 3750 stack

I also recommend using LACP to set up the etherchannels. "channel-group 1 mode active" on both ends . There should be no problems once you do this , we have this same setup going all over.

Community Member

Re: etherchannel problems between 6509 and 3750 stack

Setting the "channel-group n mode on" command works providing you set the channel-group on the 3750 stack first, then the 6500 core node. Otherwise for some reason the switch ports go into "err-disable" and the ports have to be shut/no shut and the port-channel definition deleted and then re-instated.

433
Views
2
Helpful
5
Replies
CreatePlease to create content