Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

etherchannel question

Hi guys,

How can i make an etherchannel to be backup for another one? what does the "switchport backup" from "interface port-channel" command do?

Also, there is a posibility to make an etherchannel with giga and fast ethernet interfaces?

Thanks and regards!

  • LAN Switching and Routing
7 REPLIES

Re: etherchannel question

Hi

Not sure about the first one.

Also, there is a posibility to make an etherchannel with giga and fast ethernet interfaces?

U mean to say that using at one end fastethernet and the other end gigabit then its not possible as in a ether-channel the ports needs to be identical.

Thanks

Mahmood

New Member

Re: etherchannel question

No...I mean grouping 4 lines into an etherchannel but 2 being fastethernet and 2 giga (same on both ends)

thanks

Roland

Re: etherchannel question

Hi

In that case u need to create 2 separate channels using the same ports on both the ends.

Thanks

Mahmood

Silver

Re: etherchannel question

You can configure etherchannel using 2 or 3 gig or fast ethernet interfaces.

Thanks,

satish

Silver

Re: etherchannel question

Examples

This example shows how to configure two interfaces as Flex Links:

Switch# configure terminal

Switch(conf)# interface fastethernet0/1

Switch(conf-if)# switchport backup interface fastethernet0/2

Switch(conf-if)# end

This example shows how to configure the Fast Ethernet interface to always preempt the backup:

Switch# configure terminal

Switch(conf)# interface fastethernet0/1

Switch(conf-if)# switchport backup interface fastethernet0/2 preemption forced

Switch(conf-if)# end

This example shows how to configure the Fast Ethernet interface preemption delay time:

Switch# configure terminal

Switch(conf)# interface fastethernet0/1

Switch(conf-if)# switchport backup interface fastethernet0/2 preemption delay 150

Switch(conf-if)# end

This example shows how to configure the Fast Ethernet interface as the MMU primary VLAN:

Switch# configure terminal

Switch(conf)# interface fastethernet0/1

Switch(conf-if)# switchport backup interface fastethernet0/2 mmu primary vlan 1021

Switch(conf-if)# end

The following example shows how to configure preferred VLANs:

Switch(config)# interface gigabitethernet 0/6

Switch(config-if)# switchport backup interface gigabitethernet 0/8 prefer vlan 60,100-120

You can verify your setting by entering the show interfaces switchport backup privileged EXEC command.

In the following example, VLANs 1 to 50, 60, and 100 to 120 are configured on the switch:

Switch(config)# interface gigabitEthernet 0/6

Switch(config-if)# switchport backup interface gigabitEthernet 0/8 prefer vlan 60,100-120

When both interfaces are up, Gi0/8 forwards traffic for VLANs 60 and 100 to 120 and Gi0/6 forwards traffic for VLANs 1 to 50.

Switch# show interfaces switchport backup

Switch Backup Interface Pairs:

Active Interface Backup Interface State

------------------------------------------------------------------------

GigabitEthernet0/6 GigabitEthernet0/8 Active Up/Backup Up

Vlans Preferred on Active Interface: 1-50

Vlans Preferred on Backup Interface: 60, 100-120

When a Flex Link interface goes down (LINK_DOWN), VLANs preferred on this interface are moved to the peer interface of the Flex Link pair. In this example, if interface Gi0/6 goes down, Gi0/8 carries all VLANs of the Flex Link pair.

Switch# show interfaces switchport backup

Switch Backup Interface Pairs:

Active Interface Backup Interface State

------------------------------------------------------------------------

GigabitEthernet0/6 GigabitEthernet0/8 Active Down/Backup Up

Vlans Preferred on Active Interface: 1-50

Vlans Preferred on Backup Interface: 60, 100-120

When a Flex Link interface comes up, VLANs preferred on this interface are blocked on the peer interface and moved to the forwarding state on the interface that has just come up. In this example, if interface Gi0/6 comes up, VLANs preferred on this interface are blocked on the peer interface Gi0/8 and forwarded on Gi0/6.

Switch# show interfaces switchport backup

Switch Backup Interface Pairs:

Active Interface Backup Interface State

------------------------------------------------------------------------

GigabitEthernet0/6 GigabitEthernet0/8 Active Up/Backup Up

Vlans Preferred on Active Interface: 1-50

Vlans Preferred on Backup Interface: 60, 100-120

Switch# show interfaces switchport backup detail

Switch Backup Interface Pairs:

Active Interface Backup Interface State

------------------------------------------------------------------------

FastEthernet0/3 FastEthernet0/4 Active Down/Backup Up

Vlans Preferred on Active Interface: 1-2,5-4094

Vlans Preferred on Backup Interface: 3-4

Preemption Mode : off

Bandwidth : 10000 Kbit (Fa0/3), 100000 Kbit (Fa0/4)

Mac Address Move Update Vlan : auto

Thanks,

satish

Silver

Re: etherchannel question

Example to config etherchannel using gig interfaces...

interface Port-channel5

description ****Ether channel ***

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 5 mode on

!

interface GigabitEthernet1/2

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 5 mode on

!

interface GigabitEthernet2/1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 5 mode on

Thanks ,

satish

New Member

Re: etherchannel question

Thanks guys for answers

Roland

300
Views
9
Helpful
7
Replies
This widget could not be displayed.