Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

EtherChannel Question

When I run the

show etherchannel port
                Channel-group listing:
                ----------------------

Group: 9
----------
                Ports in the group:
                -------------------
Port: Gi1/0/51
------------

Port state    = Up Mstr In-Bndl
Channel group = 9           Mode = On              Gcchange = -
Port-channel  = Po9         GC   =   -             Pseudo port-channel = Po9
Port index    = 0           Load = 0x00            Protocol =    -                                                <<<<I would expect to see LACP or PagP here.  Because it is not listed here, which protocol is currently running if any? Is this etherchannel functioning correctly?

show etherchannel 9 port-channel
                Port-channels in the group:
                ---------------------------

Port-channel: Po9
------------

Age of the Port-channel   = 248d:23h:18m:06s
Logical slot/port   = 10/9          Number of ports = 2
GC                  = 0x00000000      HotStandBy port = null
Port state          = Port-channel Ag-Inuse
Protocol            =    -

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     00     Gi1/0/51 On                 0
  0     00     Gi2/0/50 On                 0

Time since last port bundled:    186d:04h:28m:05s    Gi1/0/51
Time since last port Un-bundled: 186d:04h:59m:43s    Gi2/0/50

Config

interface Port-channel9

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 41,51,71,101,254

switchport mode trunk

interface GigabitEthernet1/0/51

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 41,51,71,101,254

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust cos

channel-group 9 mode on

Thanks for the help.

10 REPLIES

Re: EtherChannel Question

By chosing the mode on you have forced the channel to be formed. Not using either pagp or lacp.

-Todd

New Member

Re: EtherChannel Question

If I may add to Todd's correct point, PagP and LACP are negotiation protocols just as DTP is is a negotiation protocol used to set up trunks. When you set links to "On" as you have, you've pretty much excluded any type of negotiation, thus, the protocols are not used.

New Member

Re: EtherChannel Question

So with the config listed below I am using basic "etherchannel protocol".  Correct?

Re: EtherChannel Question

Tricky question. Not sure if you would call it a protocol as much as technology.

New Member

Re: EtherChannel Question

Are there any issues with this configuration? Are there pro/con's going with PagP or Lacp over my current configuration?

New Member

Re: EtherChannel Question

Not necessarily, having them "on" doesn't hurt at all. PagP (Port Aggregation Protocol) is a Cisco proprietary protocol used to form etherchannel links between Cisco switches. LACP (Link Aggregation Control Protocol) is a protocol used to for etherchannels between Cisco switches and switches from other vendors that support LACP.

Each protocol supports 4 modes.

PagP - On, Off, Desirable, Auto

LACP, On, Off, Active, Passive

(Correct me if I'm wrong)

Re: EtherChannel Question

I know with LACP you can configure thresholds (minimum links) which would allow you to determine how many links would be acceptable to lose before your etherchannel will shutdown.  Thereby forcing traffic to route to an alternative path. This would be good for latency sensitive applications. So you can't do this with the configuration you have. The etherchannel you have will stay up as long as you have active links in it.

New Member

Re: EtherChannel Question

Also, with LACP I believe you can define standby links to use in the etherchannel if any links in the "active" bundle fail. With PagP all links are "active" or "on".

Just read that somewhere, please correct me if I'm wrong.

Re: EtherChannel Question

In a nutshell there is nothing wrong with the configuration you have. We use this this configuration all the time. Basically when you configure the etherchannel you looking for aggregate bandwidth and thats what you are getting.

My 2 cents.

Re: EtherChannel Question

Here is the info from a Cisco Document....

EtherChannel On Mode

EtherChannel

on mode can be used to manually configure an EtherChannel. The on mode forces a port

to join an EtherChannel without negotiations. The

on mode can be useful if the remote device does not

support PAgP or LACP. In the

on mode, a usable EtherChannel exists only when the switches at both

ends of the link are configured in the

on mode.

Ports that are configured in the

on mode in the same channel group must have compatible port

characteristics, such as speed and duplex. Ports that are not compatible are suspended, even though they

are configured in the

on mode.

Caution

You should use care when using the on mode. This is a manual configuration, and ports on both ends of

the EtherChannel must have the same configuration. If the group is misconfigured, packet loss or

spanning-tree loops can occur.

Please rate posts that help,

Mike

562
Views
0
Helpful
10
Replies
CreatePlease to create content