Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Etherchannel setup for NetApp

We have a flexstack 2960s configured for a Netapp 2240 connectivity.  We've created a virtual interface on the NetApp side which combines the 4 ethernet ports into 1 virtuall interface.  On the switch side we've created an etherchannel and combined the 4 physical ports.  The problem we are running into is 1 of the Cisco ports in the the etherchannel comes up as "suspended"  The issue seem to be on the Cisco side but I can't seem to find where the issue can be.  Below are the configs for the etherchannl and 1 of the ports in the etherchannel.   When i remove the suspended interface from the NetApp config the failover process functions without issue.  Is there a limit on how many ports can be bundled in a 2960 etherchannel?            

Group  Port-channel  Protocol    Ports

------+-------------+-----------+----------------------------------

1      Po1(SU)         LACP      Gi1/0/1(P)  Gi1/0/3(P)  Gi2/0/1(P)

Gi2/0/26(s)

interface Port-channel1

description SAN CONTROLLER A

switchport access vlan 304

switchport mode access

switchport nonegotiate

flowcontrol receive desired

spanning-tree portfast

spanning-tree guard loop

end

interface GigabitEthernet1/0/1

description NSS791A-e0a

switchport access vlan 304

switchport mode access

switchport nonegotiate

flowcontrol receive desired

spanning-tree portfast

spanning-tree guard loop

channel-protocol lacp

channel-group 1 mode active

end

2 REPLIES
New Member

Etherchannel setup for NetApp

Hi Albert,

I only use 3750s to etherchannel with Netapps without any problems,  with the following condition for load balance:

port-channel load-balance src-dst-mac

I do not know the limitations of 2960S, but I have etherchannels with 4 interfaces in 2960 (not with netapp):

show etherchannel summary

Number of channel-groups in use: 2

Number of aggregators:           2

Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

1      Po1(SU)         PAgP      Fa0/18(P)   Fa0/20(P)   Fa0/22(P)

Fa0/24(P)

2      Po2(SU)         PAgP      Fa0/13(P)   Fa0/15(P)   Fa0/17(P)

Fa0/19(P)

Regards,

Pedro Lereno

Etherchannel setup for NetApp

You are only allowed a maximum of 6 etherchannel groups on a 2960S and 24 on a 2960X but considering your issue I doubt this is what you are hitting. It is more likely that the port with the issue is some how configured differently from the other three ports that are able to be apart of the bundle.

2966
Views
0
Helpful
2
Replies
CreatePlease to create content