Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Etherchannel Trunk and STP behavior

Hi all, have a quick question on etherchannel, trunking and spanning tree behavior.  In packet tracert I've setup 2 physical interfaces as etherchannel "po1" on each side of my switches.  I then configured po1 on each side to be a trunk.  This is working fine and if I shutdown a single port, the link stays active and I can still forward traffic.  Perfect so far! 

However, when I do a "no shut" on the downed interface, the entire etherchannel goes through a Spanning Tree initialization and takes the entire etherchannel down for approximately 30 seconds.  Is this expected behavior?  I thought that Spanning Tree treated the Port Channel as a single entity and as long as one physical interface were up on each side, there would be no reason for spanning tree to renegotiate?            

4 REPLIES
Hall of Fame Super Bronze

Etherchannel Trunk and STP behavior

When a port is added to a bundle, it needs to check for consistency.

Please read to this document for its behavior

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_tech_note09186a008009448d.shtml

Regards,

Etherchannel Trunk and STP behavior

Hello

You are correct STP treats this as one instance, and the issue you have stated shouldn't really occur, can you post your L2 etherchannel config,

Also

sh spanning-tree interface port-channel x

sh etherchannel port-channel

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.

Please don't forget to rate any posts that have been helpful. Thanks.
New Member

Re: Etherchannel Trunk and STP behavior

Edison, thanks for the link... will read in a few.

pdriver, keep in mind that I'm doing this in packet tracer for proof of concept before I try it in production so maybe it's a quirk with packet tracer?  Config is really bare bones  >

SW1

!

spanning-tree mode pvst

!

interface FastEthernet0/1

switchport access vlan 3

switchport mode access

!

interface FastEthernet0/2

switchport access vlan 3

switchport mode access

!

interface FastEthernet0/3

switchport access vlan 3

switchport mode access

!

interface FastEthernet0/4

switchport access vlan 96

switchport mode access

!

interface FastEthernet0/5

switchport access vlan 96

switchport mode access

!

interface FastEthernet0/6

switchport access vlan 96

switchport mode access

!

interface FastEthernet0/7

switchport access vlan 13

switchport mode access

!

interface FastEthernet0/8

switchport access vlan 13

switchport mode access

!

interface FastEthernet0/9

switchport access vlan 13

switchport mode access

!

!

interface GigabitEthernet0/1

channel-group 1 mode on

switchport mode trunk

!

interface GigabitEthernet0/2

channel-group 1 mode on

switchport mode trunk

!

interface Port-channel 1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Vlan1

no ip address

shutdown

!

interface Vlan3

description 10.3.0.0

ip address 10.3.0.1 255.255.255.0

!

interface Vlan13

description 10.10.13.0

ip address 10.10.13.1 255.255.255.0

!

interface Vlan96

description 10.10.96.0

ip address 10.10.96.1 255.255.255.0

!

ip classless

!

SW2

spanning-tree mode pvst
!
!
interface FastEthernet0/1
switchport access vlan 3
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 3
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 3
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 96
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 96
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 96
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 13
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 13
switchport mode access
!
interface FastEthernet0/9
switchport access vlan 13
switchport mode access
!
!
interface GigabitEthernet0/1
channel-group 1 mode on
switchport mode trunk
!
interface GigabitEthernet0/2
channel-group 1 mode on
switchport mode trunk
!
interface Port-channel 1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
!

-------------------------------------------------------------------------------------------------------------

SW1

Switch#sh etherchannel port-channel
                Channel-group listing:
                ----------------------

Group: 1
----------
                Port-channels in the group:
                ---------------------------

Port-channel: Po1
------------

Age of the Port-channel   = 00d:14h:01m:55s
Logical slot/port   = 2/1       Number of ports = 2
GC                  = 0x00000000      HotStandBy port = null
Port state          = Port-channel
Protocol            =   PAGP
Port Security       = Disabled

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     00     Gig0/2   On                 0
  0     00     Gig0/1   On                 0
Time since last port bundled:    00d:06h:29m:45s    Gig0/1

Switch#sh spanning-tree interface port-channel 1
no spanning tree info available for Port-channel1

Re: Etherchannel Trunk and STP behavior

Hello

Hum it seems you have created the port-channel first then confined the physical interfaces plus the interfaces looks like they are not are not active given the stp and ether-channel readouts

You say you need to aggregate physical port for server connection but at present the physical ports are trunked which indicates switch to switch connections -(would expect to see server porta in access mode)

Anyway please take a look at this post:

https://supportforums.cisco.com/message/4146391#4146391


Res
Paul

Sent from Cisco Technical Support iPad App

Please don't forget to rate any posts that have been helpful. Thanks.
468
Views
0
Helpful
4
Replies
CreatePlease login to create content