Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Etherchannel trunking between a 6506 and a 3750E.

I would like to set up etherchannel trunking between a Cat 6506 and a 3750E and I want to make sure I have everything covered before actually connecting the ports.

6506 settings

Software: CatOS 6.4(12)

set spantree portfast 5/42-46 disable

set trunk 5/42-46 on dot1q

set port channel 5/42-46 mode on

set port speed 5/42-46 auto

set port duplex 5/42-46 full

3750E settings

IOS 12.2(50)SE3

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

interface GigabitEthernet1/0/42

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode desirable

(settings repeated for ports 43-46)

Are there any other settings that would be germane ?

On a related note:

Current the two switches are connected with a single port.

Should I disconnect this port prior to connecting the others or does it matter?

4 ACCEPTED SOLUTIONS

Accepted Solutions
Silver

Re: Etherchannel trunking between a 6506 and a 3750E.

Hi,

Some remarks:

- C6500 site uses no channel protocol while C3750 is using pagp.

Try this:

set channelprotocol pagp 5

set port channel 5/42-46 mode desirable

int range gi 1/0/42 - 46

channel-protocol pagp

channel-group 1 mode desirable

- configure your speed/duplex fixed

set port speed 5/42-46 1000

set port duplex 5/42-46 full

int range gi 1/0/42 - 46

speed 1000

duplex full

- Can you have downtime for this migration?

If so, just disconnect your single port, and connect the port-channel.

Otherwise, STP will do the necessary when you don't disconnect this port first.

HTH,

Dario

Purple

Re: Etherchannel trunking between a 6506 and a 3750E.

On the 3750 you are using the desirable setting to setup the channel use the same on the catos side . USe set port channel 5/42-46 desirable non-silent . On the 3750 use channel-group 1 mode desirable non-silent.

Bronze

Re: Etherchannel trunking between a 6506 and a 3750E.

I'd say that you should use the two gigabit ports on the Sup if they are available.

HTH

Hall of Fame Super Bronze

Re: Etherchannel trunking between a 6506 and a 3750E.

PAgP is Cisco proprietary and it will not work when the link partner is a server.

I suggest using either unconditional etherchanneling (mode on) or LACP (mode active).

Regards,

__

Edison.

11 REPLIES
Silver

Re: Etherchannel trunking between a 6506 and a 3750E.

Hi,

Some remarks:

- C6500 site uses no channel protocol while C3750 is using pagp.

Try this:

set channelprotocol pagp 5

set port channel 5/42-46 mode desirable

int range gi 1/0/42 - 46

channel-protocol pagp

channel-group 1 mode desirable

- configure your speed/duplex fixed

set port speed 5/42-46 1000

set port duplex 5/42-46 full

int range gi 1/0/42 - 46

speed 1000

duplex full

- Can you have downtime for this migration?

If so, just disconnect your single port, and connect the port-channel.

Otherwise, STP will do the necessary when you don't disconnect this port first.

HTH,

Dario

Purple

Re: Etherchannel trunking between a 6506 and a 3750E.

On the 3750 you are using the desirable setting to setup the channel use the same on the catos side . USe set port channel 5/42-46 desirable non-silent . On the 3750 use channel-group 1 mode desirable non-silent.

New Member

Re: Etherchannel trunking between a 6506 and a 3750E.

Hello Grant

At a few line modules of the 6500 are 8 ports to one single 1 gigabit exit combined.

So from 48 front ports are internally only 8x 1 gigabit channels.

If you build a channel on this 8 ports on the front you have behind only one single 1 gigabit channel.

This runs for redundancy and backups but NOT for performance reason.

hth

Andy

Purple

Re: Etherchannel trunking between a 6506 and a 3750E.

Right , I'm not the one setting this up the original poster is ...

New Member

Re: Etherchannel trunking between a 6506 and a 3750E.

Thank you all for your responses.

I've only set up etherchannel between switches and servers to this point and have never dealt with pagp.

I had a moment of mental vapor-lock and forgot to include several very relevant pieces of info:

The 6506 has a SUP1A-2GE with a PFC and an MSFC2.

16MB flash and 64MB DRAM on the SUP1A

16MBflash on the MFSC2

The system is still running in hybrid mode (CatOS on the SUP1A, IOS on the MFSC2)

The SUP1A CatOS: 6.4(21)

The MSCF2 IOS: 12.1(27b)E3

The remaining modules are all WS-X6348-RJ-45.

The only gigabit ports on the 6506 are the two GBIC slots in the SUP1A.

In my present plan I would be trunking six to eight 10/100 ports on the 6506 to six gigabit ports on the 3750E.

In this situation is it better to leave all ports on both sides to Auto or is it better to set all ports on both sides to 100/full?

This also begs the question:

6-8 10/100 ports vs two gigabit-capable GBIC: Which would provide better performance/fewer issues?

From the standpoint of bandwidth limits, the answer is obvious.

The only reason I ask this is that I don't know if there is any preference, since the gigabit ports are on the SUP1A engine, whereas the 10/100 ports are on a line card.

Bronze

Re: Etherchannel trunking between a 6506 and a 3750E.

I'd say that you should use the two gigabit ports on the Sup if they are available.

HTH

New Member

Re: Etherchannel trunking between a 6506 and a 3750E.

OK,

Trunking the Gigabit GBICs to a couple of ports on the 3750 was no problem with

"set port channel 1/1-2 mode desirable" on the 6506 and "channel-protocol pagp

channel-group 1 mode desirable non-silent" on the 3750.

Those, combined with dot1q trunking commands on both switches worked completely without drama.

Thank you all for you help.

Setting up etherchannel for my servers, however, has been a frustration.

The IOS command reference notes that:

"The silent mode is used when the switch is connected to a device that is not PAgP-capable and seldom, if ever, sends packets. A example of a silent partner is a file server or a packet analyzer that is not generating traffic."

I think I've tried every variation in the book, starting with:

"channel-group 1 mode desirable"

Regardless of what I try, when I check the sum of the server etherchannel, it shows the following:

2 - Po2(SD) - PAgP - Gi1/0/5(I) Gi1/0/6(I)

Contrasted with the 6506 etherchannel, which reports:

6 - Po6(SU) - PAgP - Gi1/0/47(P) Gi1/0/48(P)

When I check the details of each ether channel, the parts that jump out are:

server Etherchannel:

Port: Gi1/0/5

------------

Port state = Up Sngl-port-Bndl Mstr Not-in-Bndl

Port-channel: Po2

------------

Number of ports = 0

Port state = Port-channel Ag-Not-Inuse

#########################################

6506 Etherchannel:

Port: Gi1/0/47

Port state = Up Mstr In-Bndl

Partner's information:

Partner Partner

Port Port Flags

Gi1/0/47 1/1 SC

Port-channel: Po6

Number of ports = 2

Port state = Port-channel Ag-Inuse

So, how do I know that the etherchannel setup is functioning correctly when working with servers?

Hall of Fame Super Bronze

Re: Etherchannel trunking between a 6506 and a 3750E.

PAgP is Cisco proprietary and it will not work when the link partner is a server.

I suggest using either unconditional etherchanneling (mode on) or LACP (mode active).

Regards,

__

Edison.

New Member

Re: Etherchannel trunking between a 6506 and a 3750E.

Thanks Edison,

I shall try those.

I *had* tried LACP, but could have easily had additional variables in the config that prevented success.

Hall of Fame Super Bronze

Re: Etherchannel trunking between a 6506 and a 3750E.

The teaming software and the NIC at the server must also support LACP

__

Edison.

New Member

Re: Etherchannel trunking between a 6506 and a 3750E.

Unconditional did the trick.

I've not seen anything in the documentation of Intel or Broadcom that suggests support for either PAGP or LCAP, so that should have been my 1st clue.

Thanks again to all.

783
Views
5
Helpful
11
Replies