Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

etherchannel

hi! i'm trying to connect my blade server's cisco sw module to

the 6509 core by pairing 2 links as a

channel group. below are the related config. The problem is encounter is that i can see the sw neighbor by using sh cdp nei, but i'm not able to ping

the gateway or the management vlan of the blade sw from the 6509 or from the blade sw to other network. I tried to join the vtp domain of the new blade sw to our existing vtp domain, it doesn't get populated into the blade sw as well. what could be the issue here? (native vlan is the same for both side) did i miss out something here? thanks.

6509

---------

interface Port-channel21
switchport
switchport trunk encapsulation dot1q

switchport mode trunk
!

interface GigabitEthernet1/10
description uplink1 to bladechassis
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
channel-protocol pagp
channel-group 21 mode desirable
!
interface GigabitEthernet1/20
description uplink1 to bladechassis
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
channel-protocol pagp
channel-group 21 mode desirable

bladechassis sw module

-------------------------------

interface GigabitEthernet0/17
description Uplink 1
switchport mode trunk
channel-protocol pagp
channel-group 2 mode desirable
!
interface GigabitEthernet0/18
description Uplink 2
switchport mode trunk
channel-protocol pagp
channel-group 2 mode desirable
!
interface Vlan1
10.1.1.1 255.255.255.0

ip-default gateway 10.1.1.254 255.255.255.0

2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Blue

Re: etherchannel

dkblee@hotmail.com

hi! i'm trying to connect my blade server's cisco sw module to

the 6509 core by pairing 2 links as a

channel group. below are the related config. The problem is encounter is that i can see the sw neighbor by using sh cdp nei, but i'm not able to ping

the gateway or the management vlan of the blade sw from the 6509 or from the blade sw to other network. I tried to join the vtp domain of the new blade sw to our existing vtp domain, it doesn't get populated into the blade sw as well. what could be the issue here? (native vlan is the same for both side) did i miss out something here? thanks.

6509

---------

interface Port-channel21
switchport
switchport trunk encapsulation dot1q

switchport mode trunk
!

interface GigabitEthernet1/10
description uplink1 to bladechassis
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
channel-protocol pagp
channel-group 21 mode desirable
!
interface GigabitEthernet1/20
description uplink1 to bladechassis
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
channel-protocol pagp
channel-group 21 mode desirable

bladechassis sw module

-------------------------------

interface GigabitEthernet0/17
description Uplink 1
switchport mode trunk
channel-protocol pagp
channel-group 2 mode desirable
!
interface GigabitEthernet0/18
description Uplink 2
switchport mode trunk
channel-protocol pagp
channel-group 2 mode desirable
!
interface Vlan1
10.1.1.1 255.255.255.0

ip-default gateway 10.1.1.254 255.255.255.0

Can you post the output from both the 6500 and the blade chassis

1) sh interface trunk

2) sh etherchannel summary

you don't have a port-channel interface shown in your blade config - did you just miss it out ?

Presumably  10.1.1.254 is the IP address of L3 interface for vlan on the 6500 ?

Jon

Purple

Re: etherchannel

  Does the channel show up ?  Show ether summary.   Also keep this in mind those switches are not managed   thru the port channel . They are managed thru a separate  connection to the server management module so if this link is not connected or there is a problem  with that link you won't be able to ping the switches even if the port channel is up and active .   So basically you have your etherchannel connections and a separate connection to the server mgt. module thru which the cisco switches are managed.  I believe it is a config option now to be able to manage them thru the uplinks but by default they are managed thru the mgt. module .  If this is the case then the 6500  would have to have a VLan 1 SVI  configured with the default gateway address for that address space.

5 REPLIES
VIP Super Bronze

Re: etherchannel

Hello,

Can you provide more info:

1- What type of Cisco switches are these?

2-Are they located within a chassis?

3-Are you stacking the switches you are connecting to the 6500?

Reza

Community Member

Re: etherchannel

Can you provide more info:

1- What type of Cisco switches are these?

the bladechassis's switch is a 4ports cisco sw module

2-Are they located within a chassis?

the bladechassis and 6509 are 2 seperate box

3-Are you stacking the switches you are connecting to the 6500?

no there's only one switch module within that blade server chassis.

thx

Hall of Fame Super Blue

Re: etherchannel

dkblee@hotmail.com

hi! i'm trying to connect my blade server's cisco sw module to

the 6509 core by pairing 2 links as a

channel group. below are the related config. The problem is encounter is that i can see the sw neighbor by using sh cdp nei, but i'm not able to ping

the gateway or the management vlan of the blade sw from the 6509 or from the blade sw to other network. I tried to join the vtp domain of the new blade sw to our existing vtp domain, it doesn't get populated into the blade sw as well. what could be the issue here? (native vlan is the same for both side) did i miss out something here? thanks.

6509

---------

interface Port-channel21
switchport
switchport trunk encapsulation dot1q

switchport mode trunk
!

interface GigabitEthernet1/10
description uplink1 to bladechassis
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
channel-protocol pagp
channel-group 21 mode desirable
!
interface GigabitEthernet1/20
description uplink1 to bladechassis
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
channel-protocol pagp
channel-group 21 mode desirable

bladechassis sw module

-------------------------------

interface GigabitEthernet0/17
description Uplink 1
switchport mode trunk
channel-protocol pagp
channel-group 2 mode desirable
!
interface GigabitEthernet0/18
description Uplink 2
switchport mode trunk
channel-protocol pagp
channel-group 2 mode desirable
!
interface Vlan1
10.1.1.1 255.255.255.0

ip-default gateway 10.1.1.254 255.255.255.0

Can you post the output from both the 6500 and the blade chassis

1) sh interface trunk

2) sh etherchannel summary

you don't have a port-channel interface shown in your blade config - did you just miss it out ?

Presumably  10.1.1.254 is the IP address of L3 interface for vlan on the 6500 ?

Jon

Purple

Re: etherchannel

  Does the channel show up ?  Show ether summary.   Also keep this in mind those switches are not managed   thru the port channel . They are managed thru a separate  connection to the server management module so if this link is not connected or there is a problem  with that link you won't be able to ping the switches even if the port channel is up and active .   So basically you have your etherchannel connections and a separate connection to the server mgt. module thru which the cisco switches are managed.  I believe it is a config option now to be able to manage them thru the uplinks but by default they are managed thru the mgt. module .  If this is the case then the 6500  would have to have a VLan 1 SVI  configured with the default gateway address for that address space.

Community Member

Re: etherchannel

hi! alll.....thank. the issue has been resolved.

380
Views
0
Helpful
5
Replies
CreatePlease to create content