Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

etherchannel

Hello,

I am creating an etherchannel on my 6506E with two ports as members to connect to an HP DL380 server where the two on-board nics are teamed. I am only concerned with the configuration of the switch side. I would normally create a port-channel and add two ports with "channel-group mode auto". Is this the best way to do it, assuming the HP nic is set to "802.3ad Dynamic"?

Thanks in advance,

1 ACCEPTED SOLUTION

Accepted Solutions

Re: etherchannel

I just did this same thing just a few days ago for the first time and this is what I have configured to work.

interface GigabitEthernet11/14

description Sever NIC1

switchport

switchport access vlan 3

switchport mode access

no ip address

spanning-tree portfast

channel-group 67 mode active

interface GigabitEthernet12/14

description Server NIC2

switchport

switchport access vlan 3

switchport mode access

no ip address

spanning-tree portfast

channel-group 67 mode active

interface Port-channel67

description Server etherchannel

switchport

switchport access vlan 3

switchport mode access

no ip address

Also had the NIC teaming set to 802.3ad Dynamic with Fault Tolerance and the Transmit load balancing method set to Destination IP Address

Hope that helps.

Mike

4 REPLIES
Purple

Re: etherchannel

Seeing you are using 802.3ad then you would probably want to use "channel-group X mode active" as the setup . Auto won't work .

New Member

Re: etherchannel

When I read the description from the HP Nic teaming article, it says if the server uses "802.3ad dynamic" then as long as the switch supports lacp then there is nothing for me to do. :)

This is the excerp for the section from this link... "http://h18004.www1.hp.com/products/servers/networking/teaming.html"

802.3ad Dynamic - provides receive and transmit load balancing on a single switch. In this team type, the team members negotiate with the switch to automatically form a port group, so no additional configuration is required on the switch. The switch must support the IEEE 802.3ad Link Aggregation Control Protocol (LACP). 802.3ad Dynamic Teaming is a standard feature of ProLiant teaming.

Would you agree?? Or should I put the "channel-group X mode active" and setup the port-channel just to be safe?

Cisco Employee

Re: etherchannel

Hello William,

Yes, you need the command so that switch forms a etherchannel on the switch ports connected to the server.

The following doc discusses a configuration example between Cisco IOS and Server (HP proliant teaming)

EtherChannel Between a Cisco Catalyst Switch That Runs Cisco IOS and a Workstation or Server Configuration Example

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_configuration_example09186a008089a821.shtml

HTH

Padmanabhan

Re: etherchannel

I just did this same thing just a few days ago for the first time and this is what I have configured to work.

interface GigabitEthernet11/14

description Sever NIC1

switchport

switchport access vlan 3

switchport mode access

no ip address

spanning-tree portfast

channel-group 67 mode active

interface GigabitEthernet12/14

description Server NIC2

switchport

switchport access vlan 3

switchport mode access

no ip address

spanning-tree portfast

channel-group 67 mode active

interface Port-channel67

description Server etherchannel

switchport

switchport access vlan 3

switchport mode access

no ip address

Also had the NIC teaming set to 802.3ad Dynamic with Fault Tolerance and the Transmit load balancing method set to Destination IP Address

Hope that helps.

Mike

707
Views
9
Helpful
4
Replies