Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

etherchannel

hi everybody!

I was reading bcmsn guide, and got stuck with one thing.

If we have two swithes sw1 and sw2.

sw1 and sw2 are connected by f0/1,and f0/2 on both sides.

Ether channel will form or not if sw1 has f0/1 and f0/2 in vlan 2 while sw2 has f0/1 and f0/2 in vlan 3?

thanks alot!

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Bronze

Re: etherchannel

I had to test this myself as I wasn't 100% sure.

Surprisingly, the etherchannel does form.

Switch 3 Config

S3(config)#int ran f0/13-14

S3(config-if-range)#switchport access vlan 4

S3(config-if-range)#channel-group 1 mode desirable

Creating a port-channel interface Port-channel 1

Switch 1 Config

S1(config)#int r f0/16-17

S1(config-if-range)#switchport access vlan 21

S1(config-if-range)#channel-group 1 mode desirable

Creating a port-channel interface Port-channel 1

S1(config-if-range)#

1w2d: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/16, changed state to down

1w2d: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/17, changed state to down

1w2d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up

1w2d: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/16, changed state to up

1w2d: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/17, changed state to up

S1(config-if-range)#

Switch 1 Etherchannel Summary Output

1w2d: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up

S1(config-if-range)#do show ether sum

Flags: D - down P - in port-channel

I - stand-alone s - suspended

H - Hot-standby (LACP only)

R - Layer3 S - Layer2

U - in use f - failed to allocate aggregator

u - unsuitable for bundling

w - waiting to be aggregated

d - default port

Number of channel-groups in use: 1

Number of aggregators: 1

Group Port-channel Protocol Ports

------+-------------+-----------+-----------------------------------------------

1 Po1(SU) PAgP Fa0/16(P) Fa0/17(P)

S1(config-if-range)#

Switch 3 Etherchannel Summary Output

S3(config-if-range)#do show ether sum

Flags: D - down P - in port-channel

I - stand-alone s - suspended

H - Hot-standby (LACP only)

R - Layer3 S - Layer2

U - in use f - failed to allocate aggregator

u - unsuitable for bundling

w - waiting to be aggregated

d - default port

Number of channel-groups in use: 1

Number of aggregators: 1

Group Port-channel Protocol Ports

------+-------------+-----------+-----------------------------------------------

1 Po1(SU) PAgP Fa0/13(P) Fa0/14(P)

HTH,

__

Edison.

Please rate helpful posts

12 REPLIES
Hall of Fame Super Bronze

Re: etherchannel

I had to test this myself as I wasn't 100% sure.

Surprisingly, the etherchannel does form.

Switch 3 Config

S3(config)#int ran f0/13-14

S3(config-if-range)#switchport access vlan 4

S3(config-if-range)#channel-group 1 mode desirable

Creating a port-channel interface Port-channel 1

Switch 1 Config

S1(config)#int r f0/16-17

S1(config-if-range)#switchport access vlan 21

S1(config-if-range)#channel-group 1 mode desirable

Creating a port-channel interface Port-channel 1

S1(config-if-range)#

1w2d: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/16, changed state to down

1w2d: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/17, changed state to down

1w2d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up

1w2d: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/16, changed state to up

1w2d: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/17, changed state to up

S1(config-if-range)#

Switch 1 Etherchannel Summary Output

1w2d: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up

S1(config-if-range)#do show ether sum

Flags: D - down P - in port-channel

I - stand-alone s - suspended

H - Hot-standby (LACP only)

R - Layer3 S - Layer2

U - in use f - failed to allocate aggregator

u - unsuitable for bundling

w - waiting to be aggregated

d - default port

Number of channel-groups in use: 1

Number of aggregators: 1

Group Port-channel Protocol Ports

------+-------------+-----------+-----------------------------------------------

1 Po1(SU) PAgP Fa0/16(P) Fa0/17(P)

S1(config-if-range)#

Switch 3 Etherchannel Summary Output

S3(config-if-range)#do show ether sum

Flags: D - down P - in port-channel

I - stand-alone s - suspended

H - Hot-standby (LACP only)

R - Layer3 S - Layer2

U - in use f - failed to allocate aggregator

u - unsuitable for bundling

w - waiting to be aggregated

d - default port

Number of channel-groups in use: 1

Number of aggregators: 1

Group Port-channel Protocol Ports

------+-------------+-----------+-----------------------------------------------

1 Po1(SU) PAgP Fa0/13(P) Fa0/14(P)

HTH,

__

Edison.

Please rate helpful posts

New Member

Re: etherchannel

This is weird Edison....have you waited a few minutes to see if channels goes down.

While doing some labs a few months ago I recall (not sure what kind of lab though) etherchannel went up for few minutes and then down!

Hall of Fame Super Bronze

Re: etherchannel

Still up, 30 minutes later.

Bronze

Re: etherchannel

This is interesting that the etherchannel would successfully come up. I guess that PAGP must not check that the vlans are the same. Curious if the channel would come up using LACP instead (probably since this one came up).

Of course, a person studying this should realize that while this may come up - that this isn't the right way to do things and that you probably don't have any connectivity across it. Definitely don't want to see this in a production network :)

Purple

Re: etherchannel

This would probably work fine on a strict access mode connection as it doesn't care about anything other than the connection across it (layer 2 ) . If you add trunking to the ehterchannel and use channel negotiation I know it will not come up and will tell you so if stuff like native vlans and such do not match.

Bronze

Re: etherchannel

how about if native vlans are same?will it

come up?

Hall of Fame Super Bronze

Re: etherchannel

This would probably work fine on a strict access mode connection as it doesn't care about anything other than the connection across it (layer 2 ) . If you add trunking to the ehterchannel and use channel negotiation I know it will not come up and will tell you so if stuff like native vlans and such do not match.

In this case, it will be a trunking mismatch issue, not really an etherchanneling issue.

Purple

Re: etherchannel

In this case, it will be a trunking mismatch issue, not really an etherchanneling issue.

Technically that is true but it still keeps the port channel from coming up when this happens also.

Hall of Fame Super Bronze

Re: etherchannel

Well, let's see....

Switch 3

Port Mode Encapsulation Status Native vlan

Fa0/13 on 802.1q trunking 4

Fa0/14 on 802.1q trunking 4

S3#sh run int f0/13

interface FastEthernet0/13

switchport trunk encapsulation dot1q

switchport trunk native vlan 4

switchport mode trunk

S3#sh run int f0/14

interface FastEthernet0/14

switchport trunk encapsulation dot1q

switchport trunk native vlan 4

switchport mode trunk

Switch 1

S1#sh int trunk

Port Mode Encapsulation Status Native vlan

Fa0/16 on 802.1q trunking 21

Fa0/17 on 802.1q trunking 21

sh run int f0/16

interface FastEthernet0/16

switchport trunk encapsulation dot1q

switchport trunk native vlan 21

switchport mode trunk

S1#sh run int f0/17

interface FastEthernet0/17

switchport trunk encapsulation dot1q

switchport trunk native vlan 21

switchport mode trunk

end

Now, let's do some etherchanneling, shall we?

S3(config)#int ran f0/13-14

S3(config-if-range)#channel-group 1 mode active

Creating a port-channel interface Port-channel 1

S3(config-if-range)#

04:56:56: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/13, changed state to down

04:56:56: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/14, changed state to down

S1#conf t

Enter configuration commands, one per line. End with CNTL/Z.

S1(config)#int rang f0/16-17

04:56:52: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/16 on VLAN0021. Port consistency restored.

04:56:52: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/17 on VLAN0021. Port consistency restored.

S1(config-if-range)#channel-group 1 mode active

Creating a port-channel interface Port-channel 1

S1(config-if-range)#end

S1#

04:56:59: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/16, changed state to down

04:56:59: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/17, changed state to down

04:56:59: %SYS-5-CONFIG_I: Configured from console by console

04:57:00: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up

04:57:01: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 4 on Port-channel1 VLAN21.

04:57:01: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking Port-channel1 on VLAN0021. Inconsistent local vlan.

04:57:01: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/16, changed state to up

04:57:01: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up

04:57:03: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/17, changed state to up

S1#

S1#show ether sum

Flags: D - down P - in port-channel

I - stand-alone s - suspended

H - Hot-standby (LACP only)

R - Layer3 S - Layer2

U - in use f - failed to allocate aggregator

u - unsuitable for bundling

w - waiting to be aggregated

d - default port

Number of channel-groups in use: 1

Number of aggregators: 1

Group Port-channel Protocol Ports

------+-------------+-----------+-----------------------------------------------

1 Po1(SU) LACP Fa0/16(P) Fa0/17(P)

S1#

S3#sh e

04:58:26: %SYS-5-CONFIG_I: Configured from console by consolether sum

Flags: D - down P - in port-channel

I - stand-alone s - suspended

H - Hot-standby (LACP only)

R - Layer3 S - Layer2

U - in use f - failed to allocate aggregator

u - unsuitable for bundling

w - waiting to be aggregated

d - default port

Number of channel-groups in use: 1

Number of aggregators: 1

Group Port-channel Protocol Ports

------+-------------+-----------+-----------------------------------------------

1 Po1(SU) LACP Fa0/13(P) Fa0/14(P)

Purple

Re: etherchannel

Ok I knew there was an issue , so basically neither vlan 21 nor vlan 4 is going to transfer data across the link due to spanning tree isuues with misconfiguration . This is also one of my arguments to let the link negotiate instead of hardcoding the trunks and etherchannels but I know this would create a whole line of opinions why you should or should not hardcode trunks and etherchannels.

Bronze

Re: etherchannel

So the bottom line is etherchannel does come up though trunk port have different native vlan. It also contradicts what the author david hucaby says in his book "Bcmsn guide"

" native vlans must be same on either end of trunks for the formtion of etherchannel"

thanks to everyone who responded to my post.

Re: etherchannel

I wonder if this is another case where the message got garbled on its way from the mind to the writer to his keyboard. Is it possible he meant to say "native vlans must be the same on each of the trunk links for the formation of etherchannel."?

It is interesting that it forms an etherchannel even with mismatched native vlans on each end. Glan is right about this being a good argument for negotiating EtherChannels rather than hard coding them.

Kevin Dorrell

Luxembourg

197
Views
8
Helpful
12
Replies