Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Etherchannels Mode?

Dear Netpro!

what this command mean and where we would use it:SW2(config-if)#switchport host ?

<cr>?

2) channel-group questioms?

if the questions stead for PAGP <=> THE MODE would be Desirable

for LCAP the Mode would be Active.

for IEEE The Mode would be ON

am i correct?what else?

many 10xs

10 REPLIES
Blue

Re: Etherchannels Mode?

Ya Haj Sayed:

Ingleezeetuk mish nafa3! LOL

Anyway, for LACP, which is an open standard, the choices you have when you configure ports to negotiate an etherchannel are Passive and Active.

If two neighboring ports are configured for Active, an etherchannel will be established.

If one side is set for Active and the other for Passive, an etherchannel will also be formed.

If both sides are set for Passive, an etherchannel will NOT be formed, since each side will be waiting for the other to begin negotiating.

Now for PaGP, which is Cisco's etherchannel protocol, the choices are Desirable and Auto.

If two neighboring ports are configured for Desirable, an etherchannel will be established.

If one side is set for Desirable and the other for Auto, an etherchannel will also be formed.

If both sides are set for Auto, an etherchannel will NOT be formed, since each side will be waiting for the other to begin negotiating.

As for configuring them for "on," there will be NO negotiating and both sides MUST be configured for "on" for the etherchannel to form. Moreover, my Lebanese friend, if one side is set for "on" and the other is set for "desirable" or "Auto," a broadcast storm/bridging loop may occur and cause a big outage. So, be careful.

Lastly, as for the switchport host command, it is used to optimize the connection for a host. For the most part, that means disabling the autonegotiation feature. Doing that, plus configuring the port for portfast, will decrease the time it will take for the port to start forwarding traffic when a host is plugged in to it.

HTH

Victor

New Member

Re: Etherchannels Mode?

yeh

who r you?y look Arabic!and from Lebanon too!introduce ur Self!ALMOUHIM AL-CONCEPT YA 7AJ?

MANY 10XS

Hall of Fame Super Bronze

Re: Etherchannels Mode?

> Moreover, my Lebanese friend, if one side is set for "on" and the other is set for "desirable" or "Auto,"

> a broadcast storm/bridging loop may occur and cause a big outage. So, be careful.

Nope, switchports would go into err-disable as those etherchanneling modes are incompatible.

Blue

Re: Etherchannels Mode?

Are you sure about that, Mr Edison? Accoridng to a Cisco document, what i wrote is the case...unless Cisco is wrong. :-)

New Member

Re: Etherchannels Mode?

hey Lamav.pls be normal in This Forum.BTW Y Forgat to Introduce ur Self...

10xs

Hall of Fame Super Bronze

Re: Etherchannels Mode?

Now, you are making me work and I even said that I liked you, forget that now.....

Switch 1

interface FastEthernet0/13

channel-group 1 mode on

!

interface FastEthernet0/14

channel-group 1 mode on

!

Switch 2

interface FastEthernet0/13

channel-group 1 mode desirable

!

interface FastEthernet0/14

channel-group 1 mode desirable

Now, I'm going to log my session

pod2-sw2#conf t

Enter configuration commands, one per line. End with CNTL/Z.

pod2-sw2(config)#int ran f0/13-14

pod2-sw2(config-if-range)#shut

pod2-sw2(config-if-range)#

xxxxxxx>1

[Resuming connection 1 to sw1 ... ]

pod2-sw1#conf t

Enter configuration commands, one per line. End with CNTL/Z.

pod2-sw1(config)#int ran f0/13-14

pod2-sw1(config-if-range)#shut

pod2-sw1(config-if-range)#

xxxxxxx>2

[Resuming connection 2 to sw2 ... ]

1w2d: %LINK-5-CHANGE

pod2-sw2(config-if-range)#no shut

pod2-sw2(config-if-range)#

xxxxxxx>1

[Resuming connection 1 to sw1 ... ]

%LINK-5-CHANGED: Interf

pod2-sw1(config-if-range)#no shut

pod2-sw1(config-if-range)#

%LINK-3-UPDOWN: Interface FastEthernet0/13, changed state to up

%LINK-3-UPDOWN: Interface FastEthernet0/14, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/13, changed state to up

pod2-sw1(config-if-range)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/14, changed state to up

pod2-sw1(config-if-range)#

%LINK-3-UPDOWN: Interface Port-channel1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up

pod2-sw1(config-if-range)#

%PM-4-ERR_DISABLE: channel-misconfig error detected on Fa0/13, putting Fa0/13 in err-disable state

%PM-4-ERR_DISABLE: channel-misconfig error detected on Fa0/14, putting Fa0/14 in err-disable state

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/13, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/14, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to down

Blue

Re: Etherchannels Mode?

Edison, it may have to do with the version of code being run.

After all, I got th einformation regarding this broadcast loop from Cisco and anothe rsenior engineer on this forum...

Anyway, if it does shut down, thats good.

Hall of Fame Super Bronze

Re: Etherchannels Mode?

Hmm, that behavior is being there for ages in all switches:

http://www.cisco.com/en/US/tech/tk389/tk621/technologies_tech_note09186a00806cd87b.shtml

There are various reasons for the interface to go into errdisable. The reason can be:

*

Duplex mismatch

*

Port channel misconfiguration

*

BPDU guard violation

*

UniDirectional Link Detection (UDLD) condition

*

Late-collision detection

*

Link-flap detection

*

Security violation

*

Port Aggregation Protocol (PAgP) flap

*

Layer 2 Tunneling Protocol (L2TP) guard

*

DHCP snooping rate-limit

*

Incorrect GBIC / Small Form-Factor Pluggable (SFP) module or cable

*

Address Resolution Protocol (ARP) inspection

*

Inline power

Hall of Fame Super Bronze

Re: Etherchannels Mode?

BTW, I think you got the quote from this:

(same quote is actually in every channel-group documentation not just the 3560).

http://www.cisco.com/en/US/docs/switches/lan/catalyst3560/software/release/12.2_37_se/command/reference/cli1.html#wp1860162

You should use care when using the on mode. This is a manual configuration, and ports on both ends of the EtherChannel must have the same configuration. If the group is misconfigured, packet loss or spanning-tree loops can occur.

Notice that it says "if the group is misconfigured". It means if members of a port-channel are misconfigured (different speed and duplex on each interface), the configuration will still accept the mode on etherchanneling. It does not check for integrity from the members of the channel.

For instance,

interface f0/1

speed 10

duplex half

interface f0/2

speed 100

duplex full

Those interfaces above will form a bundle if configured with mode on.

If you use PAgP or LACP, there is some intelligence built-into the protocol to check for common values (like the ones from the above interfaces) and they won't form a bundle if they aren't the same.

That's what they are trying to say in this document.

Blue

Re: Etherchannels Mode?

Fair enough. Sounds reasonable. Thanks for that clarification.

Now go answer the question I asked you in the 'ip subnet vs broadcast domain' thread. :-)

416
Views
0
Helpful
10
Replies
CreatePlease to create content