Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Etherchannnel with NIC team issue

Hi,

 

I am having difficulty implementing what should be an easy task.

 

I have a single ESXi 6.5U1 host with 2 NICs teamed in a single vSwitch. The load balancing is set to “route based on IP hash”. As part of my troubleshooting I have also disabled beacon probing (Net.MaxBeaconsAtOnce=0).

 

The NIC team connects to a single Cisco 2960 switch. Both interfaces are up and the host is reachable.

 

To avoid Mac flapping on the switch (due to the NIC teaming), I am trying to configure an Etherchannel on the switch. My config below (both switch ports are configured identically):

 

interface GigabitEthernet0/6

switchport trunk native vlan 1000

switchport mode trunk

channel-group 2 mode on

end

 

interface GigabitEthernet0/7

switchport trunk native vlan 1000

switchport mode trunk

channel-group 2 mode on

end

 

interface Port-channel2

switchport trunk native vlan 1000

switchport mode trunk

end

 

EtherChannel Load-Balancing Configuration:

        src-dst-ip

 

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
2 Po2(SU) - Gi0/6(P) Gi0/7(P)

 

The post channel comes up on the switch but the ESXi host is not reachable. As soon as I shut one of the ports, the comms is restored. I can’t figure out what I am doing wrong – any ideas?

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Etherchannnel with NIC team issue

Got it sorted. 
Facepalm.
The load balance algorithm set on the vSwitch does not propagate to the management network.
https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1022751

Thanks for confirming my etherchannel config on the switch is correct and guiding me to look on the ESXi side!

15 REPLIES
Silver

Re: Etherchannnel with NIC team issue

I would recommend rechecking your ESXi network settings :)
You might have missed something. Check if your team has the correct adapters as members

Additionally, your members SHOULD not have any vSwitch configured on one of them. Take note that your vSwitch should now be on the port-group defining your NIC team
New Member

Re: Etherchannnel with NIC team issue

Thanks, I have attached my server side config - I can't see anything wrong :(

Note that for these sreenshots, I have removed the Etherchannel on the switch to indicate that the correct interfaces form part of the NIC team (remember that with the Etherchannel configured, I can only reach the ESXi host if I shut one interface on the Cisco switch).

Can you spot anythign issue here? Thanks again    

VIP Purple

Re: Etherchannnel with NIC team issue

Hi

sounds like something is off on the server side , your switch config is correct cehck this guide may help you

 

https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1004048

New Member

Re: Etherchannnel with NIC team issue

Thanks - I have added my server config above (can't spot the problem unfortunately).

 

I have worked through the article you posted already and I have configured my environment as close as possible to this guide ... still no luck however.    

VIP Purple

Re: Etherchannnel with NIC team issue

have you tried LACP instead as an option see if its having an issue being forced on

New Member

Re: Etherchannnel with NIC team issue

Yes, with LACP (mode access) the the Etherchannel does not come up at all. I believe this might be because I am using a vSwitch - not a distributed switch (not an option in my environment). 

VIP Purple

Re: Etherchannnel with NIC team issue

Ok Cool so no lacp , says in the video too do not use beacon with ip hash load balancing looks like thats setup on your screenshots ? maybe im wrong im not a server guy
New Member

Re: Etherchannnel with NIC team issue

Yeah beacon probing is disabled - screenshot attached 

VIP Purple

Re: Etherchannnel with NIC team issue

rest of it looks spot on watching the video for server side , yours matches their config too
did you try without the native vlan just in case as a test incase if its the cause , try standard trunk
New Member

Re: Etherchannnel with NIC team issue

Thanks Mark - I tried that (no native vlan defined) but with the same result - no comms to the host.  

New Member

Re: Etherchannnel with NIC team issue

Got it sorted. 
Facepalm.
The load balance algorithm set on the vSwitch does not propagate to the management network.
https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1022751

Thanks for confirming my etherchannel config on the switch is correct and guiding me to look on the ESXi side!

Silver

Re: Etherchannnel with NIC team issue

Told ya it's on your ESXi ;)
VIP Purple

Re: Etherchannnel with NIC team issue

ah good stuff
VIP Purple

Re: Etherchannnel with NIC team issue

If your able to , mark your post as answered as it will help other people find it if there run into the same issue , its not allowing me mark your post above as answered
New Member

Re: Etherchannnel with NIC team issue

Will do. Thanks again for taking the time to help!

251
Views
15
Helpful
15
Replies
CreatePlease to create content