Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

EtherSwitch Problem

I have a lab setup where I have a 3845 router with a 4-port POE HWIC. I have a problem getting a phone to trunk to its pc port. I've tried a 7911 and 7961 IP phone. I assigh a voice vlan and an access vlan to the same port and it doesn't work at all. I read some documentation saying I had to configure the port as a trunk so I tried that and the voice vlan worked but the data vlan didnt pass through to the pc port. I hooked up a 2960 to the router and used the same commands and got the data and voice vlans working. Is this a bug with the EtherSwitch models? Does anyone know of a workaround?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: EtherSwitch Problem

Hi

can u try by configuring the data vlan as the native vlan on that port.

Thanks

Mahmood

4 REPLIES

Re: EtherSwitch Problem

Hi

can u try by configuring the data vlan as the native vlan on that port.

Thanks

Mahmood

New Member

Re: EtherSwitch Problem

did you get this working?

Hall of Fame Super Silver

Re: EtherSwitch Problem

Hello Brian,

etherswitch modules support pre-standard Cisco proprietary PoE.

when connected to the etherswitch port was the phone powered on correctly via PoE ?

when adding the trunk have you allowed on the trunk the voice and data vlan ?

I would try this:

int fasx/0

switchport

switchport trunk enc dot1q

switchport trunk allowed vlan 10,20

switchport mode trunk

switchport voice vlan 20

Hope to help

Giuseppe

Re: EtherSwitch Problem

The phones powered correctly via the PoE. Setting the native vlan to be the data vlan is what fixed the problem. Thanks alot guys!

154
Views
5
Helpful
4
Replies