Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Extended the LAN

I have four L3 switches in two different location.

One Location

Switch1-Active

interface Vlan10

ip address 10.140.49.5 255.255.255.0

standby priority 110

standby 1 ip 10.140.49.4

standby 1 preempt

Switch1-Standaby

interface Vlan10

ip address 10.140.49.6 255.255.255.0

standby 1 ip 10.140.49.4

standby 1 preempt

----------------------------------------

Other Location

interface Vlan10

ip address 10.140.49.6 255.255.255.0

standby priority 110

standby 1 ip 10.140.49.1

standby 1 preempt

Switch1-Standaby

interface Vlan10

ip address 10.140.49.7 255.255.255.0

standby 1 ip 10.140.49.1

standby 1 preempt

I want to connect two location with trunking but i donot want any L3 config because my customer do not want to breake the broadcast domain.

1 REPLY

Re: Extended the LAN

Hi Anthony,

As far as I understand, you want to have 4 HSRP routers in the same VLAN, VLAN 10, to be in the same broadcast domain, and do load-balancing between a pair of routers.

First of all I have to tell you, that according to the Enterprise Composite Network Model, Cisco does not recommend to have so called end-to-end VLANs (that span across the distribution and core layers), because of difficulties in troubleshooting and manageability.

But if you want to build your network this way, you can use the following configs (this is just one of the possibilities):

One location:

Switch1-active:

interface vlan10

ip address 10.140.49.5 255.255.255.0

standby 1 priority 110

standby 1 ip 10.140.49.4

standby 1 preempt delay minimum 30 reload 30

! the delay is needed so the router has time to build up its routing table after reload.

Switch1-standby:

interface vlan10

ip address 10.140.49.6 255.255.255.0

standby 1 ip 10.140.49.4

The other location:

Switch1-active:

interface vlan10

ip address 10.140.49.8 255.255.255.0

standby 2 priority 110

standby 2 ip 10.140.49.1

standby 2 preempt delay minimum 30 reload 30

Swtich1-standby:

interface vlan10

ip address 10.140.49.7 255.255.255.0

standby 2 ip 10.140.49.1

This configuration will separate traffic between the 2 active HSRP routers. Of course, you need to configure the default-gateway addresses in the hosts accordingly:

Host in one building have to use 10.140.49.4 for default gateway, hosts in the other building have to use 10.140.49.1 for default gateway.

Cheers: Istvan

238
Views
0
Helpful
1
Replies