Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Extension of Vlan (subnet) over layer 3

My company has 2 building in same campus.Before we have single VTP domain -common vlan enviroment.we have trunk connectivity between distribution switches of Bldg1 and Bldg2.

Now we are going to bulid saperate VTP domians for Bldg1 and bldg2 -switching enviroment for both buildings. Only layer 3 connectivity.

Issue is we have voice server in vlan X at bldg1 and some voice server in same vlan X at bldg 2.

voice servers are criticle and I can not migrate them,So I have to extend the same vlan (subnet) over layer 3.

I have found one soln. LAM-Local Area Mobility.Can it work for my issue? if yes Is there any overhead of LAM as this vlan x has criticle voice servers.

Is there any other solution?

9 REPLIES
Blue

Re: Extension of Vlan (subnet) over layer 3

Sanket:

I was in a similar situation once with one of my clients and I resolved it by using a Metro Ethernet connection between 2 layer 3 switches, in which I passed routing updates between the two over a dot1q trunk.

I had a 3560 on one end and a 4506 on the other end. Both layer 3 enabled.

3560 Config:

vlan 2

Server_Vlan

vlan 21

Layer_3_peers

interface GigabitEthernet0/1

description Connection to TLS

switchport access vlan 21

switchport trunk encapsulation dot1q

switchport trunk native vlan 21

switchport mode trunk

load-interval 60

interface Vlan21

description Connection to TLS

ip address 172.16.200.5 255.255.255.248

no ip redirects

no ip unreachables

no ip proxy-arp

!

router eigrp 200

network 172.16.200.0 0.0.0.255

no auto-summary

4506 switch:

vlan 2

Server_Vlan

vlan 21

Layer_3_peers

interface GigabitEthernet2/1

speed 1000

duplex full

switchport access vlan 21

switchport trunk encapsulation dot1q

switchport trunk native vlan 21

switchport mode trunk

spanning-tree guard loop

interface Vlan21

description TLS WAN vlan

ip address 172.16.200.1 255.255.255.252

router eigrp 200

network 172.16.200.0 0.0.0.255

no auto-summary

=============================================

Vlan 21 was the vlan created for the layer 3 routed connections.

This set up allowed me to extend vlan 2 across the dot1q trunk, while still exchanging routes over it. Strange, I know!

HTH

If so, please rate my post

Victor

New Member

Re: Extension of Vlan (subnet) over layer 3

Thanks a lot Victor,

How can I control that only vlan2 would be expanded.Hows can Vlan 2 know that it is expanded as in config on trunk port there is no commnad perticuler to vlan2.

I would appreciate if you provide some details.

Blue

Re: Extension of Vlan (subnet) over layer 3

Sanket:

If you dont specify exactly which vlans to allow on the trunk, traffic from all vlans will be allowed by default. Otherwise, you would use the switchport trunk vlan allowed 2,21 command under the trunk interface.

HTH

Victor

New Member

Re: Extension of Vlan (subnet) over layer 3

It looks like you're trying to extend l2 across. If you have an mpls core, then AToMPLS, or Ethernet over MPLS would do the trick. If you not, l2tp would do it.

New Member

Re: Extension of Vlan (subnet) over layer 3

Can it impact voice traffic??As this subnet has voice servers.

Thanks

New Member

Re: Extension of Vlan (subnet) over layer 3

You mean, you have multiple CM arranged in a cluster across this extension? It should not as long as you're within the 40ms intercluster delay spec.

New Member

Re: Extension of Vlan (subnet) over layer 3

I am not sure what exactly..but a simple trunking done on the switch should do.

New Member

Re: Extension of Vlan (subnet) over layer 3

we have call centre so we have some application and monitring servers.I think l2tp will work in my case.

thanks

2319
Views
4
Helpful
9
Replies
CreatePlease login to create content