Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Facing issue in "Show ip route" command in GNS3

Dear Support Engineers,

I am new in cisco field, i make a simple topology and below is the configuratons:

R1#show ip int brief

Interface                  IP-Address      OK? Method Status                Protocol

Serial1/0                  12.1.1.1          YES manual up                    up

Serial1/1                  13.1.1.1           YES manual up                    up

Loopback0               1.1.1.1             YES manual up                    up

R1#show ip route

Gateway of last resort is not set

 

C    1.0.0.0/8 is directly connected, Loopback0

     12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C       12.0.0.0/8 is directly connected, Serial1/0

C       12.1.1.2/32 is directly connected, Serial1/0

     13.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C       13.0.0.0/8 is directly connected, Serial1/1

C       13.1.1.3/32 is directly connected, Serial1/1

This output is confusing for me, it is veriably subnetted. I search alot on google to get the solution but failed, now looking forward to you.

I want this result as:

R1#show ip route

Gateway of last resort is not set

C    1.0.0.0/8 is directly connected, Loopback0

C       12.0.0.0/8 is directly connected, Serial1/0

C       13.0.0.0/8 is directly connected, Serial1/1

Your quick response will be very appreciated.

Thanks & Best Regards

Tayyab Arif

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions

Facing issue in "Show ip route" command in GNS3

When you're using ppp encapsulation, the default is to use a peer route which is where you see your /32. On your serial interface, enter "no peer neighbor-route", shut and no shut your interface and the /32 should be gone.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
7 REPLIES

Facing issue in "Show ip route" command in GNS3

The IP addresses on the Serial Interfaces are Class A so have a default subnet mask of 255.0.0.0 which is a /8 which is shown in the Routing Table.

If you do a #show ip route connected you should just see the connected routes:

C   1.1.1.1/32  is directly connected, Loopback0

C   12.1.1.0/30  is directly connected, Serial0/3/0

C   13.1.1.0/30  is directly connected, Serial0/3/1

Thanks

New Member

Facing issue in "Show ip route" command in GNS3

Dear Davils,

I find the same issue again, result is mentioned below

R1#show ip route connected

C    1.0.0.0/8 is directly connected, Loopback0

     12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C       12.0.0.0/8 is directly connected, Serial1/0

C       12.1.1.2/32 is directly connected, Serial1/0

     13.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C       13.0.0.0/8 is directly connected, Serial1/1

C       13.1.1.3/32 is directly connected, Serial1/1

Hall of Fame Super Blue

Facing issue in "Show ip route" command in GNS3

Can you post the full config of R1 ?

Jon

New Member

Facing issue in "Show ip route" command in GNS3

Kindly find the configurations

R1#show running-config

Building configuration...

Current configuration : 1189 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R1

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

memory-size iomem 5

ip subnet-zero

no ip icmp rate-limit unreachable

ip cef

ip tcp synwait-time 5

!

!

!

!

no ip domain lookup

!

!

!

!

!

!

!

!

!

interface Loopback0

ip address 1.1.1.1 255.0.0.0

!

interface Serial1/0

ip address 12.1.1.1 255.0.0.0

encapsulation ppp

serial restart-delay 0

clock rate 64000

!

interface Serial1/1

ip address 13.1.1.1 255.0.0.0

encapsulation ppp

serial restart-delay 0

clock rate 64000

!

ip classless

!

no ip http server

no ip http secure-server

!

!

!

control-plane

!

!

!

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

exec-timeout 0 0

privilege level 15

logging synchronous

line vty 0 4

login

!

!

end

Hall of Fame Super Blue

Facing issue in "Show ip route" command in GNS3

Tayyab

John is spot on. Could you mark the answer provided by John as correct so others who may have the same issue will be able to find the answer here.

Jon

Facing issue in "Show ip route" command in GNS3

When you're using ppp encapsulation, the default is to use a peer route which is where you see your /32. On your serial interface, enter "no peer neighbor-route", shut and no shut your interface and the /32 should be gone.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Facing issue in "Show ip route" command in GNS3

Issue solved.

Thanks John Blakley....!

3075
Views
0
Helpful
7
Replies