Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Fiber connection between c4503 and c2960x not working

I just tried to establish a fiber connection between a c4503 and a c2960x using glc-lh-sm modules on both sides, but with no success.

Link comes up on the c2960x but not on the c4503.

I tried "speed nonegotiate" on both sides: link comes up on both sides, but no data received on both sides.

A connection between a c2960-24LC-S and the c2960X-24PD-L works fine, as does a connection between the c2960-24LC-S and the c4503.

All on the same ports and modules and also different ports an modules per switch.

Any suggestions on why a connection between the c4503 and the c2960X doesn't work?

23 REPLIES
VIP Super Bronze

Fiber connection between c4503 and c2960x not working

According to the data sheet the c2960X-24PD-L need SFP+ (10Gig)

see table-21 in this link:

http://www.cisco.com/en/US/prod/collateral/switches/ps5718/ps12995/data_sheet_c78-728232.html

HTH

New Member

Re: Fiber connection between c4503 and c2960x not working

Thank you for your reply, but indeed the 2960x is capable of using 1G SFPs. SFP+ ports can be used both with 1G SFPs and 10G SFP+ modules.

1G connection over single mode fiber with GLC-LH-SM works between two 2960x or a 2960x and an older 2960 or the 2960 and the 4503, but _not_between the 2960x and the 4503.

Currently I have to use a work-around: Instead of the direct fiber connection between the 4503 and the 2960x, I have 4503 connected over 1000base-T to another 2960x and then with 1000base-LH to the remote 2960x.

New Member

Re: Fiber connection between c4503 and c2960x not working

When you say it's not coming up - is it disabling it or just staying notconnect?

Does it recognize that you inserted a GBIC?

Any logs happening on either switch when you plug it in?

New Member

Re: Fiber connection between c4503 and c2960x not working

Mixing tx and rx was the first I tried :) As changing patch fibers and fiber modules :)

> When you say it's not coming up - is it disabling it or just staying notconnect?

The 2960x logs an int-up event. The 4503 reports nothing. Just like there's nothing connected.
Unless i set 'speed nonegotiate'. Then both sides report int-up, but no data is received on both sides, receive counter stay at zero while send counters increase.

> Does it recognize that you inserted a GBIC?

Yes these are Cisco GLC-LH-SM SFPs. 'show idprom' and logs look fine. Also these SFPs work if I connect a old 2960 and the 4505.

Just not with the new 2960x and the 4505.

I guess the 4503 supervisor module or it's IOS is just to old, but it's phased out in the next months anyway, so thank you all for your ideas.
I will just have to use my above mentioned work around.

Regards,
Bernd

New Member

Re: Fiber connection between c4503 and c2960x not working

Having the exact same issue between our new 2960Xs and a 4507R in one building and a 6509 in another location... 2960X gets a connection light, 4507 and 6509 show 'notconnect'.

The existing 2960G 48 port edge switches with 1Gb SFP modules work fine. We've got the same config on the new and old switches, tried the new Cisco SFP modules we got as well as the old ones, etc. 2960X to 2960G over fiber works perfectly (which is our work-around for now). I even tried a 1M fiber patch cable from the 4507R to a 2960X direct and got no connection on the 4507R unless I set nonegotiate, but as above no data is received.

4507R has older 1Gb gbics while the 6509 has newer 1Gb SFPs. 4507R is running the latest version of ios 15 it can, while the 6509 has a version of 12 that is a couple of years old. It's really bizarre... the only common factor I can find is the 2960Xs themselves. I have a TAC case in, but no luck yet.



Sent from Cisco Technical Support iPhone App

Hall of Fame Super Gold

Fiber connection between c4503 and c2960x not working

You guys are doing this right.  I have a warm fuzzy feeling this is an IOS bug with the 2960X.

New Member

Fiber connection between c4503 and c2960x not working

We have  the same issue between  Cat 6509 1000BASE-SX GBIC (shows  notconnected) and 2960X GLC-SX-MM SFP (shows connected) 

If anyone at Cisco is looking  at this issue?

thanks,

Andrei

New Member

Re: Fiber connection between c4503 and c2960x not working

Has anyone found a solution for this issue?  I'm having the same problem between a new 2960-X stack and a 4503 Switch.  I have tried the newer 1000LX SFP's and the older ones too (all Cisco Branded) and they link in on the 2960-X side but not at all on the 4503 side. 

VIP Super Bronze

Re: Fiber connection between c4503 and c2960x not working

Can you try swapping the strands on one side and test again?
You maybe connecting tx to tx instead of tx to rx

HTH

Sent from Cisco Technical Support iPhone App

Cisco Employee

Re: Fiber connection between c4503 and c2960x not working

Hello,

Has anyone opened a tac case on this yet? If not, I would recommend doing so.  Thanks

nevermind, I see Mark did above.

New Member

Re: Fiber connection between c4503 and c2960x not working

Just an update for anyone watching...

Had a remote session with a support rep and we tried a few different connections so he could see what I described above. I setup a couple of test uplinks on the 6509 (since I was in that building) with new-->new SFP, old-->old SFP and new-->old SFP to a 2960X and had the same connection issues. I'm working on scheduling another session to see if they've come up with anything new.

Just for kicks I'm going to try the new EX3 release (even though it makes no mention of my issue) and a single-mode uplink this afternoon.

New Member

Fiber connection between c4503 and c2960x not working

I already tried the EX3 release myself and it didn't change anything.  For now I'm using a 2960-CG switch as an expensive media converter to link a 4503 Copper Gig port to the fiber going to the 2960-X switch fiber port (using the 1000-LH-SMD SFP's.  This is working but is a waste of a full switch for 2 ports.  I'm thinking of trying a standard 1000LX media converter in place of the 2960-CG but I don't have one in stock and am not sure if that will even work. 

Jim

New Member

Fiber connection between c4503 and c2960x not working

I was able to get the LX/single mode connection between the 6509 and the 2960X up for a bit until I swapped ports while testing, lost the connection and couldn't get it back up. This happened on two ports: worked and then stopped. EX3 didn't help here either, but I didn't expect anything based on the release notes.

Anyway, here's the problem: no one tested connecting the 2960X to various modular switch line cards (or such basic functionality wasn't considered a priority). Once the support rep suggested we try the uplinks on the supervisors, it immediately worked. I have dual 1G 720s on the 6509, so four out of five of our data closets are now successfully uplinked directly between that and the 2960Xs. I have to try the same with the 4507R this afternoon, but I'm expecting (or hoping for, rather) similar results.

The TAC rep suggested we might have a working ios release in 6-8 months...

New Member

Fiber connection between c4503 and c2960x not working

We are seeing the same issue between 2960X switches and 6506-E's using WS-X6724-SFP and WS-X6516-GBIC cards.  (But not between the 2960X and 2960G's.)

For the SFP's we've tried various combinations of GLC-SX-MM=, GLC-LH-SM=, GLC-SX-MMD, and GLC-LH-SMD on either side.

We haven't tried connecting the 2960X to the ports on the supervisor yet.  We're also planning to try various other combinations of 3rd party SFP's and other Cisco and 3rd party switches.

We also have a TAC case open that hasn't gotten much useful back yet.

New Member

Re: Fiber connection between c4503 and c2960x not working

Same problem here

1) 2960X (GLC-SX-MM-C) to Sup2T/6509E/6848 -> 2960X shows up/up, 6509 down/down

2) 2960X (GLC-SX-MM-C) to 2960X (GLC-SX-MMD) -> both ports up CDP Nei shows the switch

3) Upgrade Software from EX1 to EX3 -> same behaviour

Switch#show version | incl EX3

Cisco IOS Software, C2960X Software (C2960X-UNIVERSALK9-M), Version 15.0(2)EX3, RELEASE SOFTWARE (fc1)

System image file is "flash:/c2960x-universalk9-mz.150-2.EX3.bin"

*    1 52    WS-C2960X-48FPD-L  15.0(2)EX3            C2960X-UNIVERSALK9-M    

Switch#

Switch#show int gi1/0/50 capabilities

GigabitEthernet1/0/50

  Model:                 WS-C2960X-48FPD-L

  Type:                  1000BaseSX SFP

  Speed:                 1000

  Duplex:                full

  Trunk encap. type:     802.1Q

  Trunk mode:            on,off,desirable,nonegotiate

  Channel:               yes

  Broadcast suppression: percentage(0-100)

  Flowcontrol:           rx-(off,on,desired),tx-(none)

  Fast Start:            yes

  QoS scheduling:        rx-(not configurable on per port basis),

                         tx-(4q3t) (3t: Two configurable values and one fixed.)

  CoS rewrite:           yes

  ToS rewrite:           yes

  UDLD:                  yes

  Inline power:          no

  SPAN:                  source/destination

  PortSecure:            yes

  Dot1x:                 yes

Switch#

Switch#show idprom interface gi1/0/50

General SFP Information

-----------------------------------------------

Identifier            :   0x03

Connector             :   0x07

Transceiver           :   0x00 0x00 0x00 0x01 0x20 0x40 0x0C 0x00

Encoding              :   0x01

BR_Nominal            :   0x0D

Vendor Name           :   CISCO-PROLABS  

Vendor Part Number    :   GLC-SX-MM-C    

Vendor Revision       :   0x20 0x20 0x20 0x20

Vendor Serial Number  :   P1A24111       

-----------------------------------------------

Didn't open TAC case yet

New Member

Re: Fiber connection between c4503 and c2960x not working

Hi all,

I've got the same problem.

Bug: CSCuj70291

1 gig uplink on WS-C2960X-48LPD-L does not link up with 4306, 4448-GB

Symptom:

Uplink port with glc-sx-mm,glc-lh-sm not coming up between WS-C2960X-48LPD-L and any catalyst 4500 with WS-X4448-GB-SFP and WS-X4306-GB. When speed no negotiate is enabled, link comes up, but no traffic.

This is observed with catalyst 6500 line cards as well.

Conditions:

Uplink port with glc-sx-mm,glc-lh-sm not coming up between WS-C2960X-48LPD-L and any catalyst 4500 with WS-X4448-GB-SFP and WS-X4306-GB

Workaround:

None

Bug-fix will be release on 18th of Nov.

Regards, Alfred

Hall of Fame Super Gold

Fiber connection between c4503 and c2960x not working

I can't believe this bug!

I can see the 2960 BU is doing a "bang up" job in Quality Control. 

New Member

Re: Fiber connection between c4503 and c2960x not working

Same issue here. Link does not come up.

Side A

WS-C4506 (WS-X4306-GB linecard with 1000BaseSX GBIC)

Side B

Cisco Catalyst 2960X-48FPS-L* (GLC-SX-MM SFP)

All GBIC/SFP/Linecard Ports were replaces with no effekt. If we configure "speed nonegotiate" then we can see the LED turns green and  link shows connected but traffic counters remain zero.

I can assure you that there are no issues with the cabling or SFP moduels, if we replace the 2960x with a 2960s (same config) the link works like a charm!

It looks like this issue is not fixed in EX3, at least not on the WS-C2960X-48FPS-L plattform!

*

Cisco IOS Software, C2960X Software (C2960X-UNIVERSALK9-M), Version 15.0(2)EX3,

RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2013 by Cisco Systems, Inc.

Compiled Wed 11-Sep-13 02:04 by prod_rel_team

ROM: Bootstrap program is C2960X boot loader

BOOTLDR: C2960X Boot Loader (C2960X-HBOOT-M) Version 15.0(2r)EX, RELEASE SOFTWAR

E (fc1)

AS.... uptime is 23 hours, 33 minutes

System returned to ROM by power-on

System restarted at 12:33:41 MEST Tue Nov 12 2013

System image file is "flash:c2960x-universalk9-mz.150-2.EX3.bin"

New Member

Re: Fiber connection between c4503 and c2960x not working

Hi all,

bug CSCuj70291

Solution provided with EX4 (for C2960X)

Release date 18.11.2013

Regards, Alfred

New Member

Re: Fiber connection between c4503 and c2960x not working

Correction:

bug CSCuj70291

Solution will be provided with EX4 (for C2960X)

Planned release date 18.11.2013

Regards, Alfred

New Member

Fiber connection between c4503 and c2960x not working

hmm can't find the bug CSCuj70291 in the EX4 release note..

but this at least this one:

Caveats Resolved in Cisco IOS Release 15.0(2)EX4

CSCuj74167

Gigabit link from WS-C2960X-48FPD-L not coming up when using GLC-SX-MM.

There is no workaround.

New Member

Fiber connection between c4503 and c2960x not working

EX4 fixed it today for me.

A painful bug causing a lot of issues.

My main concern is that i suffered from painful bugs in the last 3-4 implementation of new cisco products.

There was no implementation without a Cisco TAC case

New Member

Fiber connection between c4503 and c2960x not working

Hi all,

exactelly, bug CSCuj74167 in the release notes is a duplicate of bug CSCuj7029.

Regards, Alfred
3325
Views
25
Helpful
23
Replies
CreatePlease login to create content